LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Error compiling KTorrent from source: No KDE Headers Installed (https://www.linuxquestions.org/questions/linux-software-2/error-compiling-ktorrent-from-source-no-kde-headers-installed-449911/)

JamesHall 05-30-2006 09:08 AM

Error compiling KTorrent from source: No KDE Headers Installed
 
Hi everyone,

Relative newbie using SUSE 10.0 OSS.

I've been having a lot of trouble with KTorrent crashing repeatedly during downloads. From searching the forums, it seems to be quite a common problem. Several people have advised removing the version of KTorrent provided by SUSE, and compiling it from source instead.

I've downloaded the source for KTorrent 1.2 from ktorrent.pwsp.net, but I've got a bit of a problem. When I run ./configure, I get the following error message:

Quote:

checking for KDE... configure: error:
in the prefix, you've chosen, are no KDE headers installed. This will fail.
So, check this please and use another prefix!
I don't know what to do about this because I don't understand what it means! Can someone explain this to me please? Any advice regarding what to do next would also be gratefully received.

Thanks

James.

bigrigdriver 05-30-2006 09:25 AM

In SuSE 9.3, the headers are in /opt/kde3/include (file names have the extension .h).

The error message is telling you that your .configure command is attempting to install in a directory which does not include the kde headers: something like '.configure --prefix=/usr'. Or, perhaps you are not specifying a prefix, and .configure is trying to use a default prefix which does not have the headers.

Try this. Check to see where SuSE 10.0 put the kde includes. Are they in /opt/kde3/include, as in 9.3? If so, change your .configure command to: .configure --prefix=/opt/kde3. See if it can find the headers that way.

JamesHall 05-31-2006 04:09 AM

bigrigdriver,

Thanks for the advice. The only .h files in /opt/kde3/include on my machine relate to k3b. I tried ./configure --prefix=/opt/kde3/include anyway, and unsurprisingly got the same error message again. Could you tell me the full names of some of the KDE header files, so that I can try to find them on my system?

Like I said, relatively new at this...

Thanks

James.

JamesHall 05-31-2006 04:38 AM

Incidentally, I don't know whether this is relevant or not, but I don't have any of the devel packages for KDE installed (kdebase3-devel, kdelibs3-devel etc.)

Do I need to install these packages? If so, which ones?

Thanks

J.

TheBrick 05-31-2006 04:41 AM

Hello. I am also running suse 10.0 and found that kde headers where not installed as default. Try going to yast2 and in softwear looking for kde development or something similar and you should find the header files. Install them and try again checking where they have been installed.

T

JamesHall 06-01-2006 03:35 AM

All done.

I installed kdebase3-devel and kdelibs3-devel, which caused quite a few other packages to be installed to resolve dependencies, and upgraded libxslt from 1.1.14-3 to 1.1.15.2 (from the guru repository). Everything installed OK, the KDE headers went to /opt/kde3/include, and KTorrent configured, compiled and installed correctly.

Thanks for the help guys!

James.


All times are GMT -5. The time now is 01:58 AM.