LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-17-2012, 03:03 PM   #1
kiran.ursal
Member
 
Registered: Feb 2012
Posts: 36

Rep: Reputation: Disabled
Post erro while installing software


I have Installed my RHEL5 before two or three days. After that whenever I try to software on it it gives me error.
examples :When I try to install Open office that time it gives error as follws:

Error resolving dependancies
unableto resolve the dependancies for some packages selected for installation.

detail:
Missing Dependency: ooobasis3.1-writer is needed by package ooobasis3.1-binfilter-3.1.0-9399.i586 (/root/Desktop/OpenOffice/OOo_3.1.0_LinuxIntel_install_wJRE_en-US.tar(2)_FILES/OOO310_m11_native_packed-2_en-US.9399/rpms/ooobasis3.1-binfilter-3.1.0-9399.i586.rpm)
Missing Dependency: ooobasis3.1-math is needed by package ooobasis3.1-binfilter-3.1.0-9399.i586 (/root/Desktop/OpenOffice/OOo_3.1.0_LinuxIntel_install_wJRE_en-US.tar(2)_FILES/OOO310_m11_native_packed-2_en-US.9399/rpms/ooobasis3.1-binfilter-3.1.0-9399.i586.rpm)
Missing Dependency: ooobasis3.1-core01 is needed by package ooobasis3.1-core03-3.1.0-9399.i586 (/root/Desktop/OpenOffice/OOo_3.1.0_LinuxIntel_install_wJRE_en-US.tar(2)_FILES/OOO310_m11_native_packed-2_en-US.9399/rpms/ooobasis3.1-core03-3.1.0-9399.i586.rpm)
Missing Dependency: ooobasis3.1-impress is needed by package ooobasis3.1-binfilter-3.1.0-9399.i586 (/root/Desktop/OpenOffice/OOo_3.1.0_LinuxIntel_install_wJRE_en-US.tar(2)_FILES/OOO310_m11_native_packed-2_en-US.9399/rpms/ooobasis3.1-binfilter-3.1.0-9399.i586.rpm)
Missing Dependency: ooobasis3.1-en-US-calc is needed by package openoffice.org3-en-US-3.1.0-9399.i586 (/root/Desktop/OpenOffice/OOo_3.1.0_LinuxIntel_install_wJRE_en-US.tar(2)_FILES/OOO310_m11_native_packed-2_en-US.9399/rpms/openoffice.org3-en-US-3.1.0-9399.i586.rpm)
Missing Dependency: ooobasis3.1-core01 is needed by package ooobasis3.1-testtool-3.1.0-9399.i586 (/root/Desktop/OpenOffice/OOo_3.1.0_LinuxIntel_install_wJRE_en-US.tar(2)_FILES/OOO310_m11_native_packed-2_en-US.9399/rpms/ooobasis3.1-testtool-3.1.0-9399.i586.rpm)
Missing Dependency: openoffice.org3 is needed by package openoffice.org3-en-US-3.1.0-9399.i586 (/root/Desktop/OpenOffice/OOo_3.1.0_LinuxIntel_install_wJRE_en-US.tar(2)_FILES/OOO310_m11_native_packed-2_en-US.9399/rpms/openoffice.org3-en-US-3.1.0-9399.i586.rpm)
Missing Dependency: ooobasis3.1-en-US-help is needed by package openoffice.org3-en-US-3.1.0-9399.i586 (/root/Desktop/OpenOffice/OOo_3.1.0_LinuxIntel_install_wJRE_en-US.tar(2)_FILES/OOO310_m11_native_packed-2_en-US.9399/rpms/openoffice.org3-en-US-3.1.0-9399.i586.rpm)
Missing Dependency: ooobasis3.1-en-US-math is needed by package openoffice.org3-en-US-3.1.0-9399.i586 (/root/Desktop/OpenOffice/OOo_3.1.0_LinuxIntel_install_wJRE_en-US.tar(2)_FILES/OOO310_m11_native_packed-2_en-US.9399/rpms/openoffice.org3-en-US-3.1.0-9399.i586.rpm)
Missing Dependency: ooobasis3.1-en-US-base is needed by package openoffice.org3-en-US-3.1.0-9399.i586 (/root/Desktop/OpenOffice/OOo_3.1.0_LinuxIntel_install_wJRE_en-US.tar(2)_FILES/OOO310_m11_native_packed-2_en-US.9399/rpms/openoffice.org3-en-US-3.1.0-9399.i586.rpm)
Missing Dependency: ooobasis3.1-core01 is needed by package ooobasis3.1-onlineupdate-3.1.0-9399.i586 (/root/Desktop/OpenOffice/OOo_3.1.0_LinuxIntel_install_wJRE_en-US.tar(2)_FILES/OOO310_m11_native_packed-2_en-US.9399/rpms/ooobasis3.1-onlineupdate-3.1.0-9399.i586.rpm)
Missing Dependency: ooobasis3.1-en-US-draw is needed by package openoffice.org3-en-US-3.1.0-9399.i586 (/root/Desktop/OpenOffice/OOo_3.1.0_LinuxIntel_install_wJRE_en-US.tar(2)_FILES/OOO310_m11_native_packed-2_en-US.9399/rpms/openoffice.org3-en-US-3.1.0-9399.i586.rpm)
Missing Dependency: ooobasis3.1-core01 is needed by package ooobasis3.1-en-US-3.1.0-9399.i586 (/root/Desktop/OpenOffice/OOo_3.1.0_LinuxIntel_install_wJRE_en-US.tar(2)_FILES/OOO310_m11_native_packed-2_en-US.9399/rpms/ooobasis3.1-en-US-3.1.0-9399.i586.rpm)
Missing Dependency: ooobasis3.1-en-US-writer is needed by package openoffice.org3-en-US-3.1.0-9399.i586 (/root/Desktop/OpenOffice/OOo_3.1.0_LinuxIntel_install_wJRE_en-US.tar(2)_FILES/OOO310_m11_native_packed-2_en-US.9399/rpms/openoffice.org3-en-US-3.1.0-9399.i586.rpm)
Missing Dependency: ooobasis3.1-calc is needed by package ooobasis3.1-binfilter-3.1.0-9399.i586 (/root/Desktop/OpenOffice/OOo_3.1.0_LinuxIntel_install_wJRE_en-US.tar(2)_FILES/OOO310_m11_native_packed-2_en-US.9399/rpms/ooobasis3.1-binfilter-3.1.0-9399.i586.rpm)
Missing Dependency: ooobasis3.1-draw is needed by package ooobasis3.1-binfilter-3.1.0-9399.i586 (/root/Desktop/OpenOffice/OOo_3.1.0_LinuxIntel_install_wJRE_en-US.tar(2)_FILES/OOO310_m11_native_packed-2_en-US.9399/rpms/ooobasis3.1-binfilter-3.1.0-9399.i586.rpm)
Missing Dependency: openoffice.org3 is needed by package openoffice.org3-draw-3.1.0-9399.i586 (/root/Desktop/OpenOffice/OOo_3.1.0_LinuxIntel_install_wJRE_en-US.tar(2)_FILES/OOO310_m11_native_packed-2_en-US.9399/rpms/openoffice.org3-draw-3.1.0-9399.i586.rpm)
Missing Dependency: ooobasis3.1-core01 is needed by package ooobasis3.1-graphicfilter-3.1.0-9399.i586 (/root/Desktop/OpenOffice/OOo_3.1.0_LinuxIntel_install_wJRE_en-US.tar(2)_FILES/OOO310_m11_native_packed-2_en-US.9399/rpms/ooobasis3.1-graphicfilter-3.1.0-9399.i586.rpm)
Missing Dependency: ooobasis3.1-en-US-impress is needed by package openoffice.org3-en-US-3.1.0-9399.i586 (/root/Desktop/OpenOffice/OOo_3.1.0_LinuxIntel_install_wJRE_en-US.tar(2)_FILES/OOO310_m11_native_packed-2_en-US.9399/rpms/openoffice.org3-en-US-3.1.0-9399.i586.rpm)
Missing Dependency: ooobasis3.1-draw is needed by package openoffice.org3-draw-3.1.0-9399.i586 (/root/Desktop/OpenOffice/OOo_3.1.0_LinuxIntel_install_wJRE_en-US.tar(2)_FILES/OOO310_m11_native_packed-2_en-US.9399/rpms/openoffice.org3-draw-3.1.0-9399.i586.rpm)


what to do sir I dont know.
pleas help me
 
Old 03-17-2012, 05:31 PM   #2
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
@ Reply

Hi kiran.ursal,

Welcome to LQ!!!

Questions for you to begin with:

1. How you are trying to install Open Office using rpm or yum?
2. Is your system configured with RHN?
3. Do you have valid subscription with Redhat?

If you have not purchased RHEL then I would suggest that you better switch to CentOS. CentOS is freely available and is a rebuild of RHEL. With CentOS you will get updates and you can easily download/install the stuff they have in repository.
 
Old 03-19-2012, 06:13 AM   #3
kiran.ursal
Member
 
Registered: Feb 2012
Posts: 36

Original Poster
Rep: Reputation: Disabled
I am using yum methode to install open office
 
Old 03-19-2012, 08:06 AM   #4
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
@ Reply

From the output it does not appear that you are using yum. It appears to me as if you have executed the following command:

Code:
 rpm -ivh /root/Desktop/OpenOffice/OOo_3.1.0_LinuxIntel_install_wJRE_en-US.tar(2)_FILES/OOO310_m11_native_packed-2_en-US.9399/rpms/ooobasis3.1-binfilter-3.1.0-9399.i586.rpm
It is possible that you ran the same using yum install but that is not the way yum works.

You didn't answer my other queries. Do you have subscribtion with Redhat? Is your system configured with RHN?
 
Old 03-21-2012, 07:55 AM   #5
kiran.ursal
Member
 
Registered: Feb 2012
Posts: 36

Original Poster
Rep: Reputation: Disabled
Post

1)I am use yum install *; command to install softwares on command line.
2)Yes;my system is not configure with rhn.
3)No, I dont have valid subscription with Red hat
actually I am student.

I dont want to install other os on my computer other than RHEL,I dont have windows also beacause I love RHEL5 .
I want to solve this problem I want to learn to solve such problems.
I have very little information about RHEL5 but I want to learn this system so deep.


when I go on any web site to download any software for RHEL5 I am get confused which one is to download because it have so many options.
how to know which one is to download.

please help me.
 
Old 03-21-2012, 09:05 AM   #6
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
@ Reply

First of all you shouldn't be using RHEL if you have not purchased it. Second thing I have suggested you to use CentOS which is a rebuild of RHEL which means it is almost same as that of RHEL. Did you search on the internet about CentOS? If not, then search it.

Coming back to your initial query of problem installing the package I would say did you read my last post? I did mention that yum does not work the way you are trying to use.

If you really want to learn linux then dont just try random things like installing some xyz package from web. This will neither help you in learning nor it will do any good to your system.

I would suggest you to first learn the basics and then jump on to customization. We here at LQ does not promote the free / illegal use of a paid software. So first thing that you should be looking for is to install CentOS instead of RHEL. Once done you can search for basic linux tutorials on the web for starter. If you get stuck somewhere then we are here to help.
 
Old 03-21-2012, 09:56 AM   #7
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,190

Rep: Reputation: 6476Reputation: 6476Reputation: 6476Reputation: 6476Reputation: 6476Reputation: 6476Reputation: 6476Reputation: 6476Reputation: 6476Reputation: 6476Reputation: 6476
Quote:
Originally Posted by kiran.ursal View Post
1)I am use yum install *; command to install softwares on command line.
2)Yes;my system is not configure with rhn.
3)No, I dont have valid subscription with Red hat actually I am student.

I dont want to install other os on my computer other than RHEL,I dont have windows also beacause I love RHEL5. I want to solve this problem I want to learn to solve such problems. I have very little information about RHEL5 but I want to learn this system so deep.

when I go on any web site to download any software for RHEL5 I am get confused which one is to download because it have so many options. how to know which one is to download.
To answer your questions:
  1. That is the wrong syntax for using Yum
  2. If you're using RHEL and your system isn't registered with RedHat (i.e. paid for), yum won't work.
  3. If you are a student, then you should be aware of the student rates for RHEL
  4. If you want RHEL, but don't want to pay, load CentOS, which is 99.x% IDENTICAL to RHEL, but FREE
T3RM1NVT0R pointed these things out too, but another question I'd ask is WHY do you want RHEL??
 
Old 03-21-2012, 02:51 PM   #8
kiran.ursal
Member
 
Registered: Feb 2012
Posts: 36

Original Poster
Rep: Reputation: Disabled
Post

actually one of my friend have done Red hat certification he told me that this is one of the power full os I use this os since last two month and I feel its power thats why I use this os.


I heard that RHEL is open source and I think it is free thats why I use it even if their is any legal issues then I will ask for student copy of RHEL.


Thank you sir for this guidance
 
Old 03-21-2012, 02:57 PM   #9
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
@ Reply

As mentioned by TBone you can ask for a student copy but if you do not find one then you can simple use CentOS. From you post it appears that someone told you that if you are preparing for Redhat certifications then you should only use RHEL. Ofcourse you can if you want to spend money but if you don't want to spend money then you can simple use CentOS.

I hope this link will be an eye opener: http://en.wikipedia.org/wiki/CentOS

This clearly states that "CentOS is a free operating system distribution based upon the Linux kernel. It is derived entirely from the Red Hat Enterprise Linux (RHEL) distribution."

So it doesn't matter if you use RHEL or CentOS for practice both will serve the same purpose.
 
1 members found this post helpful.
Old 03-21-2012, 03:41 PM   #10
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,190

Rep: Reputation: 6476Reputation: 6476Reputation: 6476Reputation: 6476Reputation: 6476Reputation: 6476Reputation: 6476Reputation: 6476Reputation: 6476Reputation: 6476Reputation: 6476
Quote:
Originally Posted by kiran.ursal View Post
actually one of my friend have done Red hat certification he told me that this is one of the power full os I use this os since last two month and I feel its power thats why I use this os.
Then you can 'feel the power' of CentOS just as easily, since it's nearly identical. And bear in mind that pretty much ANY version of Linux can do the same things that RHEL can.
Quote:
I heard that RHEL is open source and I think it is free thats why I use it even if their is any legal issues then I will ask for student copy of RHEL.
Thank you sir for this guidance
It is open source; what you PAY FOR is access to the updates/patches/bugfixes, and online repositories, from which you can install software. Go to their website and read about it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
erro when trying to install pin07 Linux - Newbie 2 12-20-2007 11:00 AM
erro in mysql imyself Linux - Software 1 08-06-2006 08:18 AM
bash erro on Suse 9.3 linuxpie SUSE / openSUSE 1 08-31-2005 12:57 PM
Erro installing .tgz PsYlTrance Linux - Software 1 05-06-2004 11:00 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration