LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 06-27-2004, 10:11 PM   #1
jon_k
Member
 
Registered: Jul 2003
Location: Fort Worth, Texas
Distribution: Mepis Linux 2004
Posts: 547

Rep: Reputation: 30
Enable remote root login in /etc/securetty


How can I do this?

This is on a LAN only and it'd be convienent to have it enabled.

I don't know what to add in /etc/securetty in order to enable root logins though.

At this time the file is blank.

running rh fc1

What should I add? tty0 or something?

Thanks
 
Old 06-27-2004, 10:29 PM   #2
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 46
It is a very bad idea to let root login over the net, especially using telnet as the root password can be read off the wire as data is sent in clear-text.

run the following command on a separate terminal window while you connect using telnet.

#tcpdump -vvX host <host to which you are telnetting>

If you still want to go ahead, you can add pts/0 through pts/10.

A more secure solution would be to use ssh and it allows root logins too without the need to add anything to /etc/securetty.

#ssh <ip of system to connect tp> -l root

Last edited by ppuru; 06-27-2004 at 10:31 PM.
 
Old 06-27-2004, 10:34 PM   #3
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,850

Rep: Reputation: 350Reputation: 350Reputation: 350Reputation: 350
Again, it is important to note that only SSHv2 is secure, SSHv1 can be sniffed over the network just as easily as telnet, and, unfortunately, many SSH server packages default to SSHv1.
 
Old 07-03-2004, 01:50 AM   #4
jon_k
Member
 
Registered: Jul 2003
Location: Fort Worth, Texas
Distribution: Mepis Linux 2004
Posts: 547

Original Poster
Rep: Reputation: 30
Seems this hasn't worked.

I added pts0 - 10 in /etc/securetty

I still get

login as: root
Welcome to UBER-term! Please enter your password below, okay?
root@192.168.0.4's password:
Access denied
root@192.168.0.4's password:

I also tried

[root@localhost jon_k]# ssh 192.168.0.2 -l root
ssh: connect to host 192.168.0.2 port 22: Connection refused

192.168.0.2 is the box of my windows machine for which I desire to be able to log in to the linbox through root.


I know it's blindly insecure to do this, but as it being on a local home network isolated behind a firewall, I don't see this as an issue.

What do you think would prevent it from allowing remote logins? I'm sure it's some /etc/something or some file like that that needs 1 line edited. I know it wouldn't be some bizzare problem because by default it let me log in as root, then i secured it -- then I forgot how to "unsecure it"
heh

thanks

Last edited by jon_k; 07-03-2004 at 01:54 AM.
 
Old 07-03-2004, 02:08 AM   #5
jon_k
Member
 
Registered: Jul 2003
Location: Fort Worth, Texas
Distribution: Mepis Linux 2004
Posts: 547

Original Poster
Rep: Reputation: 30
Problem resolved, I found a file called

/etc/ssh/sshd_config

I changed permitrootlogin no

to yes, and it works now!
 
Old 03-16-2011, 11:52 PM   #6
dharmendrajet
LQ Newbie
 
Registered: May 2010
Location: gurgaon India
Distribution: Fedora, Cent os, RHEL, Ubuntu Server
Posts: 4

Rep: Reputation: 0
not able to remote login via ssh. permisson denied

hi ,

iam not able remote login , while yesterday i was able to login . when i do ssh my machine from other machine he asked for passord . after that it give erroe permisson denied . but i was able same password yesterday.. same issue was yesterday .

when i install fresh cent os 5.5 . after it work well till night. but next day morning . we are not able to remoe login .

plz help me
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to enable auto login for root in Redhat alix123 Programming 5 06-27-2007 12:43 AM
Fedora Core 3: How do I enable remote root login? xunil321 Fedora - Installation 2 09-16-2005 05:43 AM
Enable root login in wu-ftpd? Sevoma Linux - Software 5 02-04-2005 06:49 PM
enable root logon from remote client csps6789 Linux - Networking 2 04-29-2003 08:43 PM
Disable/Enable Root Login @ Console ryanstrayer Linux - Security 4 01-18-2002 04:49 PM


All times are GMT -5. The time now is 08:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration