LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-12-2005, 06:04 AM   #1
bleneak
LQ Newbie
 
Registered: Jul 2005
Posts: 2

Rep: Reputation: 0
emerging xawtv


Hello,
when emerging xawtv, I get the following errors while linking:

console/fs.o(.text+0x371): In function `fs_open':
: undefined reference to `FSListFonts'
console/fs.o(.text+0x3e2): In function `fs_open':
: undefined reference to `FSOpenBitmapFont'
console/fs.o(.text+0x3ef): In function `fs_open':
: undefined reference to `FSFreeFontNames'
console/fs.o(.text+0x434): In function `fs_open':
: undefined reference to `FSQueryXInfo'
console/fs.o(.text+0x46d): In function `fs_open':
: undefined reference to `FSQueryXExtents16'
console/fs.o(.text+0x4b3): In function `fs_open':
: undefined reference to `FSQueryXBitmaps16'
console/fs.o(.text+0xbec): In function `fs_connect':
: undefined reference to `FSOpenServer'
console/fs.o(.text+0xc08): In function `fs_connect':
: undefined reference to `FSServerName'
console/fs.o(.text+0xc41): In function `fs_connect':
: undefined reference to `FSServerName'
collect2: ld returned 1 exit status

make: *** [console/fbtv] Error 1!!! ERROR: media-tv/xawtv-3.86-r2 failed.
!!! Function src_compile, Line 55, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.





(the errors i posted above are the topmost and only errors.)
here is my emerge info output:

Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.3.5, glibc-2.3.4.20040808-r1, 2.6.11-gentoo-r3 i686)
=================================================================
System uname: 2.6.11-gentoo-r3 i686 Intel(R) Pentium(R) 4 Mobile CPU 1.80GHz
Gentoo Base System version 1.4.16
Python: dev-lang/python-2.3.4-r1 [2.3.4 (#1, Mar 11 2005, 17:34:27)]
dev-lang/python: 2.3.4-r1
sys-devel/autoconf: 2.59-r6, 2.13
sys-devel/automake: 1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.4
sys-devel/binutils: 2.15.92.0.2-r1
sys-devel/libtool: 1.5.10-r4
virtual/os-headers: 2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -march=pentium4 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=pentium4 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS=#i cannot post urls because i haven't posted 5 messages yet, so add the http's in yourself:# "distfiles.gentoo.org distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X alsa apm arts avi berkdb bitmap-fonts crypt cups emboss encode f77 foomaticdb fortran gdbm gif gpm gtk2 imlib java jpeg libg++ libwww mad mikmod modelock motif mpeg ncurses nls oggvorbis opengl oss pam pdflib perl png python quicktime readline sdl spell ssl svga tcpd tiff truetype truetype-fonts type1-fonts unicode vdesktop xml2 xmms xv zlib"
Unset: ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, PORTDIR_OVERLAY





would anyone have an idea what the problem could be? thank you for reading this far.
 
Old 07-12-2005, 06:09 AM   #2
bleneak
LQ Newbie
 
Registered: Jul 2005
Posts: 2

Original Poster
Rep: Reputation: 0
I forgot to add; I am obviously using gentoo, with the 2.6.11-gentoo-r3 kernel, which I patched for the epcam driver (for creative pd1001 webcam)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
emerging realplayer novacrasher Linux - Software 3 11-30-2005 05:43 AM
emerging kdebase error LuckyABA Linux - Newbie 4 01-21-2005 12:01 AM
Emerging Technologies gr33ndata General 2 11-21-2004 07:01 PM
Gentoo freezes when emerging Strom_Boli Linux - Newbie 1 10-18-2004 10:52 PM
XawTV - Sound continues after closing XawTV ministre Linux - Software 5 11-05-2003 10:26 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration