LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-15-2008, 03:32 PM   #1
utahnix
Member
 
Registered: Dec 2006
Location: Utah, USA
Distribution: openSUSE
Posts: 72

Rep: Reputation: 15
Emails in Thunderbird won't open in Firefox


I know this has been discussed a few times on various Linux boards, but I've tried those fixes and they don't work.

I'm trying to get my links within Thunderbird to open in Firefox. It worked at one time on this same install, and at some point it quit working. I'm not sure when or if anything changed (upgraded to Firefox 3 is all). I go so long without rebooting that I wondered if it was just a memory leak or glitch. But alas, no, a logoff or reboot doesn't help.

Just to give you some background info, I have openSUSE 11. I've got Firefox 3.0.4 and Thunderbird 2.0.0.18. I'm using KDE 3.5.9 "release 49.1", right off the openSUSE.org site / DVD.

I'm also NOT using the Firefox / Thunderbird that came with openSUSE, but instead using the pre-compiled ones that come right off mozilla.com's website. I have both apps in /opt (/opt/firefox and /opt/thunderbird).

I've also got Firefox and Thunderbird registered as the default browser / email app in both GNOME and KDE3.

Moreover, I have gone into the Thunderbird config editor and added the "network.protocol-handler.app.http" and "network.protocol-handler.app.https" elements. They point to the right Firefox binary, /opt/firefox/firefox.

But those config editor entries have been in there for a long time (before I started having problems). I have a matching "mailto" entry in the Firefox config editor to get the "File -> Send Link" feature to send links via Thunderbird, which it does correctly.

I'm not a regular KMail user (I prefer Thunderbird's consistency over multiple platforms), but I did try it temporarily to see what happened. Links from KMail properly opened in Firefox without a hitch, which tells me this is likely a Thunderbird problem.

I've also tried several script variations that perform the launching of Firefox, and temporarily changed the "http" and "https" variables in Thunderbird to point to the script instead of directly to Firefox, and that didn't seem to help.

I can also pass URLs to Firefox on a shell and it opens correctly.

And lastly, I renamed my ~/.thunderbird and started up Thunderbird with a new profile. No go - links still won't open in Firefox (all of my mailboxes are exclusively IMAP).

So do any of you have any ideas? I'd love to have this working again!
 
Old 12-15-2008, 04:13 PM   #2
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,141

Rep: Reputation: 168Reputation: 168
You could try renaming your ~/.mozilla and ~/.thunderbird directories so that you start with a clean profile. If that works, restore the email directories, address book, bookmarks, plugins, etc. and you should be fine. I'm using those versions here and am not having the same problem.
 
Old 12-15-2008, 06:33 PM   #3
penguiniator
Member
 
Registered: Feb 2004
Location: Olympia, WA
Distribution: SolydK
Posts: 442
Blog Entries: 3

Rep: Reputation: 60
What DOES happen when you click a link in Thunderbird? Does it do nothing, or does it open in, say, Konqueror or a text editor? If it opens in the wrong browser or an editor, you may want to check the mime-type settings for .html and cousins to be sure they are not hijacking your preferences.

Also, do you still have the versions of TB and FF that came with OpenSUSE installed? Sometimes, environment settings are different for .desktop files and the shell, and can screw up your preferences. Be sure that you are running the versions of both programs that you installed in /opt and not the older ones. If that is the case, you can source your bash profile in a script in KDE's env folder to make your environment more consistent, iirc, and in KDE's app preferences be sure you specify the complete path to your versions of FF and TB, just to be safe.
 
Old 12-16-2008, 11:26 AM   #4
utahnix
Member
 
Registered: Dec 2006
Location: Utah, USA
Distribution: openSUSE
Posts: 72

Original Poster
Rep: Reputation: 15
As I said in my first post, I've already tried using an alternate profile. Didn't work.

When I click on a link, NOTHING happens. Nada. No Firefox, no Konqueror, no KWrite... no anything.

Seems Thunderbird is detecting it as a link, as it is click-able. But it's not doing anything with it.

In the past when I've had this issue, I've entered the config editor and added handlers, which always worked. I currently have those in my profiles (for both TB and FF), and it worked earlier. The only thing I can think of that changed is that I dropped FF2 for FF3 when FF3 was released to the general public (GM release).

And again, I've set FF and TB as my default apps in GNOME, as well as in KDE3 (component chooser, etc).

And yes, the shortcuts, icons, etc... they all point to the same Firefox. In fact, I actually removed the original openSUSE Firefox and symlinked the old binaries (i.e. where the binaries were) to the new Firefox in /opt.

So I'm stumped. Ideas?

Last edited by utahnix; 12-16-2008 at 11:28 AM.
 
Old 12-16-2008, 02:02 PM   #5
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,187

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
I don't use SUSE, so this may not be relevant.

On my Fedora 10 system, mail links in TB 2.0.0.18 open in FF 3.0.4 with no problem and I have nothing but the default settings in TB's config in the browser section (other than specifying the correct download directory), and nothing about "html" except that the "default.html.action" is set to 2 (and I've forgotten why I set it to that value, but I think it has something to do with html messages, not links.).
 
Old 12-16-2008, 03:40 PM   #6
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,141

Rep: Reputation: 168Reputation: 168
There was a similar problem with Firefox 3 and Thunderbird 2 on Slackware 12.1 a few months back (not for everyone). The info here and here may help.
 
Old 12-17-2008, 07:47 PM   #7
utahnix
Member
 
Registered: Dec 2006
Location: Utah, USA
Distribution: openSUSE
Posts: 72

Original Poster
Rep: Reputation: 15
Maybe I'm dense, but I don't see how those last two posts relate to me. These seem to be related to Firefox not passing email-related requests to Thunderbird. I'm not having trouble with mailto links in Firefox, or trouble with the "File -> Send Link" feature.

I fire up Thunderbird and click on a message. In the message body is a URL. I click on the URL, expecting it to open in Firefox. Nothing happens.

If I mis-read or mis-interpreted those pages, please let me know. Those threads didn't seem to be reflecting the same issue I am having.
 
Old 12-18-2008, 01:55 PM   #8
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,187

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
Quote:
Originally Posted by utahnix View Post
Maybe I'm dense, but I don't see how those last two posts relate to me. <snip>
I'd tend to agree, but they do suggest that you check the default action for, e.g., html files in the "File Associations" settings.
 
Old 12-18-2008, 03:18 PM   #9
utahnix
Member
 
Registered: Dec 2006
Location: Utah, USA
Distribution: openSUSE
Posts: 72

Original Poster
Rep: Reputation: 15
File associations in KDE/Konqueror? HTML files are associated to open up in Firefox. I've verified they point to the right Firefox binary. It's all correct.

I've played around with KDE's component chooser and tried browsers other than Firefox, which didn't do anything different. I've gone back to GNOME and checked the preferred applications list. I've even revisited about:config in Thunderbird. It's all there.

Thought... Is there a way to get TB to log this kind of stuff so that I have something to go on?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hotmail Firefox 2.0 can not open or type text in emails Sam French Linux - Newbie 2 11-10-2008 10:37 AM
How to get Thunderbird to open from Firefox Red Knuckles Mandriva 5 02-05-2006 02:57 PM
Open URLs from Thunderbird in Firefox digitalhead Linux - Software 6 03-04-2005 03:03 PM
Forcing thunderbird to open firefox Acadien Linux - General 2 09-08-2004 03:40 PM
Trying to get Thunderbird to open urls by using Firefox 0.9 Clived Linux - General 3 08-03-2004 09:03 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration