-   Linux - Software (
-   -   emacs not responding to tilde etc. (

simen 05-14-2006 08:32 AM

emacs keyboard trouble
I've been having trouble with emacs lately. Whenever I try to get any of the signs ^ ~ ` emacs doesn't respond. As if I didn't touch the keyboard at all. It used to work just fine (and works in all other applications). Sad to say, I've no clue as to how this problem arose. I've tried:

* purging and reinstalling emacs,
* removing .emacs and .emacs.d from my home dir,
* changing locale on the computer,
* googling and searching various forums (either the problem is quite rare, or I lack some fundamental knowledge).

The only "solution" I've found is to: M-x set-input-method, but this leaves me with a slightly weird editor, and I'm still unable to get ~, ^, and `. I just want to type o to get , e to get , and so forth. I feel utterly puzzled :confused: Any ideas would be appreciated.

Kind regards,

simen 11-01-2006 08:42 AM

RESOLVED: emacs not responding to tilde etc.
I fixed it. Yay! It turns out the troublemaker was none other than scim. scim is great for inputting japanese, but it's pretty buggy, breaking all kinds of software around it. I've had trouble running Flock with $GTK_IM_MODULE = scim, and now this... One indicator was that emacs was running perfectly outside of X. Anyway, what I did was simply to purge scim completely. On my system (where I installed scim from a HOWTO on the Ubuntu forums):

apt-get remove anthy im-switch libcanna1g libuim-data libuim3 scim-anthy \
scim-uim uim uim-common uim-fep uim-gtk2.0 uim-utils uim-xim && rm \

Right now I've no time for studying Japanese, so for me this was a simple case of prioritizing my single most important work tool over something that I'm just using to impress friends anyway ;). One day when I have time, I may see if I find a work-around.

Hope this might help anyone with the same esoteric problem as me.


All times are GMT -5. The time now is 12:57 AM.