LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-02-2014, 08:36 AM   #1
CollieJim
Member
 
Registered: Mar 2005
Distribution: Gentoo, Kubuntu
Posts: 582

Rep: Reputation: 28
emacs minibuffer prompt colour


I'm accessing a Beaglebone Black via ssh.

The BBB's Emacs colours are giving me grief. Black is the only background colour I can get, but that's fine since that is my preference.

The problem is the minibuffer prompt, which is a dark blue and nearly impossible to read.

I've found where its face is defined (faces.el, line 2391) but the colour specified there is not any shade of blue. I tried changing it but I still get a dark blue prompt.

Where do I change the minibuffer prompt's colour?

Thanks
Jim
 
Old 07-02-2014, 03:20 PM   #2
rtmistler
Moderator
 
Registered: Mar 2011
Location: USA
Distribution: MINT Debian, Angstrom, SUSE, Ubuntu, Debian
Posts: 9,885
Blog Entries: 13

Rep: Reputation: 4931Reputation: 4931Reputation: 4931Reputation: 4931Reputation: 4931Reputation: 4931Reputation: 4931Reputation: 4931Reputation: 4931Reputation: 4931Reputation: 4931
Here's what I do/have done on a BBB. I could not install emacs via a package for some reason, and by the way I am running Angstrom on it.

Code:
wget http://ftp.gnu.org/gnu/emacs/emacs-24.3.tar.gz
unzip the package
./configure --with-xpm=no --with-gif=no
make
make install
emacs takes up a lot of space and I didn't experiment much to figure out how to make it smaller. I don't normally have it on the target and instead I use emacs from my development station; Ubuntu or MINT and then scp my files to the target then run my builds on the target. Those flags I had to use to get it to compile. I'm running the 3.8 kernel from late September last year, not sure if they yet have any kernel updates for that. You can try different flags at your leisure, or you may have a different distro.

When I ssh over, I use the -X flag:

Code:
ssh -X <root-or-user>@<ip-address>
emacs &
I get colors when I run it this way. Running emacs on the target takes up too many cycles IMHO; and since I'm developing on the target, the application is like a kiosk app which runs at boot, I make an install file, then reboot. Therefore my emacs session can't stay open, and that's another reason why I prefer to run emacs on my dev station and scp my files over. You didn't say you were developing on your BBB or what you were using it for, but just saying that by compiling emacs on the BBB and attaching via ssh with the -X flag, I can run emacs and do see the colorings as one normally does.

The other thing I just realized is that it is sometimes glacially slow when editing on the BBB; I can't live with that, I type pretty fast and need to move around the buffer; have several buffers open and switch buffers rapidly to cut/paste or just review code. If it can't keep up it's not worth it to me.

Attached is a view of what it looked like.

Last edited by rtmistler; 08-07-2015 at 12:46 PM.
 
1 members found this post helpful.
Old 07-03-2014, 09:00 AM   #3
CollieJim
Member
 
Registered: Mar 2005
Distribution: Gentoo, Kubuntu
Posts: 582

Original Poster
Rep: Reputation: 28
Thanks.

I was using Ubuntu on an 8GB microSD card. I used your code to build a fresh copy of emacs and got the same result as with the package - only the emacs-nox version. I get colour, just not usable colour.

My numbers for the build were configure: 3.5 minutes, make: 23.7 minutes, install: 7 minutes.

I installed x11 and xorg but still got the same thing. If I entered 'emacs &' it started in the background and I saw nothing. It seems I missed something...

I removed the card and booted Angstrom and got your results. Now I need to find out what's different.

But mostly, I need to find where the minibuffer prompt's colour is set because I prefer a black background and I use the shell buffer a lot.

The current project for the BBB is a weather station. I'm using sensors on the roof from a cheap commercial station with a failing display, and an Arduino to interpret the data and send formatted records to the BBB for logging and display.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Quick bash prompt colour question (changing styles) steak1987 Linux - Software 4 01-29-2014 09:10 AM
LXer: Cool tips to change Ubuntu command line prompt colour LXer Syndicated Linux News 0 10-10-2012 10:40 AM
[SOLVED] emacs console mode : change background colour ravi.xolve Linux - Hardware 4 11-09-2011 10:54 PM
emacs prompt in shells (esp. py-shell) CoonerTheRed Linux - Software 0 05-08-2006 10:45 AM
emacs background colour karan101 Linux - Software 2 11-19-2004 10:23 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration