-   Linux - Software (
-   -   Emacs KDE clipboard interaction (

usr345 10-11-2012 03:15 PM

Emacs KDE clipboard interaction
I am using Emacs 23.3.1 and KDE 4.5.5 on Linux Slackware. When I select and copy some text in Emacs into the clipboard, using the hotkeys: C-c & Shift-<Ins> this text doesn't appear immidiately in KDE clipboard. But exists at the top of Klipper buffer. So I have to manually select this text and then it's available.

When I copy from the menu, everything works fine. How to learn, which functions called, when copying from the menu, so I could bind it to the hotkeys?

ntubski 10-12-2012 11:22 AM

You can use describe-key (<f1> k) or describe-key-briefly (<f1> c) for any keybindings. Clicking a menu item also counts as a keystroke.

For example, describe-key-briefly on the copy menu item gives me:

<menu-bar> <edit> <copy> runs the command clipboard-kill-ring-save
Also, the x-select-enable-clipboard variable may be of interest to you:


x-select-enable-clipboard is a variable defined in `x-win.el'.
Its value is t

Non-nil means cutting and pasting uses the clipboard.
This is in addition to, but in preference to, the primary selection.

On MS-Windows, this is non-nil by default, since Windows does not
support other types of selections.  (The primary selection that is
set by Emacs is not accessible to other programs on Windows.)

You can customize this variable.

To be honest, I find X Window's system of multiple cut buffers/selections confusing; my current settings work most of the time, except when they don't...

All times are GMT -5. The time now is 04:14 AM.