-   Linux - Software (
-   -   em8300 green screen (

wingcom 11-12-2004 09:21 AM

em8300 green screen

I've been trying to get my dxr3 and dvd playback up for days now. I got this far that overlay is working very well, but i'm having trouble with my tv-out. I fixed manny things reading on these forums like dvd support in xine, firewall support etc but i seem to get a little stuck on this one

* I just upgraded from mdk9.0 to mdk10.1 and saw that my dxr3 device was available in mandrake control center (i had once been messing with it on mdk9 but eventually it didnt work straight away and since i still had my laptop i let it be and used that one) so now i wanted to setup dvd-playback

* my s-vhs entrance to my tv is broken so i connect to scart which has s-vhs entrance.

* i got two cables for that purpose: one is a one-piece-cable(svhs 2 scart) other is two pieces(one svhs-svhs one scart"head") If i use the one-piece-cable i got smooth playback on my tv but in black and white :( , when i use the second i have a green screen. Since my portable running windows also gets black-white image with the first cable i'm ditching it. The second cable however gives perfect playback in windows (using a different video card), in linux its all green (using dxr3)

* I tried all possible options for the configuration of the modules. I tried this like this:
modprobe adv717x pixelport_16bit=0 pixelport_other_pal=1 swap_redblue_pal=0
modprobe em8300 dicom_control=0 dicom_fix=0 dicom_other_pal=1
I change pixelport_16bit, pixelport_other_pal, dicom_control, dicom_fix and dicom_other_pal in various combinations: always a green screen and issuing em8300setup after each combination --> the tvscreen flickers and turns green again :(
-> is this good enough to test the different options? or do i need to try a movie each time?

There are also configuration options available for the device in mandrake control center maybe the overwrite the options i set with modprobe? I dont know how they work... i sincerly hope i dont need a reboot to test each option :s cus i'm not sure how they are used and when they are loaded.

I also changed my /etc/modules.conf but that does not seem do do any good either.

Please give me some hints on how to test this properly... or tell me what i'm doing wrong or should try, any help is grately appreciated!

kind regards


madluther 11-12-2004 10:44 AM

I have a dxr3 and it is a pain to get it setup correctly, Im currently a resident of the US so my config may not help you much as it is for NTSC encoded video, that being said, here's my config ..

dicom fix = 1
dicom control = 1
dicom other pal = 1

pixelport other pal = 1

all other parameters = 0

For testing, re-running em8300setup is not enough, you have to unload the kernel modules first, and then re-run em8300setup as these parameters are only set when the modules are loaded.


rmmod em8300
rmmod adv717x



wingcom 11-12-2004 11:05 AM

Hey thanx madluther!

You are so right... em8300setup is not enough, if i had known that it would have saved me alot of trouble! I did a reboot (before I read your post cus now i would know how to unload the modules :) with the new options -->
modprobe adv717x pixelport_16bit=0 pixelport_other_pal=1 swap_redblue_pal=0
modprobe em8300 dicom_control=1 dicom_fix=0 dicom_other_pal=1
those are my options now (all others have default values) and its working! WHOEHOE! :D

Finally... hehe

Do you know how to load it automaticly? (so i dont have to do modprobe every time?) I got the lines in /etc/modules.conf but it doesn't seem to do anything with them.

I'm liking my linux better every day, maybe someday i will be windows-free since i do most my stuff on linux now. Its a little hard to set up but once it works, it rocks!



madluther 11-12-2004 11:35 AM

Glad to hear you got it working :cool:

My modules.conf looked like this (I dont run a 2.4 kernel anymore, but this was a working config before I upgraded to 2.6)

alias char-major-121 em8300
pre-install em8300 modprobe adv717x
post-install em8300 em8300setup
options adv717x (put your options here)

Also, when running a player like xine with the dxr3, I had a problem where only root could auto load the modules. After some investigation I found that the modules loaded ok but em8300setup would not upload the microcode to the dxr3 card unless it was run by root. The fix was to set em8300setup suid root. You may not need or want this, but I thought I'd mention it anyway.


run the following as root

chmod 4755 /usr/bin/em8300setup


wingcom 11-12-2004 11:56 AM

uhm, just to be sure:

You were saying:

I dont run a 2.4 kernel anymore, but this was a working config before I upgraded to 2.6
Does this matter? because i am running a 2.6 kernel too in my new mdk10.1. Sorry if i ask stupid questions, i'm forced to work in windows alot at work :s So i don't keep up alot... when everything on my linux does what its has too i leave it like that (untill mdk10.1 this was mainly server (file server with samba, firewall, dns, dhcp etc but now i discovered kde - before i was using gnome - and its kewl transparent menu's etc which got me to finally making dvd, dxr3 etc work :D )

Anywayz, my modules.conf doesn't have modprobe in it, it looks like this:

below em8300 adv717x
below adv717x sound-slot-0 sound-service-0-3
options adv717x pixelport_16bit=0 pixelport_other_pal=1
options em8300 dicom_fix=1 dicom_control=0 dicom_other_pal=1
post-install em8300 /usr/bin/em8300setup

so, i will place this in comment and try the modprobe thing you got there...

Thanx for all your help!

All times are GMT -5. The time now is 08:14 PM.