-   Linux - Software (
-   -   EFI boot manager: making it the default (NOT a dual boot issue) (

Something Else 05-14-2013 01:02 AM

EFI boot manager: making it the default (NOT a dual boot issue)
So, I do not dual boot on my PC. It's a pretty closed piece of hardware, sadly; I should have realized I'd get the Linux bug eventually while shopping for it, but I was all like "WOO WINDOWS 8 WILL WORK PERFECTLY," before realizing that that was about as far from the truth as conceivably possible, and stumbling vomiting back to Linux. Anyway, after some hackage I've managed to make it work pretty well with an Arch Linux install, with the only closed drivers being the wireless (of course).

Anyways, I previously had a Debian install which I installed with a traditional boot loader (just turning off EFI in the BIOS altogether), but when I did Arch I couldn't figure out how to replicate that for whatever reason. I was, however, able to get GRUB2 working as an EFI thing. (Still have "secure boot" disabled since it doesn't recognize it as a legitimate EFI file, but it doesn't give me any trouble.) The thing is - and I don't know if this is why I'm having the problem or not - I tried several other EFI bootloaders first, including gummiboot and rEFInd. Neither worked. It doesn't give me the "no bootable disk detected" error like it did when I didn't have any EFI bootloader, but the screen is just black if I let the PC boot. I don't know if that's rEFInd or gummi. Anyhoo, I got GRUB2 working as I said, but it doesn't load automatically - I have to hit F9, pick "change boot order" and "boot from EFI file," then go through nested directories to find core.efi insidde grub_x86_64 (I'm pretty sure those are the folders).

Anyway, this is just a PITA and I'd like to get my computer booting into Linux automatically. I'm not married to GRUB if one of the other bootloaders can be made to work. Here's my efibootmgr output:

BootCurrent: 003D
Timeout: 10 seconds
BootOrder: 3000,3001,2001,2002,2003
Boot0000* EFI HDD Device (LITEONIT LMT-32L3M-HP)
Boot0001* rEFInd
Boot2001* USB Drive (UEFI)
Boot3000* Internal Hard Disk or Solid State Disk
Boot3001* Internal Hard Disk or Solid State Disk

My boot partition, btw, is actually /dev/sdb2; / is /dev/sdb1, and /home is /sda1. That bit of oddness may be why the default, non-EFI boot loader didn't work, although I had the same setup on debian and its installer managed that fine.

business_kid 05-15-2013 11:12 AM

What's your box? I have a Samsung here, and the bios will only boot EFI from a Gpt disk.

All times are GMT -5. The time now is 06:17 PM.