LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-15-2004, 08:31 PM   #1
jpbarto
Senior Member
 
Registered: Mar 2003
Location: Pittsburgh, PA
Distribution: Gentoo / NetBSD
Posts: 1,251

Rep: Reputation: 45
Educate me about apt-get please


I'm new to debian, can someone please explain apt-get to me?

I ran apt-get update and then apt-get upgrade.
After that I tried to install an app from source that said it couldn't find gtk-config. So I tried running 'apt-get install libgtk1.2-dev'
When I do it tells me that libgtk1.2-dev depends upon xlibs-dev but is not going to be installed.

So I run 'apt-get install xlibs-dev' and it tells me that it depends on xlibs but xlibs 4.3.0-... is to be installed and it won't install xlibs-dev.

All I want is gtk-config on my system, what do I have to do to get it?

Thanks in advance,
jpbarto
 
Old 01-15-2004, 11:18 PM   #2
Rounan
Member
 
Registered: Jun 2003
Location: Ontario
Distribution: Ubuntu, Gentoo, Debian
Posts: 416

Rep: Reputation: 30
Would you mind posting an exact transcription of the command, and console output? Would help to identify the problem.

One thing I ran into after a fresh install was that dselect's package selections hadn't been installed properly. I can't remember the command, exactly, but check man dpkg, man dselect, and man apt-get
I think it was something along the lines of:

apt-get dselect-upgrade

Other than that, find a local apt mirror, and update your /etc/apt/sources.list?

It just sounds like you've got some confused dependancies.

--Rounan
 
Old 01-16-2004, 09:05 AM   #3
jpbarto
Senior Member
 
Registered: Mar 2003
Location: Pittsburgh, PA
Distribution: Gentoo / NetBSD
Posts: 1,251

Original Poster
Rep: Reputation: 45
I'll try and post something tonight

I'll try and post up the command's output tonight. Also just as an aside, the installation is a morphix install (as in installing from their livecd) not a fresh clean debian install... not sure if that's good, bad, or neither.

jpbarto
 
Old 01-16-2004, 10:40 AM   #4
Bosah
LQ Newbie
 
Registered: Feb 2003
Posts: 9

Rep: Reputation: 0
Morphix is amazing. Its a little weird, from a pure debian perspective but its much better than any Debian intaller I've ever seen (though I haven't tried their latest).

If you have morphix, try and solve most of your problems with synaptic first. Its graphic and more user friendly imho. Apt is a great dependency checker but remember that what you're doing is pretty complex. Also the morphix.org web site is very friendly too.
 
Old 01-16-2004, 10:51 AM   #5
jpbarto
Senior Member
 
Registered: Mar 2003
Location: Pittsburgh, PA
Distribution: Gentoo / NetBSD
Posts: 1,251

Original Poster
Rep: Reputation: 45
Not to change the subject, but the reason I've begun playing with Morphix is to create an Educational software livecd. One of the secretaries in our office has a son who's 4 or 5 and is going to kindergarten soon and she's worried because she says he yet does not know his ABCs. He knows the song, but is unable to recognize an 'A' as an 'A' or that it makes an 'ah' sound. So I was thinking about making a boot CD that would have software like Linux Letters and Numbers and GCompris installed on it.

I'm lucky that there were debian packages for both of these apps but I've been finding some others and I'm hoping that there are packages for these as well because if there isn't I'm back to my problem of compiling from source and needing gtk-config installed.

Anyone have suggestions of good educational games to install? (again just as a side note to solving the dependancy issues).
 
Old 01-17-2004, 04:45 PM   #6
jpbarto
Senior Member
 
Registered: Mar 2003
Location: Pittsburgh, PA
Distribution: Gentoo / NetBSD
Posts: 1,251

Original Poster
Rep: Reputation: 45
Ok, I've moved on and I'm trying to install an app called ChildsPlay. I have two debian packages Childsplay.deb and Childsplay_plugins.deb. They depend upon Python and Pygame. When I try to install them using 'dpkg -i' I get this...

Selecting previously deselected package childsplay.
(Reading database ... 35603 files and directories currently installed.)
Unpacking childsplay (from childsplay_0.68-woody-1.all.deb) ...
dpkg: dependency problems prevent configuration of childsplay:
childsplay depends on python (<< 2.2); however:
Version of python on system is 2.3-4.
childsplay depends on pygame (>= 1.4-1); however:
Package pygame is not installed.
dpkg: error processing childsplay (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
childsplay


I installed pygame using apt-get and it installed Python2.1-pygame but ChildsPlay still won't install. According to dpkg-query the pygame installed conflicts with any .deb packages of pygame << 1.5-2. What's the problem with this thing?
 
Old 01-19-2004, 04:31 AM   #7
merana
Member
 
Registered: May 2002
Location: Philly/So. Jersey
Distribution: ESXi CentOS Red-Hat Ubuntuu Solaris Debian
Posts: 85

Rep: Reputation: 15
From one Debian newbie to another, here's what I read from your last post:


Quote:
Unpacking childsplay (from childsplay_0.68-woody-1.all.deb) ...
What sub-distribution are you running (Woody/Stable?)

Quote:
dpkg: dependency problems prevent configuration of childsplay:
childsplay depends on python (<< 2.2); however:
Version of python on system is 2.3-4.
I've learned that each particular sub-dist of Debian has default versions of the applications that come bundled in their 'default' install. You can over-ride this in apt get by specifying specific version numbers (see below) and ensuring that you have a path to those libraries in your sources file (/etc/apt/sources)

Quote:
From man apt-get
A specific version of a package can be selected for installation by following the package name with an equals and the version of the package to select. This will cause that version to be located and selected for install. Alternatively a specific distribution can be selected by following the package name with a slash and the version of the distribution or the Archive name (stable, testing, unstable).
Quote:
childsplay depends on pygame (>= 1.4-1); however:
Package pygame is not installed.
dpkg: error processing childsplay (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
childsplay
This is due to the first conflict. Once you satisfy that conflict then this will proceed.

A little care in considering the installation of the older library so that you don't break any other dependencies that the current version fills. Instead try to see if there is a version of childsplay in the distro that you are running.

Hope that was semi-helpful.
 
Old 01-19-2004, 09:20 AM   #8
php
Member
 
Registered: Jun 2001
Location: USA
Distribution: Slackware
Posts: 825

Rep: Reputation: 30
You can read all about apt-get at debian.org
 
Old 01-19-2004, 10:25 AM   #9
jpbarto
Senior Member
 
Registered: Mar 2003
Location: Pittsburgh, PA
Distribution: Gentoo / NetBSD
Posts: 1,251

Original Poster
Rep: Reputation: 45
I got childsplay and other python issues resolved, not totally mind you, however the packages did install. I further ran into problems with the python package distutils.

However the problem of "but I installed that package already!" became clearer when I looked into /usr/lib. It seems that by executing 'apt-get python*' to get libraries such as pygame, distutils, and assetml I have managed to install _FOUR_ different versions of python (1.5, 2.1, 2.2, & 2.3)!!! So after looking into the directories I discovered that executing apt-get install would install say the pygame package for python2.3, but not for any other versions, then when installing distutils it would install into 1.5 thus spreading my required installations across 4 versions of the interpreter (!!).

So after a little experimentation I have managed to meed dependancies and get these packages installed. Not all are working completely but those are different issues I will have to look into.

Until then I want to say thank you to all of you who have offered up your time and advice.

Sincerely,
jpbarto
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get update errors since Debian released ( bad /etc/apt/sources.list ?) forgox Debian 10 06-13-2005 01:28 PM
/etc/passwd, /etc/shadow, /etc/group? Educate me :)! nutnut Linux - General 4 06-11-2005 08:47 PM
knoppix 3.4 and no apt-setup how to fix info install apt-file + base-config maximalred Debian 0 10-16-2004 07:36 PM
knoppix 3.4 apt-setup on hdinstall / apt-get on live-cd non3 Linux - Distributions 0 05-25-2004 11:14 AM
rh9 xd2 apt apt-get problem fix and solution transeunt Red Hat 0 12-16-2003 11:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration