-   Linux - Software (
-   -   Edit a file in single-user mode (

ricardocastro 02-22-2002 03:41 PM

Edit a file in single-user mode


Please!!, it's very important!!

I tried to made available the quota for the users; i'm using a Linux that it's has been installed by another people and i don't know exactly how he did configured the machine.
I thought : "why don't just copy the /etc/fstab file from another server to make available the quota?" because there's a line like this:
/dev/hda8 /home ext3 usrquota
in another account that i have like user (no root)

I made a reboot and ooppss!!!, says:

fsck invalid device /dev/hda8
try e2fsck -b 8193 device to fix the problem
Enter in single mode user
root's password :

but, when i'll trying to do
e2fsck -f -b 8193 /dev/hda8

The computer indicates that is not an available device!!!

I'm just only trying to edit the /etc/fstab and delete these line, but the system indicates that it's just a read-only.
I've tried with chmod +ugo rwx fstab and still indicates me that i cant because its a read only mode

What can i do???



Malicious 02-22-2002 03:55 PM

When the boot process is interrupted with an error like this and you are dumped into single user mode, your root partition is mounted read-only. You should do this:

mount -n -o remount,rw /

This will remount root as read-write and you should be able to edit the fstab. After you finish, do a control-d to reboot.

ricardocastro 02-26-2002 05:37 PM

Thank's !!!!, :)
You save my life!!! :)

All times are GMT -5. The time now is 07:01 AM.