LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-05-2016, 02:11 PM   #1
bluesailor45
LQ Newbie
 
Registered: Nov 2016
Posts: 4

Rep: Reputation: Disabled
Unhappy Eclipse does not start - ClassNotFound Exception


Hi all
after several attempts to install eclipse on my Linux Mint 17.3 I get this error message:

An error has occurred. See the log file
/usr/lib/eclipse/configuration/1478372855526.log

in log:

!ENTRY org.eclipse.equinox.launcher 4 0 2016-11-05 19:32:34.997
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:626)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
at org.eclipse.equinox.launcher.Main.main(Main.java:1414)

seems I messed somehow the java installation ? How can I recover?

Thank you very much. Kind regards
 
Old 11-06-2016, 08:27 AM   #2
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 16,500

Rep: Reputation: 5536Reputation: 5536Reputation: 5536Reputation: 5536Reputation: 5536Reputation: 5536Reputation: 5536Reputation: 5536Reputation: 5536Reputation: 5536Reputation: 5536
as a first tip: it is not the java itself, but the eclipse installation (what looks messed). Would be nice to explain how did you try to install it.
 
Old 11-07-2016, 05:08 AM   #3
bluesailor45
LQ Newbie
 
Registered: Nov 2016
Posts: 4

Original Poster
Rep: Reputation: Disabled
Thank you pan64 for your analysis.
First of all, I am trying to install the eclipse platform with the avr-eclipse plugin. My goal is to write programs for the atmel atmega128 u-processor for the Nibo2 robot system. On MacOS there is no obvious alternative available and I desperately want to avoid using a (MS) Windows solution.
So this are the messed installations I tryied on Linux-Mint 17.1 (in the meantime I have upgraded to Mint 17.3).
--------------------------------------------------------------------------------------------------------------------
Installed eclipse-platform (from Linux Software Manager) 1.11.2016
- after installing: in Eclipse Help -> install additional SW: C/C++ Development Tools cdt plugin
- install AVR eclipse plugin. Help-> ins. add. SW: work with: http://avr-eclipse.sourceforge.net/updatesite
- due to installation of eclipse via SW-Manager Eclipse installed under root:root -> if trying to update "insufficient access priviledge" due to running eclipse as user kurt:
-> chown -R kurt:adm /usr/lib/eclipse
- Installed GCC-AVR from Software Manager

2.11.2016
uninstalled: (with Eclipse -> Help: Installed SW
- GCC-AVR
- AVS
-C/C++ Development Tools

- reinstalled from
//download.eclipse.org/releases/juno: C/C++ Development Tools
//avr-eclipse.sourceforg.net/updatesite : AVR eclipse plugin

3.11.2016
uninstalled all eclipse
installed with package manager: gcc-avr and avrdude
installed with Siftware Manager: eclipse-cdt
-> chown -R kurt:adm /usr/lib/eclipse
-> chown -R kurt:adm /usr/share/eclipse
avr-eclipse plugin could not be installed: -> already installed (but not working)

5.11.2016
uninstalled eclipse-cdt with Software Manager
uninstalled eclipseplatform 3.8.1-5.1 with uninstall on Menu -> Programming -> Eclipse / unistall
remove eclipse packages with Synaptic package manager
-> in /usr/share/ all eclipse related is removed
-> in /usr/lib/ eclipse directory still here with ./plugins avr-eclipse plugin
remove eclipse-cdt-jni with synaptic Package Manager
-> eclipse still in /usr/lib/ directory
remove libecj-ava with Package Manager (Eclipse Java Compiler)
installed eclipse-cdt with Software Manager
-> got installed in /usr/share/ with user:root
-> Help -> install new software does not work
remove eclipse-cdt with Software Manager
eclipse platform still installed
uninstall from Menu
-> /usr/share/ eclipse now removed

complete removal of packages: eclipse-platform-data / eclipse rcp / libecj-java / eclipse-cdt-jni
-> /usr/lib/eclipse not removed (not empty)
-> all dirs and files in /usr/lib/eclipse manually deleted

Install with package manager: eclipse-platform / eclipse-platform-data /eclipse-rcp /libecj-java
-> /usr/lib/eclipse/configuraion not writeable
-> chown -R kurt:adm /usr/lib/eclipse
when starting eclipse:
"An error has occurred. See the log file
/usr/lib/eclipse/configuration/1478346783565.log"
-> installed eclipse-cdt with package manager
-> chown -R kurt:adm /usr/share/eclipse
something wrong with java path variable or so ??? .... ClassNotFoundError: java

remove libecj-java with Package Manager (Eclipse Java Compiler)

Install eclipse-cdt with Software Manager
same error when started
uninstall eclipse-cdt

-------------------------------------------------------
Yes, it is really a mess. But how can I recover now for a clean installation?
Thank you very much for further help. Kind regards Bluesailor45
 
Old 11-07-2016, 05:42 AM   #4
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 16,500

Rep: Reputation: 5536Reputation: 5536Reputation: 5536Reputation: 5536Reputation: 5536Reputation: 5536Reputation: 5536Reputation: 5536Reputation: 5536Reputation: 5536Reputation: 5536
here are 3 different ways to install eclipse.
https://www.youtube.com/watch?v=jVU_LIFR-OI
http://stackoverflow.com/questions/2...-on-linux-mint
https://community.linuxmint.com/tutorial/view/1503
as a start, next you will need to install plugins.
do not chown anything.
 
1 members found this post helpful.
Old 11-07-2016, 08:07 AM   #5
sundialsvcs
LQ Guru
 
Registered: Feb 2004
Location: SE Tennessee, USA
Distribution: Gentoo, LFS
Posts: 9,148
Blog Entries: 4

Rep: Reputation: 3232Reputation: 3232Reputation: 3232Reputation: 3232Reputation: 3232Reputation: 3232Reputation: 3232Reputation: 3232Reputation: 3232Reputation: 3232Reputation: 3232
A Macintosh, did you say? Then, do what I did ...

"Screw Eclipse!" XCode ... which is probably built-in (or else you need to install the "Developer Tools") ... will do quite nicely.
 
Old 11-07-2016, 08:08 AM   #6
sundialsvcs
LQ Guru
 
Registered: Feb 2004
Location: SE Tennessee, USA
Distribution: Gentoo, LFS
Posts: 9,148
Blog Entries: 4

Rep: Reputation: 3232Reputation: 3232Reputation: 3232Reputation: 3232Reputation: 3232Reputation: 3232Reputation: 3232Reputation: 3232Reputation: 3232Reputation: 3232Reputation: 3232
A Macintosh, did you say? Then, do what I did ...

"Screw Eclipse!"

XCode ... which is probably built-in (or else you need to install the "Developer Tools") ... will do quite nicely.
 
Old 11-07-2016, 09:29 AM   #7
bluesailor45
LQ Newbie
 
Registered: Nov 2016
Posts: 4

Original Poster
Rep: Reputation: Disabled
Thank you Pan64
you saved my day !
I downloaded eclipse from eclipse.org and extracted it to a newly created library. To install it I had to install Java JDK 8 from oracle. After that installing the avr-eclipse plugin did work.
 
Old 11-07-2016, 09:34 AM   #8
bluesailor45
LQ Newbie
 
Registered: Nov 2016
Posts: 4

Original Poster
Rep: Reputation: Disabled
@ sundialsvcs:
Its not really a macintosh. Its a 2015 MacBook Pro.
I have installed Xcode and am now in process of getting used to that aswell. However I did not really find any convincing tutorial on how to install avr-plugins for a atmegaxxx prcessor. Can you give some advice?
Thanks a lot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I get an exception when trying to start Azureus dr_zayus69 Linux - Software 7 12-15-2007 12:30 AM
Tomcat Unable to Start - Exception PerfectReign Linux - Software 2 08-10-2006 05:24 PM
eclipse will not start. cdc5205 Linux - Software 8 05-16-2006 01:12 AM
Eclipse does not start anilbh Linux - Software 5 02-15-2006 07:03 PM
No games will start w/ winex: Unhandled Exception sboy Linux - Games 3 10-15-2003 10:41 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration