LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-23-2009, 02:53 PM   #1
fakie_flip
Senior Member
 
Registered: Feb 2005
Location: San Antonio, Texas
Distribution: Gentoo Hardened using OpenRC not Systemd
Posts: 1,495

Rep: Reputation: 85
E: Build-dependencies for gnome-applets could not be satisfied.


I'm trying to rebuild the gnome-applets deb package in Ubuntu 9. How can I get all the dependency packages to do so???

PHP Code:
chris@ubuntu:~/Build/gnome-applets-2.26.0sudo apt-get build-dep gnome-applets
Reading package lists
... Done
Building dependency tree       
Reading state information
... Done
E
Build-dependencies for gnome-applets could not be satisfied.
chris@ubuntu:~/Build/gnome-applets-2.26.0
 
Old 05-26-2009, 07:45 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,492

Rep: Reputation: 3639Reputation: 3639Reputation: 3639Reputation: 3639Reputation: 3639Reputation: 3639Reputation: 3639Reputation: 3639Reputation: 3639Reputation: 3639Reputation: 3639
May be not much help, this is what I get .....

Attached, the output from
'sudo apt-get build-dep gnome-applets'
( mostly, all Danish words were removed ).

Also attached : /etc/apt/sources.list
.....
Attached Files
File Type: txt build-dep-gn-applet.txt (2.3 KB, 9 views)
File Type: txt sources.list.txt (2.8 KB, 8 views)

Last edited by knudfl; 05-26-2009 at 07:51 AM.
 
Old 05-27-2009, 12:29 AM   #3
fakie_flip
Senior Member
 
Registered: Feb 2005
Location: San Antonio, Texas
Distribution: Gentoo Hardened using OpenRC not Systemd
Posts: 1,495

Original Poster
Rep: Reputation: 85
The problem is solved, and I'll post the answer for those who search the forums.

I was missing a few things from my sources.list, maybe jaunty-updates main. I added them with softwaremanager-gtk. I didn't make this mistake, but be sure all src repositories are enabled. And now I have the rebuilt deb for 64-bit gnome-applets to include minicommander panel applet. If anyone would like the debs for Ubuntu 9.04, you can ask me for them. They are 64-bit debs, but I can create 32-bit ones with a 32 bit ubuntu running in vmware.

Last edited by fakie_flip; 05-27-2009 at 12:32 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fluxbox and Gnome applets s26c.sayan Linux - Desktop 2 04-25-2007 01:41 PM
Applets in Gnome R¬dical_úD SUSE / openSUSE 3 05-28-2005 12:08 AM
Gnome Panel Applets workman161 Linux - General 0 03-31-2005 10:41 AM
Not really understand Applets in Gnome leduytien Linux - Newbie 0 10-19-2004 01:31 AM
gnome-applets : battstat h/w Linux - Newbie 0 04-06-2003 12:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration