LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   dvd's wont play (even with libdvdcss) (https://www.linuxquestions.org/questions/linux-software-2/dvds-wont-play-even-with-libdvdcss-71379/)

spyderusa11 07-09-2003 04:44 PM

dvd's wont play (even with libdvdcss)
 
i'm running xine-1-beta12 and i have libdvdcss 1.2.7 installed. here's the output i get when i try to play a dvd:

libdvdnav: Using dvdnav version 1-beta12 from http://xine.sf.net
libdvdread: Using libdvdcss version 1.2.7 for DVD access
libdvdread: Attempting to use device /dev/cdrom mounted on /mnt/cdrom for CSS authentication
libdvdread: Could not open /dev/cdrom with libdvdcss.
libdvdread: Can't open /dev/cdrom for reading
libdvdread: Device /dev/cdrom inaccessible, CSS authentication not available.
libdvdnav: Can't read name block. Probably not a DVD-ROM device.
libdvdnav: Unable to find map file '/home/spyderusa11/.dvdnav/.map'
libdvdnav: DVD disk reports itself with Region mask 0x00f20000. Regions: 1 3 4
load_plugins: plugin dxr3-spudec failed to instantiate itself.
libspudec:init_plugin called
input_dvd: Error getting next block from DVD (Error reading NAV packet.)


can anybody help?

thanks,
Mike

spyderusa11 07-09-2003 05:36 PM

ok so i ran xine-check and it told me to make a group called cdrom and put my username in it and then run "chgrp cdrom /dev/scd0" and then "chmod g+rw /dev/scd0"

that all worked ok but then it said to run "id -a" to make sure i was in the cdrom group, but i wasnt. so i just ran "chgrp spyderusa11 /dev/scd0" and "chmod g+rw /dev/scd0"

everything works fine now but i'm wondering if i'm gonna have any other problems as a result of this.

thanks,
Mike

Tinkster 07-09-2003 05:41 PM

I'd think this is a permission problem...

For reading DVD's (not vob-files
of a mounted media) you need
permissions for the raw-device.

Create a group dvd, add users that
are supposed to be able to play dvd's
to it, and then do
chgrp dvd /dev/cdrom
chmod g+rw /dev/cdrom

If /dev/cdrom is just a symlink you'll
have to do tha stuff above for the REAL
device (ie /dev/hdc, /dev/scd0, ...)

Cheers,
Tink

P.S.: Oh lol, I was too late :}

No you won't have a problem with that. Unless
there's other users on the box who aren't member
of the group... ;)

Well ... you can still just edit /etc/groups and
add yourself (and other users) to the cdrom group ;)


All times are GMT -5. The time now is 06:37 PM.