-   Linux - Software (
-   -   dvdrecord + kernel 2.6 (suse 9.1) - ide-scsi = bad (

eccles23 10-27-2004 05:29 PM

dvdrecord + kernel 2.6 (suse 9.1) - ide-scsi = bad
I think that software is the best place for this because it's not actually a hardware issue - more of a hardware interface issue.

I have had no problems burning DVDs under 2.4 kernels (under gentoo, debian, suse 9.0) but I am having probs now.

since kernel 2.6 apparently has support for cd writing without using scsi emulation, suse doesn't set up the burner as a virtual scsi device as it did in earlier versions (9.0).

I tried putting "hdc=ide-scsi" in my lilo.conf, but of course that didn't do anything. So I decided to try to find out how to get the burner working without scsi emulation.

I have tried both dvdrecord and growisofs, and neither of them have worked. Both of them say "OPC reported errors during power calibration" or something [growisofs: :-[ PERFORM OPC failed with SK=3h/ASC=73h/ACQ=03h]: Input/output error] - basically they both report I/O errors. it seems to me that the disks never get anything written to them either. and I can hear the drive spin up... then stop, then spin up... then stop... and so on...

So basically my drive is not being interfaced with properly by either of the two burning apps.
(I used dev=/dev/hdc with growisofs, and dev=ATAPI:0,0,0 with dvdrecord, as that was the address given by a 'dvdrecord dev=ATAPI -scanbus'. I am using a modified version of dvdrecord I found that added atapi support from a cdrecord package. (but this is not the problem I don't think).

Can anyone suggest anything? alternative rpms (I built my own from the tarball) - different config etc? I'd really prefer not to be wasting time on this, I just want dvd burning working again (I installed SuSE 9.1 only 2-3 weeks ago and this is the first time I have needed to burn a DVD).

the options I used were:

dvdrecord -v dev=ATAPI:0,0,0 speed=4 delay=0 -dao ns.iso

interestingly enough when I put '-dummy' as an option it goes through the motions just fine. so this IS an I/O issue and I believe that I have a broken hardware interface. (ie whatever driver is trying to access the drive is just not doing what it's meant to do).

thanks in advance to anyone who replies :)


eccles23 10-27-2004 06:59 PM

I got it working using ide-scsi...
I had forgotten to run lilo to apply the changes I made to the config file the first time I tried it...
but now it works (although I had to do a 'modprobe ide-scsi' to load the driver).
in SuSE 9.1 where is the best place to put the ide-scsi alias line?
nothing seems to be in modules.conf... and it seems that there is a /etc/init.d/modules.d.local file (or something) that I am meant to use... what's the exact line I should do?

timomeinen 11-03-2004 04:50 PM

My Last Hope
Hi eccles23,

I have a new NEC ND-3500 DVD Burner but I always get the same "OPC Failure". After 2 days of experimentation I don't have ideas anymore. I am on the brink of depression. :-)

I read, that you got the problem fixed. Could you give me a little howto, please?

I set the ide-scsi in grub vor the device and modified the fstab. K3b successfully found it but now it needs over 3 minutes until it says "growisofs -> opc could not be performed". Normally the OPC failure occurrs after 20 seconds.

Thanks for help
Timo Meinen

K3b 0.11.17
KDE 3.2.1
growisofs 5.21
cdrecord 2.01a35

All times are GMT -5. The time now is 12:37 PM.