LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   DVDbackup "NEW COPY PROTECTION?" Dummy Sectors? (https://www.linuxquestions.org/questions/linux-software-2/dvdbackup-new-copy-protection-dummy-sectors-291552/)

elyk1212 02-17-2005 05:54 PM

DVDbackup "NEW COPY PROTECTION?" Dummy Sectors?
 
Hi all!

When attempting to back up our DVD, "The Forgotten", I was unable to complete the process using dvdbackup. The problem area is the VOB files with the main feature included. This is the same case with "The Grudge" DVD and when searching around the net, other users have had the same issues (mainly on Mac OS X DVDbackup).

Anyhow, I have found a windows solution to the issue, that involves a program called DVDDecrypter_3.5.2.0. This program inserts what it called "Dummy Sectors" [into the stdin of the file stream (I assume)]. Anyhow the output of the program states "Inserting Dummy sectors" when the problematic VOB files are accessed and decrypted.

Does anyone have a DVD backup solution algorithm for linux that bypasses this issue? I really would not like to go into windows just to back up disks, I can do so much more in linux...

Thanks in advance,
Kyle

elyk1212 02-17-2005 08:41 PM

Anyone with this same issue? I know someone must have seen this.

Electro 02-18-2005 12:20 AM

Did you try using mplayer's mencoder or transcoder.

elyk1212 02-18-2005 12:47 AM

Thx for the response. Does mencoder get distributed with the mplayer tarball? Or is a seperate program distributed on uhulinux.hu?

Oh by the way here is the software info I am using:

libdvdread: Using libdvdcss version 1.2.8 for DVD access


And, also available on my system are:
libdvdcss2-1.2.8-1plf
libdvdread3-0.9.4-3mdk
dvd+rw-tools-5.21.4.10.8-2mdk
libdvdcss2-devel-1.2.8-1plf

elyk1212 02-18-2005 07:40 PM

Come on fellow DVDbackup enthusiests... This problem will present itself to us should it not be solved in dvdcss in later versions etc. Please let's discuss ... :)

Lleb_KCir 02-18-2005 09:16 PM

well i have never messed with what you are doing but i have copied a few of my disney movies from my DVDs to the HD so i dont burn up the DVD or my DVD player with as much as my kids watch several shows like Nemo and Shrek.

for both of those i just used DVD::RIP and converted them to avi files. dont know if that helps or not sorry, but i hear DVD::RIP is very good at making copies of DVDs.

elyk1212 02-22-2005 01:02 PM

Hi there,
Thank you for the suggestion. It looks like that is a PERL module..? That's cool, PERL is fun. Anyhow, the dvdcss software will decrypt all older movies that do not implement this macroVision protection (actually only the NEWEST movies use this and it is only implemented by a few companies I have seen so far, but it look like it COULD* become the standard).

theturtle 02-27-2005 09:34 AM

I would post this question to doom9.org forums. I've seen this problem on The Forgotten dvd on some windows ripping apps as well. Your right it pertains to Structure Protection Sectors that are on the dvd. libdvdread is having some issues with the ifo sounds like. IFO pointing to bad sectors that just need to be padded with dummy sectors, it's not an actual disc reading error such as a scratch or anything.. I'm not an expert by any means, infact i'm a complete newb. If i run into this as well, i'll sure be posting to libdvdread mailing list.

elyk1212 03-03-2005 08:18 PM

Quote:

There is no website configured at this address.
I hope they ar e up soon, I am anxious to try them out. Thanks again for your suggestion. I am hoping this protection is addressed in CSS or libdvdread as to avoid using winbloze, which is a huge inconvenience for me, all my PCs are Linux :D (except my laptop, but it only has a 10GB harddrive)

bglnelissen 03-03-2005 09:00 PM

restrictions?
 
I solved my restriction problem.

I uninstalled all libdvd**** packages and removed all files and symbolic
links from /usr/lib and /usr/local/lib to any files starting with libdvd.

Then I installed all libdvd**** packages again and also installed libdvdcss2
from plf again (found it at
http://public.planetmirror.com/pub/p...rake/10.0/i586)

Then i removed all hidden directories regarding ogle, dvdcss and xine. E.g.
rm -rf .xine .ogle .dvdcss

Then running Xine for the first time I set the Region = 2 in the xine setup
under the input tab

Success!!!! Now I am playing any DVD!
so mightbe you can encode any DVD now?...

elyk1212 03-11-2005 07:57 PM

Hi bglnelissen,
Sounds promising, however, the oddity was I could play the movie but not use dvdbackup to backup the movie. Sounds counter intuitive doesn't it?

bglnelissen 03-12-2005 09:08 AM

well, cant help you than.
Luck with your ripping 'problems'
bas

tw001_tw 03-12-2005 11:03 AM

elyk1212,

Have you tried the script here at LQ?

http://www.linuxquestions.org/questi...64#post1509264
Here is version=0.186a (newest)
I havn't tired it yet, but ver .15b through .17b worked fine for me. (found earlier in the same thread)
-tw

elyk1212 03-28-2005 03:51 PM

Hi again.
I have not tried out the script yet. I will check it out. Thanks.

I have a solution that involving wine. I used DVDDecrypter for windows within wine. The only issue was this software not seeing and DVD/CD rom devices. The solution was to use 'ide-scsi' emulation accomplished by the following in Mandrake 10.1/

Addition into /etc/modprobe.preload of [exact text]:
ide-scsi

Addition int /etc/lilo.conf of:
under append directive:
append="acpi=ht resume=/dev/hda6 splash=silent hdc=ide-scsi"

Note just add hdn=idescsi before the ending quote on the append directive [where n is your DVD drive letter].

After this DVDdecrypter is hella buggy and there were these write permission messages that pop up in the beginning, but I am able to decrypt to the 'c' directory dictated by wine.

ISSUE!:
I am unable to change the destination folder for the files. The folder selection GUI shows a 'desktop' tree and no branches appear (you cannot browse the file system).

ANYONE know a wine configuration what would allow this, or perhaps a linux tweek?

elyk1212 03-28-2005 03:54 PM

For the search engines:
----------------------------------------
Linux DVD rippers don't yet get around the new Sony Arccos copy protection,
but I'm told DVD-Decrypter works. Has anyone gotten it to work on Linux? I've read a few
threads that claim it does, but when I run it under wine it doesn't find any DVD/CD devices.
(wanting to backup "The Forgotten" with this new
copy protection)
----------------------------------
[taken from form at:
http://forums.afterdawn.com/thread_view.cfm/164009

Which helped me solve my problem. Hope to see dvdbackup implement the work around for Arccos.


All times are GMT -5. The time now is 10:47 AM.