LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   DVD Region problem HELP!!!!! (https://www.linuxquestions.org/questions/linux-software-2/dvd-region-problem-help-78340/)

skip1 08-02-2003 01:31 PM

DVD Region problem HELP!!!!!
 
hey,
I've got a reeeaallly annoying problem. I've recently bought a new DVD-ROM 16x drive to replace my old one (cos my old one was a crappy colour and slow). So I hook it up to my pc and everything is sweet.

BUT

I CAN'T WATCH DVDs UNDER LINUX!!! - because I get this error message in xine, "Your DVD is probably crypted. According to your country laws, you can or can't install/use libdvdcss to be able to read this disc, which you bought (Playback aborted)"

Now, all my DVDs are region 2, and my DVD drive is also region 2, so there should be no problem. They work fine under windows though. I've tried flashing the drive's firmware but that doesn't solve my problem.

Any ideas? I'm completely stumped and pissed off.

Thanks

Looking_Lost 08-02-2003 01:45 PM

I don't know mandrake but I think I've heard on here that to keep themselves safe from any proseceution no matter how slim the chance is the default dvd player software doesn't support decryption a bit like in red hat there is no support for playing mp3's by default (big scaredy cats)



probably getting a hold of the libdvdcss packages will solve this. It's not a problem with your hardware I don't think.

DrOzz 08-02-2003 01:47 PM

i don't know if this will help but i will leave you with this page and you can see if there is any helpful information on that site...i noticed when i quickly browsed through it that regions shouldn't be an issue in linux so this article says, but this article in turn could be pointless to you but i'll let you be the judge of that :D
http://www.katspace.net/computers/linux_dvd.php
i also read something about disable RPC (which i have no idea what this is) but whatever it is i'll let you also research that ...
hopefully you find a fix or someone can give you a flat out answer

skip1 08-02-2003 02:04 PM

Hmmm. I already have libdvdcss installed. I'll re-install it and see what happens.

Corin 08-02-2003 03:26 PM

The issue here is not the Region Code, but the fact that like most commercial DVDs, the contents are encrypted with CSS.

It does not matter whether or not you have libdvdcss installed if the version of xine you are running has not been compiled to use libdvdcss support!

So re-installing libdvdcss is probably pointless.

What you need to do is to either find an rpm with xine compiled with dcss support, or download the source code and build it yourself.

Alternately, you could install ogle, ensuring that it is a version compiled with decss,which although much more crude an interface, I have found gives the best results for playing encrypted DVDs, and also ignores the region code on the disk, enabling me to play without any problem encrypted region 2 disk on a region 1 DVD drive.

I have found that a really good places to look for rpms is

http://rpm.pbone.net/

where we find for Mandrake 9.0

http://rpm.pbone.net/index.php3?idpl....i586.rpm.html

You may also have to install a xine-plugins rpm as well.

And as I suggested whilst you are there, do a search for ogle as well.

skip1 08-04-2003 04:49 AM

Thanks for your help, I'll download those RPMs and let you know what happens.

The funny thing about this is that before I replaced my DVD drive I could watch any DVD without any problems.

Its just since I put my new drive in that it doesn't work. Any idea why this may be?

I'm pretty new to linux so I'm not sure if you're suppost to re-configure anything when you change hardware.

Corin 08-04-2003 09:00 AM

Well if the only change you made was replacing an older DVD drive with a new one, then the reason is due to the fact that the old DVD drive was a region free enabled drive, and that the new one (as they now have to
be) is locked to a particular region.

Are you sure you did not update a xine rpm from Mandrake as well during this period, since it appears that Mandrake has turned off dcss support
in xine for legal reasons?

If I understand correctly, the way that a DVD disc identifies itself is simply by a file at the beginning of the disk with the number 1, 2, 3, or 4 etc in it, which the commercial dvd playing software then compares with the region setting from the firmware on the DVD drive.

Please let us know how you get on with installing the updated rpms.

skip1 08-05-2003 04:38 AM

man i hope hope i haven't thrown away my old region-free drive then!!! If my new dvd drive is region 2 locked then it should still be able to read my region 2 dvds. Man, oh man.

Re-installing libdvdcss didn't work, and neither did another dvd-enabed pre-compiled package. I think I'm gonna re-install mandrake...some other things are going a bit weird too.

Oh, by the way, I downloaded mplayer the other day. And it kinda plays dvds. When i hit play, the intro screen plays (Pathe, Dreamworks etc) but then an error message pops up saying 'there are too many video packets in the buffer, 4096 in 328472343'.

I've looked at the MPlayer help and apparently this means my pc is too slow, but thats no way true. Anyone have experience with MPlayer??

Specs:
AMD Athlon XP 2200 @ 1.8Ghz
ABIT KD-7 Mobo 333MhzFSB
256 Mb DDR Ram
MSI DVD-ROM 16x (Man i hate MSI)
....and loads of other stuff which doesn't really matter.

Corin 08-05-2003 03:42 PM

How come you have not downloaded ogle as previously recommended?

MPlayer is a very useful tool to have but is still in development and its performace leaves somewhat to be desired.

If you had read the home page for MPlayer, you would have learnt that the developers are working on a completely new version MPlayer2 from scratch, since the current version is so cobbled and held together with bits of string, that a complete redesign is necessary. This always happens when software is not built from a solid design framework and bits and pieces are just added on as people see a need, which is what has happened with MPlayer.

So, before trying to use something as complex as Mplayer, which requires lots of extras, like external codecs, gui, skins etc, why not give ogle a try and see if a simple, not fancy, DVD player will work.

Once you have established that the simple case works, you can try the more complicated Mplayer and optimizing it for your system.

Makes sense, huh?

skip1 08-06-2003 03:52 AM

yeah i've tried Ogle. It just crashes.

Corin 08-06-2003 03:34 PM

Sounds like something really is messed up with your libraries then.

AquamaN 08-06-2003 04:19 PM

get mplayer, works great.

-AquamaN

Corin 08-06-2003 07:22 PM

Quote:

Originally posted by AquamaN
get mplayer, works great.
Aquaman : did you bother to read the preceeding posts?

skip1 wrote in a previous post that mplayer was not working properly for him.

skip1 08-08-2003 04:57 PM

well, I've completely wiped linux from my pc. I've ordered Mandrake 9.1 from ebay and it should arrive pretty soon. maybe the newer version is slightly better, i dunno.

it soooo annoying: now my keyboard doesn't work when i log out of mandrake. works fine to begin with, but as soon as I log out I can't type. <BIG SIGH>

sorrodos 08-08-2003 05:07 PM

If you can't get Mandrake 9.1 to work, try SuSE 8.2. It doesn't come enabled for DVD playback, but if you uninstall all xine rpms, and download the ones from the below site, it should work. I did it and it works great. Make sure you set your DVD drive to DMA mode though.

http://packman.links2linux.org/


All times are GMT -5. The time now is 01:28 PM.