LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-05-2006, 07:47 AM   #1
albatros_la
LQ Newbie
 
Registered: Sep 2004
Posts: 13

Rep: Reputation: 0
DVD:filenames more than 103 characters long?


Is there a way to burn a dvd (or a cd) adding files with filenames more than 103 characters long? It seems impossible using k3b because the limit of 103 characters is fixed by joliet standard. So k3b adds files to compilation but when I try to launch the burn process it stops saying that is going to truncate files with filenames too long...
Thanks in advance for any comment of suggestion you can give me!
 
Old 04-05-2006, 08:44 AM   #2
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Debian, Arch
Posts: 8,507

Rep: Reputation: 128Reputation: 128
On a DVD, I think you could remove Joliet support, providing that UDF was enabled. If UDF is used to read the disc then, longer filenames should be no problem.
 
Old 04-05-2006, 09:07 AM   #3
albatros_la
LQ Newbie
 
Registered: Sep 2004
Posts: 13

Original Poster
Rep: Reputation: 0
Thank you for the answer. I've found out that joliet is needed only by Window$ and it's limited to 64 characters per filename. Then there's joliet-long format which supports up to 128 characters filenames. But if I want a linux-only dvd, I can use rockridge extension, which seems to have no limitations on filenames' length, but dvd remains unreadable on Window$ machines.
 
Old 04-05-2006, 09:38 AM   #4
jagerhans
LQ Newbie
 
Registered: Dec 2003
Location: italy
Distribution: debian lenny , lubuntu 11.10
Posts: 10

Rep: Reputation: 0
well, take this without guarantees. i've tried to make an ISO image with mkisofs that contains a file name longer than 103 chars. the file is contained in the single directory i want to copy.


here the commandline: mkisofs -r -J -l -D -L -joliet-long -V -P -p -abstract -biblio -o ./myimage.iso -graft-points /=/mnt/hdb/musica/italiani

this is the commandline output generated by x-cdroast. some options may be superfluous.
then I tried to mount it to check out, with:

# mount -o loop myimage.iso ./somedirectroy -tiso9660

effectively mkisofs created an ISO image containing one file with a filename exceeding 170 chars. maybe it works for you too. try to make an ISO image using mkisofs and then burn it.

hope this helps
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How get rid of funny characters in filenames? Bengan Mandriva 11 01-07-2006 11:38 AM
Special characters in filenames gmartin Linux - General 2 01-05-2006 08:22 PM
bash and filenames with special characters CoolAJ86 Programming 2 03-09-2005 02:50 PM
sftp with filenames and weird characters Nevion Linux - Software 1 05-28-2004 05:29 AM
smbclient and filenames with special characters cloro_x Linux - Newbie 0 07-30-2001 04:15 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration