-   Linux - Software (
-   -   DVD Decrypter (via Wine) not detecting DVD drive (

DirkDiggler 06-03-2007 11:59 PM

DVD Decrypter (via Wine) not detecting DVD drive

I've resarched this problem, and tried a solution I found, but to no avail. In tools-settings and in the I/O tab, you can set it to WINASPI32.DLL (I believe thats what it is) and that did nothing. Can anyone advise as to what I should do?



KenJackson 06-04-2007 06:46 AM

try this:

ls -l ~/.wine/dosdevices

You should see an entry something like this.

lrwxrwxrwx 1 ken 10 Aug 7 2006 d: -> /dev/cdrom

If you don't see it, make it. If your cdrom isn't on /dev/cdrom, then change it.

cd ~/.wine/dosdevices
ln -s /dev/cdrom d:

DirkDiggler 06-04-2007 09:14 AM


I followed the instructions you gave and no bueno. Here is what dos devices had in it before any changes:

lrwxrwxrwx 1 BadMammaJamma BadMammaJamma 10 2007-06-03 12:25 c: -> . ./drive_c

lrwxrwxrwx 1 BadMammaJamma BadMammaJamma 1 2007-06-03 12:25 z: -> /

I then followed the instructions you gave. I'm assuming the drive letter d: you gave is because you're assuming that's what it is in my particular Windows setup. it's actually e:, but I made two entries just in case. In addition to above, I added this:

lrwzrwxrwz 1 BadMammaJamma BadMammaJamma 10 2007-06-04 09:55 d: -> /dev/cdrom

lrwxrwxrwx 1 BadMammaJamma BadMammaJamma 10 2007-06-04 09:53 e: -> /dev/cdrom

Now, I'm pretty sure my DVD drive resides at /dev/cdrom is there any way I can double check that. I think the only reason those commands wouldn't have worked is because the drive doesn't reside at /dev/cdrom.



lazlow 06-04-2007 10:37 AM

Try this. Mount the disk in the drive and then start wine.

Right now F7 is going through it's interesting quirks stage. Hopefully in within a week there should be a huge update (gnome anyone) to help with a lot of these issues. You could also look at the solutions for earlier versions.

Good Luck

DirkDiggler 06-04-2007 07:16 PM


I did make sure to have the DVD in the drive, mounted when I ran Wine. Still no go. This update, would it be a kernel update to 2.6.21-3? I've seen people with this kernel, not Fedora 7 though. I'll wait for this to come out and we'll see what happens. If anyone else has any other ideas, please share.



lazlow 06-04-2007 07:30 PM

I was not speaking about anything in particular. Just that in the first month or so after release there are always a ton of updates.

I just tried DVDshrink and it seems to behave normally (after shutting off the sound).

DirkDiggler 06-06-2007 08:26 PM


Stupid me, I didn't know that Wine had to be configurd first, but NONE of the configurations worked. So, this is what I did. Please let me know of any errors. I added two programs, DVD Decrypter and DVD Shrink. I need to use DVD Decrypter first, I have not attempted to use Shrink. I put the OS as Windows NT 4.0 (I also tried XP ad 2000). I autodetected my drives. It detected the mount points of my cdrom, Windows and a shared vfat drive. Under the advanced options for my cdrom, I put that it was a cdrom (I also left it as local hard drive). After doing that I fired up DVD Decrypter, it didn't detect any drives. Under I/O options, I tried ASPIWIN32.DLL, and SPTI. Absolutely nothing has worked. If anyone could please advise further, I would greatly appreciate it.



edit: I did also try to manually add a device by the commands listed above, and also by the way the user manual on indicates and neither of those worked.

Unmindfulawe 06-06-2007 08:44 PM

Did you check out this link yet?

DirkDiggler 06-06-2007 09:06 PM


Thanks for the quick reply. I did not know of that site, but I went ahead and tried to link to cdrom by their directions and still nothing. Differing from the directions slightly trying another method, I created a link (-s means soft link, right?) to the mount point of my cdrom for the first step. I followed the directions for the second step to a tee.

Any other ideas?



lazlow 06-06-2007 09:33 PM


I just checked mine. Try defining it as /dev/scd0 (the softlink). The switch in drives in F7 (hda vs sda) makes everything seen as scsii format (I think).

DirkDiggler 06-06-2007 10:45 PM


I tried with both scd and scd0. Neither worked.



Unmindfulawe 06-07-2007 01:12 PM

Did you check your /etc/mtab file to make sure that you are mounting the correct device? I think mtab will make it more clear where your dvd device is mounted. Pop in a CD or DVD and open up your mtab file. Once you found a device that looks like your dvd device make sure by initiating the following command as the root user...

(as an example my dvd device is listed in mtab as the following...

/dev/hdd /media/DVD iso9660 ro,nosuid,nodev,noatime,uid=1004,utf8 0 0)
Device Directory file type

I can be sure of the above is my DVD drive because of two conditions 1. iso9660 2. when I execute the following command as root the drive pops open.

eject /dev/hdd

now you have determined the exact location of your drive. When you get that far you have to make sure that you execute the following commands.

cd ~/.wine/dosdevices

rm d:

ln -s /media/DVD -s d: //Dirk modify this to reflect which directory your DVD drive is mounted.

ln -s /dev/hdd -s d:: //Dirk modify this to reflect which device your DVD is.

Then initiate the following.


under the applications tab you should see DVDDecrypter.exe and when you click on that app you should see the "Windows Version" Box change to "Windows NT 4.0". If this did not happen change "DVDDecrypter.exe" to "Windows NT 4.0".

Hope that helps.

DirkDiggler 06-07-2007 04:00 PM


Thanks Unmindful. I'll perform these commands when I make it home tonight and give you an update later.



All times are GMT -5. The time now is 09:08 PM.