LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   DVD Burner Ruins Data DVD (https://www.linuxquestions.org/questions/linux-software-2/dvd-burner-ruins-data-dvd-425882/)

natewlew 03-17-2006 07:34 PM

DVD Burner Ruins Data DVD
 
I have an 8x Hi-Val dvd burner. I have been able to write a dvd-r at 4x with limited problems. (2x seems to give better results). Just recently K3B won't write any faster than .7x. It took about 2 hours to burn a full disc. Then it messed it up. I went to view the pictures on my disc and it lock up my burner (a common problem when it burns faster than 4x).
So I installed Nero Demo to see if that would help and it says I don't have the right drivers.
I also tryed growisofs and it failed at about 25%.
I'm not sure if my problem is drivers,software or that I just need a new burner?
Can someone please help?

1.3g amd
256mb ram
40g hd

p.s. I really like the spell ckeck built into the forum (firt time I have ever seen that).

DeusExLinux 03-18-2006 12:06 AM

Quote:

p.s. I really like the spell ckeck built into the forum (firt time I have ever seen that)
You must really neetd it. :) I do too!

But, did you install the Nero demo in Windows? or in Linux? (does Nero have a native linux version, or were you running through wine?)

If it messed up in both Windows and Linux, I would say it's a drive problem, otherwise (if it worked before), it should be a problem with K3B, or one of the programs it requires. Have you updated anything else recently? Did you even upgrade K3b?

There might be a way to run a system-test on the drive, one time I had one that, for some reason, decided it was too good to burn DVDs and would only burn CDs. Check the manual.

...and I do assume that you have DVD+R tools installed,right?

natewlew 03-18-2006 03:40 AM

Yes, nero has an rpm and a deb (the deb installed ok).

I borrowed my brothers sony 16x dvd-burner and got a speed of 1.5x (better) and it didn't ruin any of my files. I guess its my dvd burner thats breaking the files. Thats what I get for buying hi-val.

I updated kpackage thinking it was Karchiver.:scratch:
That could have been my problem but I'm not sure. I don't think I updated K3B.

I just did a smart update and I guess it installed KDE 3.5. All of my K programs were messing up. I had started to use Nautilus and it changed my desktop to the default debian gnome background. It also changed my trash to wastebasket (don't know how that happened).

All of my kde programs are running now with the KDE 3.5 but I still can't seem to burn a 4.1gig iso image. I tryed to burn a small file and it started fine.

Here is the K3B error report:

Devices
-----------------------
DVD-ROM 16X 5.KV (/dev/hdd, ) at /media/cdrom1 [CD-ROM; DVD-ROM; DVD+R] [DVD-ROM; DVD+R Double Layer; CD-ROM] [None]
SONY DVD RW DRU-810A 1.0a (/dev/hdc, ) at /media/cdrom0 [CD-R; CD-RW; CD-ROM; DVD-ROM; DVD-R; DVD-RW; DVD+R; DVD+RW] [DVD-ROM; DVD-R Sequential; DVD-RW Restricted Overwrite; DVD-RW Sequential; DVD+RW; DVD+R; DVD+R Double Layer; CD-ROM; CD-R; CD-RW] [SAO; TAO; RAW; SAO/R16; RAW/R96R]

System
-----------------------
K3b Version: 0.11.20
KDE Version: 3.5.0
QT Version: 3.3.4
Kernel: 2.4.27-2-386

growisofs
-----------------------
Executing 'builtin_dd if=/home/user/dvd.iso of=/dev/hdc obs=32k seek=0'
:-( write failed: Invalid argument

growisofs comand:
-----------------------
/usr/bin/growisofs -Z /dev/hdc=/home/freaky/dvd.iso -use-the-force-luke=notray -use-the-force-luke=tty -speed=16


You must really neetd it. I do too!
Must be a Linux thang!:study:

haertig 03-20-2006 04:28 PM

Unlike most CD's, DVD's can be a bit finicky to burn and read. You really can't expect to pick up "any-old-el-cheapo" DVD media, shove it into "any-old-generic-burner", and come up with a disc that is universally readable on "every-other-DVD-reader" out there.

CD's used to be like this too when they first became available, but they're pretty much commodity items now. Quality varies, but for the most part anything can read/burn any CD media (knock on wood!) It would be nice if DVD's were mature to this level, but they're not. For my NEC burner, Verbatim DVD's are my first choice for best quality and best readability on readers other than the one that burned it. Other brands of burners might (and probably do) prefer other brands of media. I don't know what would work best in your Hi-Val. I believe Hi-Val is a generic rebrander. The actual drive may be a NEC, Lite-ON, BenQ, etc. and probably not the newest or best drive available from whatever manufacturer actually made the thing.

natewlew 03-26-2006 03:41 PM

I just bought a new Sony DVD Burner. I still seem to be having trouble. I get a 1.0x average on a 16x burner. I believe my problem is growisofs. Every time I burn something I get a growisofs in/out error. It seems like half of my discs are coasters. I have tryed to reinstall everything I can think of but I guess reinstalling doesn't help. I have updated my whole system but that doesn't change anything. Does anyone know of anyway to fix this without having to reinstall Debian?

P.S. I don't know how to do a drive test.

DeusExLinux 03-26-2006 04:13 PM

what about dvd-r tools? Did you try re-installing it?

One time I had an issue burning DVD-R (and DVD+R), it would only do RW.

haertig 03-26-2006 06:06 PM

Quote:

Originally Posted by natewlew
I get a 1.0x average on a 16x burner. I believe my problem is growisofs.

What kind of media are you putting in the burner? When you say you have a 16x burner, that does not mean it will burn every DVD at 16x. There are usually different max speeds for -R, +R, -RW, +RW, and DoubleLayer DVD's. Add to that the complexity of different brands of media burning at different max speeds. Cheaper media may not even burn at the max speed it says it can. And some burners prefer certain brands of media over others. NECs generally like Verbatim, so I might be able to burn my Verbatim +R 8x media at 8x, but your Sony may only burn them at 4x (just an example - I don't know how Sonys work with Verbatim). You can also tell your burning software what speed to burn at. You wouldn't be telling growisofs to burn at a max of 1x would you? (That would be the parameter " -speed=1 ")

Below is my burner, a NEC ND3540A (which is "a 16x burner"), with three different types of media in it (I don't have any 16x media on hand to demonstrate with). Output has been manually cut down to only the relevent info related to speed. You can see my max burning speeds vary with the media inserted.
Code:

$ dvd+rw-mediainfo /dev/dvdrw
INQUIRY:                [_NEC    ][DVD_RW ND-3540A ][1.01]
GET [CURRENT] CONFIGURATION:
 Mounted Media:        1Ah, DVD+RW
GET [CURRENT] PERFORMANCE:
 Write Performance:    2.4x1385=3324KB/s@[0 -> 2295104]

Code:

$ dvd+rw-mediainfo /dev/dvdrw
INQUIRY:                [_NEC    ][DVD_RW ND-3540A ][1.01]
GET [CURRENT] CONFIGURATION:
 Mounted Media:        11h, DVD-R Sequential
GET [CURRENT] PERFORMANCE:
 Write Performance:    4.0x1385=5540KB/s@[0 -> 2297888]

Code:

$ dvd+rw-mediainfo /dev/dvdrw
INQUIRY:                [_NEC    ][DVD_RW ND-3540A ][1.01]
GET [CURRENT] CONFIGURATION:
 Mounted Media:        1Bh, DVD+R
GET [CURRENT] PERFORMANCE:
 Write Performance:    4.0x1385=5540KB/s@[0 -> 442367]
                        6.0x1385=8310KB/s@[442368 -> 1155071]
                        8.0x1385=11080KB/s@[1155072 -> 2295104]


daihard 03-26-2006 06:34 PM

Quote:

Originally Posted by DeusExLinux
what about dvd-r tools? Did you try re-installing it?

One time I had an issue burning DVD-R (and DVD+R), it would only do RW.

I remember having a similar problem where the DVD burner doesn't write nearly as fast as it can. The problem was with one of the dvd tools that came with my Linux distro - I had to download and compile a newer version. That fixed the problem. I just wish I remembered exactly which tool it was. :scratch:

natewlew 03-29-2006 02:29 PM

When I run the command:
debian:/home/user/# dvd+rw-mediainfo /dev/hdc
INQUIRY: [SONY ][DVD RW DW-Q30A ][YYS3]
GET [CURRENT] CONFIGURATION:
Mounted Media: 11h, DVD-R Sequential
Media ID: MCC 03RG20
Current Write Speed: 16.0x1385=22160KB/s
Write Speed #0: 16.0x1385=22160KB/s
Write Speed #1: 12.0x1385=16620KB/s
Write Speed #2: 8.0x1385=11080KB/s
Write Speed #3: 6.0x1385=8310KB/s
GET [CURRENT] PERFORMANCE:
Write Performance: 6.4x1385=8864KB/s@[0 -> 0]
Speed Descriptor#0: 00/0 R@6.4x1385=8864KB/s W@16.0x1385=22160KB/s
Speed Descriptor#1: 00/0 R@6.4x1385=8864KB/s W@12.0x1385=16620KB/s
Speed Descriptor#2: 00/0 R@6.4x1385=8864KB/s W@8.0x1385=11080KB/s
Speed Descriptor#3: 00/0 R@6.4x1385=8864KB/s W@6.0x1385=8310KB/s
READ DVD STRUCTURE[#10h]:
Media Book Type: 25h, DVD-R book [revision 5]
Legacy lead-out at: 2298496*2KB=4707319808
READ DVD STRUCTURE[#0h]:
Media Book Type: 25h, DVD-R book [revision 5]
Last border-out at: 2298496*2KB=4707319808
READ DISC INFORMATION:
Disc status: blank
Number of Sessions: 1
State of Last Session: empty
Number of Tracks: 1
READ TRACK INFORMATION[#1]:
Track State: invisible incremental
Track Start Address: 0*2KB
Next Writable Address: 0*2KB
Free Blocks: 2297888*2KB
Track Size: 2297888*2KB
READ CAPACITY: 0*2048=0

I have also reinstalled Debian.


All times are GMT -5. The time now is 07:04 PM.