-   Linux - Software (
-   -   DVD burner don't burn dvd anymore (but burn cd without problem) (

0kage0 11-28-2010 11:45 AM

DVD burner don't burn dvd anymore (but burn cd without problem)
my DVD Burner is a MATSHITA BD-CMB UJ-120
i'm running DEBIAN SQUEEZE
In the past using Kubuntu (until 9.10) it burned DVD without problems
other info are in the k3b debug output


i don't know what to do


MATSHITA BD-CMB UJ-120 1.00 (/dev/sr0, CD-R, CD-RW, CD-ROM, DVD-ROM, DVD-R, DVD-RW, DVD-R DL, BD-ROM, DVD+R, DVD+RW, DVD+R DL) [DVD-ROM, DVD-R sequenziale, DVD-R sequenziale a doppio strato, DVD-R jump a doppio strato, DVD-RAM, DVD-RW a riscrittura limitata, DVD-RW sequenziale, DVD+RW, DVD+R, DVD+R a doppio strato, CD-ROM, CD-R, CD-RW, BD-ROM] [SAO, TAO, Riscrittura limitata, Livello Jump] [%7]

mkisofs print size result: 2219746 (4546039808 bytes)

K3b Version: 2.0.0
KDE Version: 4.4.5 (KDE 4.4.5)
QT Version:  4.6.3
Kernel:      2.6.32-5-amd64

Used versions
mkisofs: 1.1.11
cdrecord: 1.1.11

/usr/bin/wodim: Operation not permitted. Warning: Cannot raise RLIMIT_MEMLOCK limits.
scsidev: '/dev/sr0'
devname: '/dev/sr0'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Wodim version: 1.1.11
SCSI buffer size: 64512
Beginning DMA speed test. Set CDR_NODMATEST environment variable if device
communication breaks or freezes immediately after that.
TOC Type: 1 = CD-ROM
Driveropts: 'burnfree'
Device type    : Removable CD-ROM
Version        : 5
Response Format: 2
Capabilities  :
Vendor_info    : 'MATSHITA'
Identification : 'BD-CMB UJ-120  '
Revision      : '1.00'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Current: 0x001B (DVD+R)
Profile: 0x0040 (BD-ROM)
Profile: 0x0012 (DVD-RAM)
Profile: 0x002B (DVD+R/DL)
Profile: 0x001B (DVD+R) (current)
Profile: 0x001A (DVD+RW)
Profile: 0x0013 (DVD-RW restricted overwrite)
Profile: 0x0014 (DVD-RW sequential recording)
Profile: 0x0016 (DVD-R/DL layer jump recording)
Profile: 0x0015 (DVD-R/DL sequential recording)
Profile: 0x0011 (DVD-R sequential recording)
Profile: 0x0010 (DVD-ROM)
Profile: 0x000A (CD-RW)
Profile: 0x0009 (CD-R)
Profile: 0x0008 (CD-ROM)
Profile: 0x0002 (Removable disk)
Using generic SCSI-3/mmc DVD-R(W) driver (mmc_mdvd).
Supported modes: PACKET SAO
Drive buf size : 7602176 = 7424 KB
FIFO size      : 12582912 = 12288 KB
Speed set to 5540 KB/s
Track 01: data  4335 MB       
Total size:    4978 MB (493:16.61) = 2219746 sectors
Lout start:    4979 MB (493:18/46) = 2219746 sectors
Current Secsize: 2048
HINT: use dvd+rw-mediainfo from dvd+rw-tools for information extraction.
Blocks total: 2295104 Blocks current: 2295104 Blocks remaining: 75358
Starting to write CD/DVD at speed  4.0 in real SAO mode for single session.
Last chance to quit, starting real write in    2 seconds.
  1 seconds.
  0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... Errno: 5 (Input/output error), reserve track scsi sendcmd: no error
CDB:  53 00 00 00 00 00 21 DE E2 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 04 00 00 00 00 0A 00 00 06 31 09 90 00 00
Sense Key: 0x4 Hardware Error, Segment 0
Sense Code: 0x09 Qual 0x90 (track following error) [No matching qualifier] Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 3.708s timeout 200s
/usr/bin/wodim: Cannot open new session.
input buffer ready.
Writing  time:    3.743s
/usr/bin/wodim: fifo had 192 puts and 0 gets.
/usr/bin/wodim: fifo was 0 times empty and 0 times full, min fill was 100%.

cdrecord command:
/usr/bin/wodim -v gracetime=2 dev=/dev/sr0 speed=4 -sao driveropts=burnfree -data -tsize=2219746s -

I: -input-charset not specified, using utf-8 (detected in locale settings)
  0.02% done, estimate finish Sun Nov 28 22:14:04 2010
  0.05% done, estimate finish Sun Nov 28 20:27:05 2010
  0.07% done, estimate finish Sun Nov 28 19:50:43 2010
  0.09% done, estimate finish Sun Nov 28 19:31:57 2010
  0.11% done, estimate finish Sun Nov 28 19:21:05 2010
  0.14% done, estimate finish Sun Nov 28 19:13:47 2010
  0.16% done, estimate finish Sun Nov 28 19:08:34 2010
  0.18% done, estimate finish Sun Nov 28 19:04:31 2010
  0.20% done, estimate finish Sun Nov 28 19:01:29 2010
  0.23% done, estimate finish Sun Nov 28 18:59:02 2010
  0.25% done, estimate finish Sun Nov 28 18:57:03 2010
  0.27% done, estimate finish Sun Nov 28 18:55:20 2010

mkisofs calculate size command:
/usr/bin/genisoimage -gui -graft-points -print-size -quiet -volid Progetto dati K3b -volset  -appid K3B THE CD KREATOR (C) 1998-2010 SEBASTIAN TRUEG AND MICHAL MALEK -publisher  -preparer  -sysid LINUX -volset-size 1 -volset-seqno 1 -sort /tmp/kde-kage/k3bYl4084.tmp -rational-rock -hide-list /tmp/kde-kage/k3bna4084.tmp -joliet -joliet-long -hide-joliet-list /tmp/kde-kage/k3beB4084.tmp -no-cache-inodes -full-iso9660-filenames -iso-level 3 -path-list /tmp/kde-kage/k3bcs4084.tmp

mkisofs command:
/usr/bin/genisoimage -gui -graft-points -volid Progetto dati K3b -volset  -appid K3B THE CD KREATOR (C) 1998-2010 SEBASTIAN TRUEG AND MICHAL MALEK -publisher  -preparer  -sysid LINUX -volset-size 1 -volset-seqno 1 -sort /tmp/kde-kage/k3bBs4084.tmp -rational-rock -hide-list /tmp/kde-kage/k3bJi4084.tmp -joliet -joliet-long -hide-joliet-list /tmp/kde-kage/k3bsM4084.tmp -no-cache-inodes -full-iso9660-filenames -iso-level 3 -path-list /tmp/kde-kage/k3bRS4084.tmp

frankbell 11-28-2010 08:49 PM

Did you try a different blank DVD, a different burning program, and a different source file? If not, try each option one at a time.

(I have had Brasero choke on a file and K3B burn it successfully, but I must say I've not had the opposite.)

Every once in a while, when I buy one of those 50/100 packs of blanks, a couple of them are bad.

They've gotten so cheap that I figure "luck of the draw" and try a different one.

tordfurden 11-28-2010 08:54 PM

Did you try burning a DVD in Windows? I'll bet that would work, so it must be your configuration or your software, man.

catkin 11-28-2010 09:52 PM

CD+DVD burners use one laser for burning CD and another for burning DVD. It is possible that the DVD burning laser has failed.

0kage0 11-29-2010 12:55 AM

i've tried with brasero and wodim (command line).both failed
however k3b and brasero are both frontend for wodim, so the problem is in wodim or something related to it
i've tried a lot of blank DVDs, also DVD-R (the error is slightly different), the outcome is the same with each one.
i haven't tried with windows, as soon as i can i give it a try and post here the results

All times are GMT -5. The time now is 01:23 PM.