-   Linux - Software (
-   -   Dumb newbie issue: firefox-0.8 cant run after installed... (

michelbehr 03-05-2004 03:46 AM

Dumb newbie issue: firefox-0.8 cant run after installed...

First thing, im running Slack 9.0. I installed firefox-0.8 yesterday, but i cant get it to work. Yesterday it was running, but only when i called startx as non-su. Now it doesnt run AT ALL... :-( And if i wanted to get it running, i had to call firefox from the desktop, you know? If i try to call it from terminal, comes a message "cannot open display" or something... (BTW, i installed xpdf and same thing happened: only open with "run..." command on the desktop)... Well, Im REALLY just beguinning to learn Linux (imagine how hard it was for me to get Slack running!), so... take it easy, ok? :-)

Mega Man X 03-05-2004 04:16 AM

Oi amigo tudo bem ai no Brasil?

First, you should be very proud of yourself in trying out Slackware without much of experience with Linux. First tip I've to give you, is to never startx as root. Start X server always as an normal user and then, and only then, if you need to be root to install, move stuff or whatever, use the su command as you already know.

The second thing you've to know, is where Firefox is installed and how you are calling it. Some folders, programs and other stuff on Linux can only be accessed by root user. I will give you a small how-to installing and running Mozilla Firefox ;).

Create a directory called tmp or temp at your /home/user directory to download stuff. Download then this file:

To keep the system more "organized", I install all programs at /usr/local. So then, as root (only root can do stuff outside /home/user), create a directory called firefox there:

mkdir /usr/local/firefox

Now, copy that file from your temp directory to /usr/local/firefox:

cp /home/user/temp/firefox-0.8-i686-pc-linux-gnu.tar.gz /usr/local/fireforx

Hint: You don't have to type the full name to directories or files. Type the first letters and then "tab" key. Linux will auto-complete the name for you. Now, go to firefox folder and uncompress that file:

cd /usr/local/firefox

tar xvzf firefox-0.8-i686-pc-linux-gnu.tar.gz

now, a folder called firefox will be created, go into the folder with cd command. By now, you should be able to type ./firefox and run it. Don't ;). Instead, create a link to make it executable:

ln -s /usr/local/firefox/firefox /usr/bin/firefox

Now, log out from root (exit) and try typing firefox at the terminal to see if it works... If not, we shall need to change some permissions, but let's see if it works first ;)


michelbehr 03-05-2004 04:39 AM

Thanks! But...
Well, i did exactly what u told... 2 things, though:

1) when i try to run firefox (./firefox) i get this message: (firefox-bin:1644): Gtk-WARNING **: CANNOT OPEN DISPLAY :-(

2) I couldt create the symbolic link: "No such file or directory"

Anyway, by now im getting the same errors messages... :-) Any siggestion?


BTW: Are u brazlian? Can we type portuguese here?

Mega Man X 03-05-2004 05:00 AM

yeah, but I've not been living in Brazil for a long time though :(. I doubt we are allowed to use any other language then english here. It will make also easier to peoples to help you, in the case I cannot :D (most likely I won't, lol).

Let's see. First, I believe that you are running X server right? (any desktop manager will do, KDE, Gnome, Fluxbox). Try giving permissions to Firefox so every user can have access to it. As root, type:

chmod 666 /usr/local/firefox/firefox/firefox
chown 666 /usr/local/firefox/firefox/firefox

Note: substitute the path (/usr/loca/........) to the full path of firefox executable. At my previous post, I think the link did not work because the path was wrong (almost). I think when you uncompress firefox-0.8-i686-pc-linux-gnu.tar.gz, a new directory called firefox is created, and a firefox bin is inside that directory. So to create the link it has to be:

ln -s /usr/local/firefox/firefox/firefox /usr/bin/firefox

Just a guess, I'm on Win95 right now at school (can you believe it...Win95, gheheh).

Well, try giving the permissions first, then run firefox as ordinary user. See if it works. Another guess though.. your slackware distribution is a little bit dated. There might be a little tiny possibility that newer packages of GTK has to be installed in order to make Firefox work. I will not say this or that package because I've no Slack 8.1 box anymore, and at the moment I am in a totally different system :p. But I hope someone will help us here if so is the case ;)

Mega Man X 03-05-2004 05:05 AM

Sorry, you said you are using Slack 9.0. That should work, since I also run Slack 9.0 with Firefox. I thought it was 8.1 (because it stands into your profile ;))... Let's hope the permissions will fix the stuff for you ;)

michelbehr 03-05-2004 05:32 AM

The chmod and chown commands u gave me didnt let me execute firefox as root, but i already fix it... :-) im learning about permissions right now... anyway, same error: gtK-WARNING: cannot open display... and if i try to open firefox with "run...", it just doesnt open, but no error messages appears...

Well... dont know what to do... :/

BTW, if this helps: when i try to open xmms from terminal, it gives me a similar error message: ** CRITICAL **: Unable to open display... And also when i try to open xpdf: cant open display... But in both cases if i open with "run...", on the desktop, it works just fine... (but not firefox, as i mentioned)...

Mega Man X 03-05-2004 05:55 AM

This is a tough one :). Hmmmmmm. I need to get a straight answer before I google for anything.

Are you trying to run Firefox (and other programs) logged as root? (by that, I mean logged as root, not that you logged and su to become root later). The reason because I ask that is because some applications, for security reasons, won't run when logged in as root... You have to always log in as non-root and when you need to use install or do any other "root stuff", then you become root with su-command. To sum up, 1-) if you are root and you are trying to run firefox as root and it returns error, that's normal. 2-) If you are logged in as non-root and gives that error, then we have a problem :). In fact, you should not even startx as root, ever ;).

If the item 2 is your case (problem appears when logged as non-root), then try installing the package wxGTK. It should be shipped with your Slackware CD's. If you don't have it, get from from an ftp near you. Then re-run Firefox, as user, not root ;)

Mega Man X 03-05-2004 05:58 AM

Those permissions and stuff might be a pain at the beginning, but when you have a system with multi-users or servers they are really handy :D

michelbehr 03-05-2004 06:23 AM

No deal... :-( Gtk error, still... and im doing this as non-su... startx was opened as non-su...

WOW! It opened!... :-) But only when i do "run..." from the desktop... cant get it to run from the terminal, and i dont have ANY idea about how this is possible...Do u have any clue? If u dont no prob, the important thing is that its working! :-)

Very briefly, 2 other things: 1) im trying to give acess to a directory, that is not EXACTLY a directory, its symbolic link to one of my drives on the WindowsXP partition. How can i set permission of this link? According to man chmod permissions cant be set for symbolic. But my drive has permission 744 (root does anything and the rest only read)... How can i change it? I tried to do with chmod anyway, but (for mt surprise! :-) it didnt work... 2) Everytime i turnoff the computer and turnon again i have to reconfigure the net:

root# ifconfig eth0 netmask up
root# route add default gw eth0

How do i make this configuration permanent?


michelbehr 03-05-2004 06:29 AM

One more thing: what i was calling "terminal" was in fact rxvt... when i use xterm it opens nice...

Mega Man X 03-05-2004 06:40 AM

Well, it's weird that "run" runs but not the terminal :(. I've never seen anything like that. But let's hope someone will help us out with that :).

1-) Do you mean that you want to read/write to a Windows partition from Linux?. Well, if you are using fat32, that should be no problem. Just adding a few lines at /etc/fstab would do the trick. Now, if you are using NTFS, that would be tricky. First you need to have a newer kernel and build it with support to NTFS. I've never done it myself. NTFS is also very new, so there're plenty of peoples on the net with broken systems trying to write in NTFS. Assuming that you are using FAT32, edit, as root, you /etc/fstab, to something like this:


/dev/hda2                /mnt/win_d                vfat uid=500,gid=500,umask=000,exec,dev,suid,rw 1 0
So, what does it means. That means that my second part of my harddrive (/dev/hda2) is of FAT32 and is beng mounted at /mnt/win_d. You can mount any partition anywhere you please. I choose to mount my "Windows D drive" at /mnt/win_d, once again, to keep my system more organized, since cdrom and other devices usually are mounted at /mnt/. The above code will give full read and write permissions to all users into that partition.
Hint: Usually, when I partition my hard-drive to dual boot with Windows, I make two small partitions: One with Windows system only and another one with Linux system one. A third partition of FAT32 is used with all the space left of my hard-drive, so both Windows and linux can use that piece, regardless to system that I choose to boot :)

2-) About your network, that's a good question. I ran "netconfig" in my Slackbox only once, and it always remembers my Internet configuration. Try running netconfig and see if helps. You might need to install a package if the command fails. That package (cannot remember the name) is located at your Slackware CD, under the folder Slackware/network I think :).

Mega Man X 03-05-2004 06:44 AM


Originally posted by michelbehr
One more thing: what i was calling "terminal" was in fact rxvt... when i use xterm it opens nice...
Cool. Does it work with another terminal as xterm? There're plenty of different terminals for Linux, as gnome-terminal, eterm, aterm, xterm, rxvt, you name it :). I use myself aterm:

It's a pretty fast terminal as xterm is (in fact, they use the very same engine). The cool thing is, it can handle transparencies:

as well as backdrop images. It's neat. It's also simple to build it from source. I always recommend that program when somebody wants to learn how to install something from source, because it's easy plus you get a nice terminal :D

michelbehr 03-05-2004 07:27 AM

i did what u told (about fstab) but it didnt work, that is, i still cant have acess as a non-su to my windows partiotion files... one thing i think weird: the file lookslike this:

/dev/hda6 swap swap defaults 0 0
/dev/hda4 /other swap defaults 0 0
/dev/hda2 /another vfat defaults 0 0

Now u want me to put all this parameters on the defaluts column? i did that, but the thing got quite unorganized! :-) And it didnt work... How is this file read? The separaion between the columns matters?...

michelbehr 03-05-2004 08:25 AM

Oh... feels gooooooooooood!... Sound!... Do it LOOOUD, SWEET HEART!!! man... what a relief, i was almost giving up... thanx for the help.... i actually did other thing on /etc/fstab, i did THAT line:

/dev/hda5 /fat-d vfat auto,user,owner,umask=000 0 0

I have an instinct that I opened up all i could on my machine!! :-) Anyway... that wasnt the problem anyway (i had tried that before)... i needed to umount/mount /dev/hda5, with some parameters:

mount -t vfat -w -o user,umask=000 /dev/hda5 /fat-d

THEEEN... the magic happened!!! :-)
End of story... :-) Thanx a lot!!! C ya!!!

Mega Man X 03-05-2004 08:33 AM

Cool :) Really great. You've found a much better solution with a simpler syntax then mine. I was following a Slackware manual that I have here but you've surpassed me :). "You've become a wiser Jedi than I am..." lol... alright, been watching Star Wars today, lol ;).

All times are GMT -5. The time now is 05:22 AM.