LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   dual boot after format (https://www.linuxquestions.org/questions/linux-software-2/dual-boot-after-format-52847/)

PSIO 04-01-2003 06:59 AM

dual boot after format
 
I had windows xp and red hat linux 8 installed on my system with dual boot.
After i formatted my windows partition the dual boot menu is gone...
How do I get it back?

I read you can use the rescue function from the red hat installation cd but I've tried it and I dont know how I can use it...

does anyone have a solution to my problem?
I just want the dual boot menu back

thanks

moinefou 04-01-2003 09:55 AM

Boot your RedHat CD, type :

linux rescue

and when you have a prompt, run :

chroot /mnt/sysimage

then run :

lilo

And it should reinstall LInuxLOader in the MBR of your hard disk, and you'll have the dual boot back.

PSIO 04-01-2003 10:26 AM

when i type lilo it says "no such file or directory"
but i think redhat 8 uses grub instead of lilo.

i'm now trying to find out how to reinstall grub :)

moinefou 04-01-2003 10:29 AM

You just have to run grub, then follow the instruction of the documentation : http://www.gnu.org/manual/grub/html_...RUB%20natively

PSIO 04-01-2003 10:44 AM

i've read the explanation and I think this is what i should type in the grub interface:

root (hd0,0)
setup (hd0)

is it correct or completely wrong :confused:

just asking because i dont want to risk my sysytem becoming unbootable...

moinefou 04-01-2003 12:21 PM

try the 'find' command explaned in the doc to be sure...

PSIO 04-01-2003 01:35 PM

when i type: find /boot/grub/stage1

it says: error15 file not found

but i checked and the file is definately there...

moinefou 04-01-2003 07:05 PM

Could you tell me the content of /etc/fstab ?

PSIO 04-02-2003 04:51 AM

this is what i get when i type: view /etc/fstab

LABEL =/ / ext3 defaults 1 1
LABEL =/boot /boot ext3 defaults 1 2
none /dev/pts devpts grid = 5, mode = 620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hdag swap swap defaults 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,hudzu, ro 0 0
/dev/cdrom1 /mnt/cdrom1 iso9660 noauto,owner,hudzu, ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,hudzu 0 0

hope it means something to you

moinefou 04-02-2003 07:42 AM

To find which disk holds /boot, as root, run :

findfs LABEL=/boot

For info, I didn't know, and found by :

man fstab

Then found e2label

man e2label

There was no info about how finding a specific disk with it's label, so I did, but the manpage says it was part of e2fsprogs package :

dpkg -L e2fsprog | grep bin

and found findfs

man findfs

...

PSIO 04-02-2003 08:23 AM

I dont understand a word you just said :(


sorry I'm a :newbie:

moinefou 04-02-2003 08:30 AM

When you want informations about the use of a command, just run :

man command

So here's where I found how to find you /boot... In the manpages. Have you tried findfs ?

PSIO 04-02-2003 08:54 AM

when i use findfs it says command not found

moinefou 04-02-2003 10:07 AM

are you root when you try it ?

PSIO 04-02-2003 10:39 AM

yes I am...


All times are GMT -5. The time now is 07:35 AM.