-   Linux - Software (
-   -   dpkg fatal error unable to open files list file Stale NFS file handle (

cmr26 09-06-2009 02:05 PM

dpkg fatal error unable to open files list file Stale NFS file handle
This morning when attempting to upgrade (aptitude update; followed by aptitude safe-upgrade) my system I started receiving the following error:

Preconfiguring packages ...
(Reading database ... dpkg: unrecoverable fatal error, aborting:
unable to open files list file for package `apache2-doc': Stale NFS file handle
E: Sub-process /usr/bin/dpkg returned an error code (2)
A package failed to install. Trying to recover:

It doesn't seem to matter what repository I use or what particular package that I attempt to upgrade (all or just a single package). (In particular, apache2-doc is not even a package being upgraded, although it is installed on the system.) I have rebooted, run apt-get clean, run apt-get check, etc. to no avail.

I am running a standard Debian (5.0.2/Lenny) desktop PC and am not running any NFS processes, client or server.

Are there any Debian experts out there that can give me a clue?



repo 09-06-2009 02:11 PM

What happens when you do a

aptitide clean
then again update and safe-upgrade

cmr26 09-06-2009 02:40 PM

Thanks, but that doesn't seem to make any difference. Just to be certain I tried once again, but I still receive the same error.

repo 09-06-2009 02:46 PM


rm /var/lib/dpkg/info/apache2-doc.list

cmr26 09-06-2009 05:07 PM

Thanks! That was just the hint that I needed.

When I attempted to remove the file, apache2-doc.list, I received the same error about a stale NFS file handle. It turned out that the file system was corrupted and several of the list files either were missing. `rm` and `rm -f` wouldn't work so I had to run fsck & repair the file system. After that, I discovered several more list files that were corrupted. I ran `dpkg -i` manually to reinstall the packages with missing/corrupted list files (after removing the corrupted files). After that I was able to update the system successfully with aptitude.


repo 09-06-2009 05:10 PM

Glad to see the problem is solved.
You can mark the thread solved if you want.

All times are GMT -5. The time now is 12:45 AM.