-   Linux - Software (
-   -   DownGrading Failure (

Ceafin 01-16-2005 11:14 PM

DownGrading Failure
I'm pretty new to Linux, so please don't flame me. I've been trying to learn by working on something that will give me some drive. My choice was a particular MUD code base. And yes... I _HAVE_ searched this forum through and through, and MY question has not been answered.

Well, my problem is I'm using Fedora Core 3, straight off of, and I'm trying to compile this rather old code base. It was coded before there was that big ANSI standard change. Therefore, the gcc compiler that came with FC3 is too new. I've talked around, emailed handfuls, and checked several formus (including this one) and found nothing. The one thing I find the most, is people saying, "You don't want the older version, you want to new compilers."

Well, this is all well and good, but I don't want the new compilers. I really would like to see this old code get off the ground. I know the code is supposed to compile fine on linux and under this compiler:
gcc version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)

I tried installing the libraries my current compiler said it needed, (through seperate RPMs and such) I also tried installing the egcs-1.1.2 rpm & I tried installing the gcc 2.91 & gcc 2.95.2 rpms... but none of them were showing up, they weren't being installed, or something I'm just too green to recognize.

I want to learn. I am NOT asking for some hand out. But everywhere I turn to find some hints or heaven forbid some good help. I've been getting a turn down, a brush off, or someone who thinks they're so good they don't need to help lil' ol' me. I do admit I'm pretty green, but Linux seems very awesome so far, and I've enjoyed working with it for what I've done.

Thanks for your time, I really appreciate it.

foo_bar_foo 01-16-2005 11:32 PM

sorry people brush you off , it's very common to have a collection of compilers around
but it's important to not mess with the system compiler in /usr and don't install another compiler in --prefix=/usr

go download a copy of the current cvs realease of "Beyond Linux from Scratch"
in there is a page titled "gcc2.html"
it has detailed instructions on how to compile and use gcc-2.95.3 on a modern system.
this is the compiler from the 2 series that became the standard for that time
before 2.95.3 the standard was 2.91.66 but the two are very simmilar
think of 2.95.3 as a better 2.91.66

i would imagine the documentation you looked at was simply written before 2.95.3
and 2.95.3 will work for you
if it does not you can try to build 2.91.66 but i know of no instructions for doing that on a modern system like fedora core 3 but like all things Linux I'm sure it can be done

Ceafin 01-17-2005 12:43 AM

I found several version of the page you referred me to; however, each of them start off with:


Installation of gcc
Apply the two patches, one to fix compilation and the other to stop the fixincludes script from executing.

patch -Np1 -i ../gcc-2.95.3-1.patch &&
patch -Np1 -i ../gcc-2.95.3-no-fixinc.patch

From the get go. Do I just enter these commands right into the terminal while my pwd is the directory where I've downloaded the gcc-2.95.3.tar.gz and related patches? Or do I save this step for last, after I've done all other steps to install the gcc compiler?

The rest of the page I think is enough that I can follow, but I feel there's some steps in the beginning I'm missing. I know they are probably obvious steps to more experienced users, but I've been trying with what I read, and I'm not getting anywhere close to the same results.

__J 01-17-2005 01:53 AM

What i usually do is install gcc-2.95.3 with the prefix /opt/gcc-2.95.3. ( I need it cause gcc-3.4 refuses to compile gnome-1.4 due to deprecated features). on the patches command, it depends on where the patches are ( ../patch.... is telling bash the patch is in the parent directory of the directory you are currently in) So say you have gcc-2.95.3 source in /home/joe/gcc-2.95.3 and the patches are in /home/joe as well. the commands as you quoted them will work if this is the case.

The patches must be applied right after you unpack the source (before ./configure ).

everything else on that page (gcc2.html) should work out for you.
dont forget to make the cc symlink like so:

ln -s /opt/gcc-2.95.3/bin/gcc /opt/gcc-2.95.3/bin/cc
and when you want to use gcc-2 compiler ( instead of your default one ) do:

export PATH=/opt/gcc-2.95.3/bin:$PATH ( this sets PATH to look in /opt/gcc-2.95.3/bin before anywhere else)

test it by running:

cc -v

and it should tell you the configure options and version as well as release date.

All times are GMT -5. The time now is 04:02 PM.