LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-17-2003, 12:45 PM   #1
leisure
LQ Newbie
 
Registered: Mar 2003
Posts: 12

Rep: Reputation: 0
Don't know if my RPM database is corrput


I would really appreciate if someone can help me with this issue. I am not a Linux expert, so patience will be greatly appreciated as well. I've been looking around, but found no answers on the subject.

I have a system installed with RH 8.0. When installing I did not install the Devlopment tools packages (cvs, gcc, etc. etc.). The system has been automatically updated using rhn. Now, my problem is:

When I go through the Package Manager Tool (in GNOME) to install the Development tools, I get an error saying that a couple of packages (openssl, openldap amongst them) were not found. However, when I go in the command line and do a rpm -q openssl I do get the correct response. Moreover, I get ALL the packages that re currently insalled in my system. The only difference is that the GUI error is bringing up an older version of the package.

I thought that this only applied to the Development tool packages, but I wanted to install another package (under printing support) and I got the same problem. That lead me to conlcude that my database might be corrpoted.

What I've done:
1) rm /var/lib/rpm/__*db
2) rpm -vv -rebuilddb

Did not help at all.... same problem.

I guess I can force the installation of new packages, but that will just solve my immediate need of installing gcc. I'd rather fix the darn thing.

Thanks!
 
Old 03-17-2003, 01:00 PM   #2
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
I'm not sure if I understood you correctly but if your not using these openssl packages try un-installing all of them and then re-installing all of them. Along the way do a few rebuilds of the database.

I had something similar to this happen to me and the only way I got everything to work was by getting rid of the packages it was complaining about and then reinstalling them.
 
Old 03-17-2003, 02:20 PM   #3
zap
LQ Newbie
 
Registered: Mar 2003
Posts: 2

Rep: Reputation: 0
Lesiure

Have you got to the bottom of this as I have exactly the same problem. However I am so new to all this I do not even know how to un-install the packages.

Can anyone offer any help ?

Cheers
Paul
 
Old 03-17-2003, 02:25 PM   #4
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
To uninstall a package you do:

rpm -e package name

The -e means erase.
 
Old 03-17-2003, 02:30 PM   #5
leisure
LQ Newbie
 
Registered: Mar 2003
Posts: 12

Original Poster
Rep: Reputation: 0
Uninstalling

Uninstalling is pretty straightforward....

1) Go to a terminal window
# rpm -q package

it should come with the list of packages that match your search criteria, for example my system has upgraded the kernel three times, so wen I do:

#rpm -q kernel

it comes back with something like.....

kernel-2.4.18.0
kernel-2.4.24.0
kernel-2.4.28.6

Now, if you would like to uninstall the oldes version, you just got to issue a -e:

#rpm -e kernel-2.4.18.0

This will take care of it....

You might want to issue a --test and a -vv to make sure what the thing will do:

#rpm --e --test -vv kernel-2.4.18.0

Once you fell comfortable, go for it!

Hope this helps.
 
Old 03-17-2003, 02:43 PM   #6
zap
LQ Newbie
 
Registered: Mar 2003
Posts: 2

Rep: Reputation: 0
OK I have tried to un-install openssl, but when I do this I get a long list of messages saying that the package is needed by other programs and does not un-install.

I am trying to add Developer tools but it just says that an older version of openssl is not installed. If I try to iunstall the older version I get a message saying that a newer version is already installed.

What else can I do ?

Thanks
Paul
 
Old 03-17-2003, 03:00 PM   #7
leisure
LQ Newbie
 
Registered: Mar 2003
Posts: 12

Original Poster
Rep: Reputation: 0
Explsining the issue further

I have not gotten to the bottom of it, but I'll try to explain it better:

1) When using the Package Management Tool (in GNOME), I try to add the Development tools (a single check mark). I open the details link and fine tune the packages I want to install.

2) After I click on update, it compiles the package dependencies, and it comes back with an error in a popoup window, saying something like (these are not the same messages nor the same version number, but the principle is pretty much accurate):

The following packages are not installed and are required in order to install the new packages, and then it shows the details:

openssl-0.98-1 required by openssldevel-1.4.3
openldap-1.5.4-3 required by openldapdevel-1.7.8.3
.... (like five of them)

3) However if I bring up a terminal and issue the following command:

#rpm -q openssl

and I get:

openssl-0.99-5

What tells me that there is a newer version installed, and for some reason the program doesn't pick up this new version.

At first I thought it was only for these packages, but as I gave up and tried to configure an HP DJ 970, I realized that I was missing a package. I tried to do the same thing (using the GUI) to install the missing package and it came back with the same error, but different module (it had nothing to do with the openssl, ldap, etc. - I believe it was the ghostview).


I'm thinking of:
1) run rpm -qa > shellfile
2) backing up my /var/lib/rpm directory
3) rpm -initdb
4) modify my shellfile to issue the command to install all packages (with the justdb option)
5) and hopes this takes care of it....

But before doing that, I wanted to know if there was an easier way, and as I said, since I'm not an expert.... that will just be experimenting with my system (totally against for since I've spent a lot of time already configuring some other stuff).

Thanks!
 
Old 03-18-2003, 08:22 PM   #8
leisure
LQ Newbie
 
Registered: Mar 2003
Posts: 12

Original Poster
Rep: Reputation: 0
Angry Digging around a little more

Zap,

It looks like we are not alone.... I've found a lot of postings with the same problem. This link provided the most reasonable explanation.

http://www.linuxquestions.org/questi...&highlight=rhn

I'll probably just re-format my computer and install EVERYTHING upfront. I was considering an HD upgrade, so it might work out well.

Good luck!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I lost my rpm database Janneman Red Hat 6 12-15-2004 12:46 PM
RPM database, help! Thetargos Fedora 2 07-30-2004 05:47 PM
Can't rebuild RPM database tawalker Linux - Software 3 04-22-2004 04:17 AM
rpm database palmmjsg23 Linux - General 6 03-09-2004 11:58 PM
RH rpm database gfyspf Red Hat 1 09-17-2003 10:39 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration