LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-31-2005, 01:12 AM   #1
Joseph Schiller
Member
 
Registered: Oct 2003
Location: New Jersey
Posts: 44

Rep: Reputation: 15
does anyone know how to enable line completions in vim or gvim


Hello Folks,

Maybe this topic belongs in programming forums, but it's a feature not only used by programmers.

After upgrading SuSE 9.1 to 10.0, I've noticed that line completions in Vim and Gvim do not work, although they work fine in Emacs. For example, when saving an existing file, after typing a few characters, you can hit TAB and the whole string will be populated, if there is more than one file that begin with these characters you will be presented with all possible completions. This feature worked perfectly fine under 9.1. I've upgraded to gvim 6.4.1 which is newer than the one in SuSE 10.0 distribution, but have vim 6.3.84. When I hit TAB I see that ^I is inserted instead of line completion. I'm not sure which components control this behavior.

Regards,

Joe
 
Old 10-31-2005, 01:27 PM   #2
missy_b
LQ Newbie
 
Registered: Oct 2005
Posts: 3

Rep: Reputation: 0
of course, this all depends on your vim settings.
I played a little with mine and found that
:se nocompatible
will enable tab-completions, while
:se compatible
will output ^I (Ctrl-I)
One way to find out is to start vim with
'-u NONE' (i.e. no special settings)
and then adding your settings from
your .vimrc or .gvimrc or wherever.

But you are right, this belongs to a programmer's newsgroup (or maybe comp.editors)
 
Old 10-31-2005, 10:11 PM   #3
Joseph Schiller
Member
 
Registered: Oct 2003
Location: New Jersey
Posts: 44

Original Poster
Rep: Reputation: 15
Thanks for the tip! I've added two lines to my .gvimrc: the first adds tab-completions the other alleviates squinting to read the default fonts.

set nocompatible
set guifont=Monospace\ Bold\ 14

Joe
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Vim: Starting line numbers from 0 funkymunky Linux - Software 0 11-27-2005 07:40 PM
prompt within gvim/vim/vi zchoyt Linux - Software 6 02-02-2005 07:30 AM
[Vim] enable features noir911 Linux - General 2 08-09-2004 02:21 PM
vim or gvim raees Linux - General 7 03-17-2004 06:02 PM
vim / gvim Shak Linux - Software 4 04-03-2003 10:25 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration