-   Linux - Software (
-   -   Does anybody use clamav with sendmail? help (

lzyking 03-30-2004 12:08 AM

Does anybody use clamav with sendmail? help
I used clamav-0.67 on my redhat 8.0 server . I installed it with the
installation guide , and I used clamav-milter with my sendmail , but when I
started the clamav-milter , the system told me that

/var/run/clamd.sock: No such file or directory
Can't talk to clamd server via /var/run/clamd.sock
Check your entry for LocalSocket in /etc/clamav.conf

but I have defined the /etc/clamav.conf
what can I do for this?
another question , when I run the command clamd , then I run the command
ps -ef |grep clamd ,but I saw nothing about it . Is this right?

I also want to know whether the file clamad.sock is generated by the clamav or I must generate by myself.

help me ,thanks.

chaan 04-09-2004 11:27 AM

You need to make sure that the user ID that clamav is running under has write access to the directory where you are telling it to create the clamd.sock socket. The clamav.sock socket is created by clamd when you start it up. If you can find clamd in the output from ps, there is definitely something wrong.

What user is clamd running as (specified in User directive in clamav.conf) and what user are you logged in under when you execute clamd?


All times are GMT -5. The time now is 06:06 PM.