LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-28-2015, 08:32 AM   #1
Ihatewindows522
Member
 
Registered: Oct 2014
Location: Fort Wayne
Distribution: Ubuntu 16.04 LTS
Posts: 616
Blog Entries: 2

Rep: Reputation: 166Reputation: 166
Do I have PulseAudio or don't I?


Having a very odd issue here. I am able to use PulseAudio to record sound from my desktop using SimpleScreenRecorder with no issues whatsoever. I've recorded numerous screencasts with sound with no problems.

However, I was trying to record my system sound yesterday with Audacity and it didn't see PulseAudio, as the online manual said I should.

Since I didn't see the bar (under step 2 in the manual) in Audacity, I figured the one in the Ubuntu repos was tampered with. I was right, and after adding the Audacity PPA and installing the official version the bar reappeared...however I still couldn't record from PulseAudio.

Screenshot 1

Screenshot 2

Could really use some help here, thanks in advance!
 
Old 08-28-2015, 08:51 AM   #2
hortageno
Member
 
Registered: Aug 2015
Distribution: Ubuntu 16.04 LTS
Posts: 236

Rep: Reputation: 65
Quote:
Originally Posted by Ihatewindows522 View Post
Having a very odd issue here. I am able to use PulseAudio to record sound from my desktop using SimpleScreenRecorder with no issues whatsoever. I've recorded numerous screencasts with sound with no problems.

However, I was trying to record my system sound yesterday with Audacity and it didn't see PulseAudio, as the online manual said I should.

Since I didn't see the bar (under step 2 in the manual) in Audacity, I figured the one in the Ubuntu repos was tampered with. I was right, and after adding the Audacity PPA and installing the official version the bar reappeared...however I still couldn't record from PulseAudio.

Screenshot 1

Screenshot 2

Could really use some help here, thanks in advance!
It would be interesting to see the "Input" and "Configuration" tab of the "Volume Control" window.
 
Old 08-28-2015, 09:11 AM   #3
Ihatewindows522
Member
 
Registered: Oct 2014
Location: Fort Wayne
Distribution: Ubuntu 16.04 LTS
Posts: 616

Original Poster
Blog Entries: 2

Rep: Reputation: 166Reputation: 166
Input
Configuration
 
Old 08-28-2015, 11:37 AM   #4
hortageno
Member
 
Registered: Aug 2015
Distribution: Ubuntu 16.04 LTS
Posts: 236

Rep: Reputation: 65
Open Audacity and the Volume Control and change to the Recording tab. Hit Record in Audacity and it will appear in the Recording tab. There you move the slider for the volume somewhere between Silence and 100% (0dB), otherwise you'll get a lot of feedback and change the device to "Monitor of...".
 
Old 08-28-2015, 03:24 PM   #5
Ihatewindows522
Member
 
Registered: Oct 2014
Location: Fort Wayne
Distribution: Ubuntu 16.04 LTS
Posts: 616

Original Poster
Blog Entries: 2

Rep: Reputation: 166Reputation: 166
Nope, still nothing.

http://s2.postimg.org/t0ohpvrs9/recording_nosound.png
 
Old 08-28-2015, 04:26 PM   #6
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
You need to be actively recording for the pulseaudio recording tab to populate. In the old days, audacity needs to be compiled with --with-portaudio=v17 (or was it v19). I don't think you need that these days, but you might need to do some .asoundrc configuration for pulse to be recognized by some apps.

In audacity:
Edit -> Preferences -> Devices -> Recording -> Device: dropdown is where you'll find pulse as a selectable option if it's there to be selected. You might need to select the interface part of that same dialog to see it there or not. Lots of ways to configure your setup.

I tend to have pulseaudio over jackd on my system. But I have pulseaudio with "autospawn = no" so I can switch setups as I need to. If pulseaudio is in your ps output, then you're using it. Everything else is a matter of configuration.
 
Old 08-28-2015, 04:39 PM   #7
hortageno
Member
 
Registered: Aug 2015
Distribution: Ubuntu 16.04 LTS
Posts: 236

Rep: Reputation: 65
In Audacity, where it shows your soundcard "HDA Intel: ALC262..." select "default" or "pulse" instead.
Attached Thumbnails
Click image for larger version

Name:	2qntuzn.jpg
Views:	19
Size:	112.1 KB
ID:	19310  
 
Old 08-31-2015, 01:44 PM   #8
Ihatewindows522
Member
 
Registered: Oct 2014
Location: Fort Wayne
Distribution: Ubuntu 16.04 LTS
Posts: 616

Original Poster
Blog Entries: 2

Rep: Reputation: 166Reputation: 166
I'm not seeing an option for just "pulse", rather for different devices (most of which I don't even have).
http://s10.postimg.org/uketuuixl/options.png

This is one of those rare times where I like having a display that will rotate...here is the complete list:
http://s28.postimg.org/7hpqb5v71/fulloptions.png

Also want to be clear that this is the official version from Audacity as well.

Last edited by Ihatewindows522; 08-31-2015 at 02:30 PM.
 
Old 08-31-2015, 05:38 PM   #9
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
So it's verbose. Record from a microphone (MIC). Play the sound to a line out (LINE). And various other holes in your device for external things. You have pulse: in that list so pulse is there and active (or it wouldn't be listed). Pulse is likely your default so most things pulse: or default: should function.
 
1 members found this post helpful.
Old 08-31-2015, 08:12 PM   #10
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 17,511
Blog Entries: 28

Rep: Reputation: 5436Reputation: 5436Reputation: 5436Reputation: 5436Reputation: 5436Reputation: 5436Reputation: 5436Reputation: 5436Reputation: 5436Reputation: 5436Reputation: 5436
If you do not have pavucontrol installed, install it; it should be in the repros.

It gives you more options for managing pulse.
 
Old 08-31-2015, 10:11 PM   #11
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,523

Rep: Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619
if this is fedora then you have it

fedora moved to using it in Fedora 6
first major OS to use pulse audio and fedora 6 had BUGS with it


But ALSA is still used as a plugin to pulse
 
Old 09-01-2015, 09:39 AM   #12
Ihatewindows522
Member
 
Registered: Oct 2014
Location: Fort Wayne
Distribution: Ubuntu 16.04 LTS
Posts: 616

Original Poster
Blog Entries: 2

Rep: Reputation: 166Reputation: 166
Quote:
Originally Posted by Shadow_7 View Post
So it's verbose. Record from a microphone (MIC). Play the sound to a line out (LINE). And various other holes in your device for external things. You have pulse: in that list so pulse is there and active (or it wouldn't be listed). Pulse is likely your default so most things pulse: or default: should function.
Like I said, the majority of those devices I don't have. I literally only have 2 headphone jacks and 2 mic jacks. That's it.

pulse: Front Mic:0 works. That's good...but not quite what I wanted. As in my fist post, I would like to record my system audio output, and I don't see an option to do that.
 
Old 09-01-2015, 09:48 AM   #13
Ihatewindows522
Member
 
Registered: Oct 2014
Location: Fort Wayne
Distribution: Ubuntu 16.04 LTS
Posts: 616

Original Poster
Blog Entries: 2

Rep: Reputation: 166Reputation: 166
Haha, I think I just figured it out!

In pavucontrol under Devices, I simply turned off the mic jack and turned on the monitor. After that, I again used pulse: Front Mic:0 in Audacity, and instead of recording the microphone like I thought it might, it recorded from the monitor! That was a lot simpler than I thought it would be.

Thanks for the help everyone, marking this thread as solved.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Don't play audio from two or more sources. Debian wheezy - pulseaudio gigam Linux - Desktop 1 08-13-2012 05:13 AM
[SOLVED] Squeeze + Pulseaudio + Alsa and USB Midi device causes Pulseaudio crash mad4linux Debian 1 01-26-2011 03:57 AM
Winecfg crashes on sound tab with Pulseaudio and no 'sounddrivers' without pulseaudio William (Dthdealer) Linux - Software 5 06-13-2010 07:30 AM
Some Menu Icons don't appear in GNOME if I don't install KDE - How can I fix it? doraimom Linux - Desktop 4 04-14-2007 01:37 AM
Suse dontīt boot X; donīt ask for root passwd, YAST donīt work... carrie Linux - Newbie 4 10-08-2004 07:46 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration