LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-12-2004, 01:50 AM   #1
karan101
Member
 
Registered: Aug 2004
Location: CANADA
Distribution: Fedora core4
Posts: 60

Rep: Reputation: 15
Disk Usage


hello people
i've been reciveing these emails in my root account:
Message 1:
From root@localhost.localdomain Mon Oct 11 14:10:32 2004
Date: Sat, 25 Sep 2004 21:01:01 -0700
To: root@localhost.localdomain
From: "Disk Usage Monitor" <root@localhost.localdomain>
Subject: Low disk space warning - res1n-403-1.res.unbc.ca

Disk usage for res1n-403-1.res.unbc.ca:

Inodes: /dev/hda1 (/mnt/windows) is 100% full -- 56K of 56K used, 47 remain

&
Message 2:
From root@localhost.localdomain Mon Oct 11 14:10:32 2004
Date: Sat, 25 Sep 2004 23:01:06 -0700
To: root@localhost.localdomain
From: "Disk Usage Monitor" <root@localhost.localdomain>
Subject: Low disk space warning - res1n-403-1.res.unbc.ca

Disk usage for res1n-403-1.res.unbc.ca:

Inodes: /dev/hda1 (/mnt/windows) is 100% full -- 56K of 56K used, 47 remain

&

is there anyway i can stop this or increase the size ....
thank you very much
 
Old 10-12-2004, 05:05 AM   #2
maroonbaboon
Senior Member
 
Registered: Aug 2003
Location: Sydney
Distribution: debian
Posts: 1,495

Rep: Reputation: 48
If you are running out of inodes it means you have too many files, even tho' there may be plenty of space left on the disk. The inodes are part of the data structure making up the filesystem. As far as I know this is something that has to be set when the filesystem is created and can't be altered while preserving the data. Some linux filesystem types (e.g. ReiserFS) can create inodes as needed.

But if this is a windows partition I don't know what you can do. If you have a lot of small files maybe you could archive them into a single tar file and free up some inodes that way? Or maybe you can set something via windows?
 
Old 10-12-2004, 09:58 AM   #3
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
have you actually mounted /dev/hda1?

sl mritch.
 
Old 10-12-2004, 12:11 PM   #4
karan101
Member
 
Registered: Aug 2004
Location: CANADA
Distribution: Fedora core4
Posts: 60

Original Poster
Rep: Reputation: 15
yes its mounted

i've mounted the /dev/hda and if there's no way other than using tar would you be kind and gimme an example of how doin it....
thank you very much
 
Old 10-12-2004, 12:45 PM   #5
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
i'd mean, was hda1 mounted when the cron job ran?

first, lets be sure we really have a problem:

do (some as root):
"df -i /dev/hda1"
"mount | grep /dev/hda1"
"cat /etc/fstab | grep /dev/hda1"
"cat /proc/sys/fs/inode-state"
"cat /proc/sys/fs/file-nr"
and post results.

the error message could also mean that the script you run from cron doesn't know how to handle the ms partitions correct and believes there is a problem with the number of inodes allocated. so if it's not to long, please post it.

sl mritch.

Last edited by mritch; 10-12-2004 at 12:51 PM.
 
Old 10-13-2004, 02:05 AM   #6
karan101
Member
 
Registered: Aug 2004
Location: CANADA
Distribution: Fedora core4
Posts: 60

Original Poster
Rep: Reputation: 15
here is the result

[root@localhost karan]# df -i /dev/hda1
Filesystem Inodes IUsed IFree IUse% Mounted on
/dev/hda1 60464 59352 1112 99% /mnt/windows
[root@localhost karan]# cat /etc/fstab |grep /dev/hda1
/dev/hda1 /mnt/windows ntfs ro,defaults,umask=0222 0 0
[root@localhost karan]# cat /proc/sys/fs/file-nr
2740 0 65536
[root@localhost karan]#

thank you verymuch
karan
 
Old 10-13-2004, 02:49 AM   #7
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
there should be no trouble if you leave it mounted readonly. write access for ntfs is imho not 100% stable yet and i don't suggest using it if you care for your data.
if you really need your windows partition writeable keep (a small) fat32 for now.

..if you want to get rid of the mail you'll have to edit the script or disable that cronjob at all.

sl mritch.
 
Old 10-17-2004, 03:16 AM   #8
karan101
Member
 
Registered: Aug 2004
Location: CANADA
Distribution: Fedora core4
Posts: 60

Original Poster
Rep: Reputation: 15
umm would you explain how i can edit my cronjob
thank you
 
Old 10-17-2004, 03:59 AM   #9
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 47
crontab -e
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Disk Usage kegwell Linux - Software 2 05-11-2005 10:59 AM
LQ disk usage student04 LQ Suggestions & Feedback 4 10-24-2004 09:35 PM
AS 2.1 disk usage buck2bcr Red Hat 4 03-23-2004 09:50 AM
101% disk usage on an empty disk tsiuser Linux - Software 3 01-28-2004 06:24 PM
Disk Usage dvong3 Linux - Software 2 06-13-2003 12:56 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration