-   Linux - Software (
-   -   Disappearing thumbdrive Gigabyte bios file. (

Jonor 06-17-2009 12:35 PM

Disappearing thumbdrive Gigabyte bios file.
Has any Gigabyte mobo user found that when using Q-Flash via a thumbdrive the update file disappears when in Q-Flash mode ?
Q-Flash will list all other files on the thumbdrive other than the one that is needed. The thumbdrive was formatted in Fat32.

Not sure if this is a software or hardware topic.

thorkelljarl 06-17-2009 04:06 PM

No, but I read the manual...

The last time i flashed the BIOS on my Gigabyte motherboard there were only the three files that had been unpacked from the BIOS download. That is because I followed the instructions saying that the Q-Flash Utility will not work if there is any other files on the media than those of the BIOS.

Note also that on my board I must use the <end> key at POST to enter Q-Flash since the BIOS is set to use AHCI for my SATA HDD.

For flashing a BIOS I always read the instructions very thoroughly. Might you do the same? Luck

Jonor 06-18-2009 05:38 AM

I very much do the same, very thoroughly indeed, couldn't agree more, it would be crazy not to. The bit about it not working when there are other files didn't make it into my issue of the user's manual. However it is interesting to know you were given that instruction. Q-Flash recognized other files that were not even .exe. I did try with no other files (other than a U3 security system) but that wouldn't reveal the update file either. I may be forced to try formatting a bit of hard drive in FAT32 if that is possible.

thorkelljarl 06-19-2009 01:58 PM

Not in the motherboard manual...

Now that I look, the information about not having anything in the media but the BIOS is not in the Gigabyte motherboard manual, but is correct nevertheless. That restriction includes the U3 files as well as any others.

You could remove the U3 files and perhaps format the USB flash drive to FAT16 or vfat just to be sure and try again, or go out and buy a reasonable quality USB flash drive of 1 or 2GB, format it and use it as your BIOS flashing media from now on. USB flash drives of that size are cheap, and a Sandisk or Kingston should not cost much.

I would also remind you of the advisability of entering Setup and changing the BIOS to its Optimized Defaults before the first POST. That is in the manual.

May it go well.

Jonor 03-01-2010 06:11 PM

Although it has been nine months i would like to resume this issue if there are any gigabyte specialists around as what was previously purely an academic interest has become more urgent.
Navigating the BIOS setup program is now full of long delays and flickering banners that is threatening its usability.
As thorkelljar suggested the thumbdrive has been wiped of the U3 security system and formatted in FAT16. The BIOS update file will still not show in Q-Flash.
Clicking the update BIOS banner in Q-Flash fist gives a box with one option highlighted in yellow of FLOPPY A, with notes below showing 0B filesize (there is no floppy anyway).
I then clicked enter (well why not) and the highlighted line changed to


with notes at the bottom showing a filesize of 15.2 GB which is correctly the size of the thumb drive.
A further click of the enter key returned to the Floppy display.
So i don't think it was the U3 that was causing the problem.

thorkelljarl 03-02-2010 09:11 PM

What is the size...

I believe that if you are using a USB flash that is 2GB or larger, it should be formatted with VFAT, otherwise FAT16.

I hope and trust that you have executed the .exe BIOS file that you downloaded on a Windows system to obtain the three components of the BIOS, an autoexec.bat file, a flasher(.exe) file and the BIOS(.exe) file.

You make no mention of having done so. The BIOS file as downloaded is a self-extracting generator of the three files that are to be used.

I fear that by now you may be trying to upgrade from one BIOS version to another that is more than a few numbers above it. Best practice is to proceed by a couple of version numbers at a time.

By the way, welcome back.

Jonor 03-03-2010 06:19 AM

Thank you for the welcome thorkelljarl and for the advice of downloading on a MS Windows system, executing to obtain the three components and stepping the upgrade a couple of versions at a time, all of which i knew nothing about.

thorkelljarl 03-03-2010 07:28 AM

Read the manual, I did...

I looked at the manual for the GA-MA78G-DS3H (rev.2) and found the instructions for using Q-Flash; they are not detailed. However, the flashing instructions seem adequate.

When you open the downloaded BIOS file, you may find something other than three files. I took my BIOS as a universal example.

After starting the flashing utility, you should see the USB flash drive as "HDD 1-0" listed below "Floppy A". Start by pressing "Enter" and follow the sequence.

If you look carefully at the bottom, at the keystroke commands for the Q-Flash utility, you will notice that you can kill Q-Flash at any time before receiving the final notice "Are you sure to update BIOS?". You will do no harm.

Before flashing a BIOS it is advisable to disconnect anything attached, LAN, printer, speakers, etc., leaving only the computer itself.

It would be most considerate of you were you to post back upon your success, and indeed to post again in reply to some other worthy seeker of advice with a problem.

syg00 03-03-2010 07:32 AM

This thread jolted me to download a BIOS update for my old GA-P35C-DS3R which has never been touched. Will flash it tomorrow and report my experiences.

Jonor 03-03-2010 06:32 PM

With your help thorkelljarl, the BIOS has been updated (and so the initial problem solved).
I accept that the manual is adequate for a MS Windows user (who would have found it easy) and Linux users who knew about Windows extraction, something i regrettably overlooked ( hence the apparent disappearance of the file).

The BIOS setup program however is still variously :

1. Slow, taking typically minutes to respond to a keystroke.
2. Uncontrollable, switching through the Main Menu options without a key being touched at about 10 options a second.

Not sure whether this secondary issue should be started in a new thread, but if anyone could identify a cause or solution to this kind of behaviour it would appreciated. The troubleshooting section in the manual suggested loading fail-safe defaults which will be tried as a last resort.

thorkelljarl 03-04-2010 03:01 AM

You do have a problem somewhere...

What I would try is to note what I have for BIOS settings, set the BIOS for the Defaults, first trying the Optimized, then the Fail-Safe, and then flash the BIOS again. You did use VFAT on that large USB flash drive and you trust it?

The flashing function is not at all normal, but whether it is a problem that you can do any thing about or is a sign that your USB flash or your motherbord is slightly defective, I don't know.

I have a USB flash stick that I trust for flashing, and have tested it by flashing the BIOS on a junk computer I brought in from the trash.

You could try google with your motherboard model or manufacturer and something like slow/unsure BIOS update to see if the symptoms are so common that they are noted.

The important question is whether the BIOS functions properly and whether you want to do more and risk more by flashing again. My choice would be governed by the fact that I have a spare functioning computer, time to play around, and a high tolerance and experience with the failure characteristic of fools.


syg00 03-04-2010 07:04 PM

My update worked as advertised. Unable to explain the OP problems.

Jonor 03-06-2010 05:13 AM

Changing the keyboard has cured the BIOS setup program problems so there must have been keyboard compatibility issues i guess.
My Palimpsest disk utility offered 37 different types of format for the thumbdrive but none were described clearly as VFAT, so i kept with the alternative suggestion of FAT16. The drive seems trustworthy.
Having a spare functional computer saved a stack of blood pressure at the BIOS upgrade.
Thorkelljarl your posts are unusually thorough and helpful.

All times are GMT -5. The time now is 05:06 AM.