-   Linux - Software (
-   -   disabling ACPI before shutdown with a command (

P5music 03-13-2013 09:13 AM

boot issue [solved]: disabling ACPI before shutdown with a command
I have a serious problem with ACPI. I think this is a known bug of kernel and I found some users with this issue too: after shutdown of a Linux (any distro) system on certain notebooks (like my Acer Aspire model) the system doesn't boot, it doesn't even start bios loading; after an electric discharge procedure boot is again possible. This issue doesn't affect Windows on the same system.
I cannot wait for this strange kernel issue being solved because I think there is some serious problem underlying so I ask:
Is it possible to run a command before shutdown to disable any ACPI action? I see an ACPI error message at shutdown so I think that some parameter is written in some register at that time and I am looking for a command that stops any ACPI action or register updating before it does something that creates the boot issue.
Thank you in advance

jefro 03-13-2013 02:46 PM

I think it has to do with the newer systems and their ability to use windows' hybrid sleep.

Since bios is part of this acpi, you may be able to stop some parts on linux but others may not be changed I'd think.

Why not boot without acpi if possible?

On shutdown, how do you tell it to shutdown? Try logging off the user and from main splash, do a shutdown.

P5music 03-13-2013 03:44 PM

Do you know some command I could issue before shutdown about stopping ACPI functions? I mean, a command with no permanent effect. Any suggestion is welcomed so I can try. Who knows, maybe it works and I have somehow solved. Thank you.

jefro 03-14-2013 04:34 PM

See this down the page for acpi stop.

P5music 03-18-2013 04:36 AM

Hello, thank you for the response.
When I try to stop acpid I get this error:

stop: Rejected send message, 1 matched rules; type="method_call", sender=":1.53" (uid=1000 pid=2620 comm="stop acpid ") interface="com.ubuntu.Upstart0_6.Job" member="Stop" error name="(unset)" requested_reply="0" destination="com.ubuntu.Upstart" (uid=0 pid=1 comm="/sbin/init")
What does it mean?

jefro 03-18-2013 02:25 PM

Post exact command you tried.

P5music 03-18-2013 02:50 PM

various commands yield that message:
acpid stop
stop acpid
service acpid stop
because alternative forms are suggested

P5music 03-25-2013 12:26 PM

sudo service acpid stop
was the right command.
If I issue it before shutting down my Linux Mint system the notebook boots without any problem next time.

jefro 03-25-2013 03:37 PM

Thanks for the update.

You might be able to get that to run in shutdown scripts, maybe even have to put in a pause to be sure it ends.

P5music 04-11-2013 04:40 AM

Would you be so kind to help me on this topic:
because nobody seems to be able to answer my question about specific Fedora 18 environment. Thank you in advance.

All times are GMT -5. The time now is 02:23 AM.