LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-24-2006, 06:21 AM   #1
flebber
Member
 
Registered: Jan 2005
Location: Newcastle, Australia
Distribution: debian stable
Posts: 394

Rep: Reputation: 30
Disabled Desktop Effects Stopped Window Function


I enabled Desktop Effects, was using them, I went and disabled them following instructions from the Fedora Rendering Project . However after I loggged back in all open windows lost the ability (and bar) to be minimised maximised and closed or even moved. So I enabled the effects again and logged out/in and with effects on my windows buttons were restored and working. I want to be able to disable effects when I have a heavy workload but want the windows to function. Any ideas ?

I am using FC6. My card is Geforce FX5600, and I used the dkms enabled nvidia driver from Dries to enable the effects.

Here is the Xorg.conf I used to disable effects
Quote:
# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "yes"
Option "AIGLX" "off"
EndSection

Section "Extensions"
Option "Composite" "Disable"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbVariant" "intl"
EndSection

Section "Monitor"

### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
Identifier "Monitor0"
ModelName "Monitor 1280x1024"
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 31.5 - 79.0
VertRefresh 50.0 - 90.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
And this is what I did to renable.
Quote:
Section "ServerFlags"
Option "AllowMouseOpenFail" "yes"
Option "AIGLX" "on"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Last edited by flebber; 11-24-2006 at 06:23 AM.
 
Old 11-24-2006, 07:24 AM   #2
Hitboxx
Senior Member
 
Registered: Mar 2006
Location: India
Distribution: Fedora
Posts: 1,562
Blog Entries: 3

Rep: Reputation: 61
When you lose the window borders and titlebars, just run 'metacity' command.
 
Old 11-24-2006, 07:38 AM   #3
flebber
Member
 
Registered: Jan 2005
Location: Newcastle, Australia
Distribution: debian stable
Posts: 394

Original Poster
Rep: Reputation: 30
That easy . Thanks for that.
 
Old 11-29-2006, 10:17 AM   #4
flebber
Member
 
Registered: Jan 2005
Location: Newcastle, Australia
Distribution: debian stable
Posts: 394

Original Poster
Rep: Reputation: 30
The only problem is that I now have to run ´metacity´ after every boot. Could this be amended to the xorg.conf to make this automatic.
 
Old 11-29-2006, 03:52 PM   #5
Hitboxx
Senior Member
 
Registered: Mar 2006
Location: India
Distribution: Fedora
Posts: 1,562
Blog Entries: 3

Rep: Reputation: 61
Why do you have to run it everytime? I don't understand. You disable desktop effects, you lose those things, run metacity once and reboot your system. Once rebooted everything should be normal. Isn't it??
 
Old 11-29-2006, 05:25 PM   #6
flebber
Member
 
Registered: Jan 2005
Location: Newcastle, Australia
Distribution: debian stable
Posts: 394

Original Poster
Rep: Reputation: 30
I disabled effects. I ran metacity. BUt every time I reboot or log out log in I need to run metacity, otherwise I have no window function as before.
 
Old 11-29-2006, 10:15 PM   #7
Hitboxx
Senior Member
 
Registered: Mar 2006
Location: India
Distribution: Fedora
Posts: 1,562
Blog Entries: 3

Rep: Reputation: 61
Put "metacity &" on a new line in your ".bash_profile" in your home directory. This will launch it every time you log in. Also check what's the case with root account, no borders there?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FC6: desktop effects = no window "On Top" psychobyte Fedora 1 11-01-2006 06:50 AM
FC6 desktop effects cause screen frozen heha Fedora 1 10-29-2006 11:39 PM
AIGLX 3d Desktop effects on Suse 10.1 tfm1 Linux - Software 1 10-26-2006 05:57 AM
window id, gnome-like desktop when show icons disabled (KDE, 2005 LE) + root-tail Emmanuel_uk Mandriva 1 11-16-2005 12:27 PM
Gnome 2.2 window effects... how do I get rid of them? QCompson Linux - Software 0 08-29-2003 08:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration