LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-27-2009, 06:34 PM   #1
crxssi
Member
 
Registered: Apr 2005
Location: USA
Distribution: Mageia,Fedora,RHEL,CentOS
Posts: 94

Rep: Reputation: 16
Disable subpixel antialiasing?


Subpixel antialiasing doesn't look very good on my monitor because I get color "ringing". (Subpixel is when red and blue pixels are used on the sides of font dots to try and smooth diagonal/curved lines... you can see this more easily by using "xmag" or "kmag" and zooming into some text on the screen).

I would like to disable subpixel (RGBA) and just use greyscale antialiasing instead. On some systems, I had success by use adding this to my .fonts.conf file:

<match target="font" >
<edit mode="assign" name="rgba" >
<const>off</const>
</edit>
</match>

Normally such a construct would immediately take effect on any new application launched that uses freetype/fontconfig. (I have also used "none" instead of "off"). However, this doesn't appear to work on this Mandriva 2009.1 system! I even tried it in /etc/fonts/conf.d and it doesn't do anything there either.

Documentation for fontconfig is really spotty. I have spent many hours fighting this to no avail. Am I missing something? Thanks!
 
Old 08-28-2009, 11:02 AM   #2
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Testing"
Posts: 6,096

Rep: Reputation: 408Reputation: 408Reputation: 408Reputation: 408Reputation: 408
If you're running KDE3 this can be fixed by running kcontrol from a terminal.
Appearance & Themes -> Fonts -> Configure anti-aliasing
I think you may have to logout and then back in to see the changes.
 
Old 08-28-2009, 06:17 PM   #3
crxssi
Member
 
Registered: Apr 2005
Location: USA
Distribution: Mageia,Fedora,RHEL,CentOS
Posts: 94

Original Poster
Rep: Reputation: 16
I am running KDE4 at home. I have verified that when you use systemsettings and go under Appearance->Fonts->Use Anti-Aliasing it is set to Enabled and Use Sub-pixel Rendering is disabled (off/unchecked). I have logged out, even restarted the Xserver. Makes no difference, it is still performing (color) sub-pixel rendering in all applications.

I also verified that KDE4 systemsettings is, indeed, just modifying ~.fonts.conf in exactly the way I was doing manually. I am not sure how this system can ignore ~.fonts.conf and yet use fontconfig.
 
  


Reply

Tags
antialiasing, fontconfig, mandriva, subpixel


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GTK 2.8 Subpixel Hinting? milkycow Slackware 3 09-17-2011 09:07 AM
Subpixel rendering and xrandr Morosoph Linux - Desktop 1 08-27-2009 06:38 PM
RHEL 3 - Can't disable antialiasing jaloba Red Hat 1 08-29-2005 11:46 AM
Firefox not using subpixel antialiasing? wintermute222 Linux - Software 6 03-15-2004 12:40 AM
Disable antialiasing in GTK2 apps Wynd Linux - General 0 12-18-2003 08:13 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration