-   Linux - Software (
-   -   Digikam 2.2.1 won't start (

CollieJim 01-24-2012 05:38 AM

Digikam 2.2.1 won't start
I have just installed Digikam 2:2.1.1-0ubuntu1 in Kubuntu 11.10. All the photos from Digikam on my Gentoo system are on a network drive now. They used to be on a USB drive.

When I started 2.1.1 the first time I got the configuration window. When I clicked 'Finish', Digikam died with no message. If I type digikam in a terminal window, I get

QSqlDatabasePrivate::removeDatabase: connection 'ConnectionTest' is still in use, all queries will cease to work.
I rebooted and tried again, but got the same result.

The last session on the superseded Gentoo system finished normally.

How do I get Digikam working on a network drive?


eco 01-26-2012 07:17 AM

This is just a thought but could it be that your Digikam Gentoo puts his config files (forgot the name) on the network drive and that your Digikam on Kubuntu is trying to use them for his own?

CollieJim 01-27-2012 06:55 AM

Possible, but I think something else is happening here.

I just updated the Gentoo system and got Digikam 2.4.1. I started it from the command line as root by mistake. It appeared to start normally and presented a configuration window. I killed the window so I could restart as my normal user id.

As a normal user I got the above message immediately.
As root, I got the configuration window again, but when finished, I got the above message again.
I would think it is a bug in digikam. I will check their website and report it if necessary.
There may be a database incompatibility issue here.

All times are GMT -5. The time now is 01:38 AM.