-   Linux - Software (
-   -   Difficulty installing OpenAstro for Ubuntu 12.04 (

michaelas 09-30-2012 02:04 PM

Difficulty installing OpenAstro for Ubuntu 12.04
I am a Linux Newbie. I just installed Ubuntu v 12.04.1, having tried out Suse Linux back in 2008. Currently using Windows 7, and wanting to get away from it.

I am trying to install Open Astro v 1.1.25
I have managed to download the software (I think), as the file is in the Software Center, but am unclear about how to install it.
When I tried opening through the Ubuntu Software Center (double click on the file) I get a page describing the openastro features, with the following message:
Dependency is not satisfiable: python 2.6

On the Astro download page, under Ubunto, it lists three links, for Maverick, Natty, and Oneiric. Since I have Ubuntu v 12.04, I wasn't sure which to pick, so I clicked on Oneiric (under I-386, with the other two choices being AMD 64, and LPLA), I have an AMD processor, but it is not 64 (32 I think). Anyway, I went to the Terminal and typed in the following commands listed at the bottom of the download page (see openastro link above):


tar -xzf openastro.org_1.1.25.orig.tar.gz


sudo ./ install

It seemed to download everything fine, and then I found the file on the software page when I searched for it, and it was also in my dash folder. But then I got the error message.

Is Python the problem?

Anyone know where I can go from here?
Thanks for your help.

Hope this is the right forum. Sorry if it's not.


knudfl 10-01-2012 10:28 AM

Welcome to LQ.

sudo apt-get install \
python-all-dev python-dateutil python-rsvg python-gtk2 python-cairo imagemagick

cd && sudo python install

... But the data files are installed to a wrong location (/usr/local),
so this is a solution :
1) sudo cp -a /usr/local/share/ /usr/share/
2) sudo cp -a /usr/local/share/swisseph/ /usr/share/

P.S. : Same issues with Debian Wheezy (Ubuntu is a Debian clone),
but no issues on other OS's with Python2.7, e.g. Fedora 17.


knudfl 10-01-2012 12:20 PM

... Later : I found the right syntax for installing to /usr/ .
( Not sure what happened, when I tried 2 hours ago.)

It's as simple as : sudo python install --prefix=/usr

michaelas 10-02-2012 10:16 PM

Wow, thanks for replying. That's tons more than one of the "other sites" did.
Sorry. I'm embarrassed to admit this, but I'm not 100% sure what you said in both your posts, knudfl.
Am I to insert these into the terminal as written?
Not sure of which order to do things in.
I wouldn't mind just a little more newbie translation.
I appreciate your reply. makes me feel hopeful here. :Pengy:

knudfl 10-03-2012 12:19 AM

Post # 4

Yes. All long commands / combined commands can be executed as one command.

sudo apt-get install python-all-dev python-dateutil python-rsvg python-gtk2 python-cairo imagemagick
2) And if you have the openastro folder (with the same name) in your current location:

cd && sudo python install --prefix=/usr
etc. etc.

And you don't have to type the commands.
In Linux the "mouse middle button" will paste any highlighted text.


michaelas 10-03-2012 09:15 AM

Thank's so much, knudfl.
I will try this and get back to you.

All times are GMT -5. The time now is 05:41 PM.