-   Linux - Software (
-   -   difficulty installing distributions (

namayay 10-19-2004 10:02 AM

difficulty installing distributions
A bit of assistance please.

I have recently upgraded to a gigabyte 848p motherboard. At the same time I installed Windoze XP SP2 onto the machine with the intention of finally installing a Linux distribution - my intention was to try and install Linare under a dual boot.

That installation did not work, so I tried to install Mandrake 10.1 community- didn't work either. So guaess what? Tried Suse 9.1 (which I had operated previously) - no luck again.

Each time the programs literally kick me off saying that the partition table was not correct. I had partitioned my system in windoze using Partition Magic 8.0 (same as I have done previously)

To assist anyone with feedback, my machine is Pentium 4 2.4Ghz machine running 2 hardrives with 7 partitions across the drives (wife and kids use the these drives mostly). All partitions are NTFS, except for one ptition that has been ext2 and ext3 (at various times in recent days). Ram is 512m

Help - I miss my Linux (sniff)

bulliver 10-19-2004 10:10 AM

Can you give us a bit more help with the errors you are getting, and at which point during the install you get them? You're not trying to install Linux on partitions created by XP are you? You will want to make new partitions using whichever tool the distro you are installing provides.

tuxisnottux 10-19-2004 11:16 AM

SuSE encouragement--don't give up
Some encouragement, though not a direct solution:
I have RH9, RH7.2, Mandrake 9.x and SuSE 9.x (in process of un-hosing) plus W98SE and SMSQ (actually a simulator under W98) on my main machine. So it can be done--as I say, encouragement (more than howto), although I'd have to study what I did to remember, as it's been quite a while.

I started with W98 and Partition Magic (8.0 in fact), making partitions, say a /boot and a /root before each Lx install,(one swap for all four Lx's). For Lx installs, I mostly took their defaults for a "typical" install, possibly with some custom treatment of partitions and examining all that "/dev/hdax" business (oh yes, some logical/extended partitions within primaries, or whatever the terms are, in PM 8.0).

I managed to get grub installed and make entries, I believe in grub.conf, and grub works fine for all 6 OS's. I had trouble with two or three of the installs where I had to put "rootnoverify (hdx,y)" for grub to see and pick up. Possibly through LQ I learned I wasn't setting x,y quite right, so not always a big deal.

Lately, I forgot my SuSE root pwd and tried to do what I'd done for the Mandrake pwd, which involved rescue mode. This was easy in Mandrake, using CD1, but SuSE required "Rescue login" for which there was nothing. I decided to reinstall, starting with I believe the /boot partition, and kept getting "module failed" or some such. After a slew of those I aborted the install. At this point Partition Magic would no longer delete the partition due to "wrong file system"--PM 8 understands ext2 and 3, but possibly not Reiser. I had tried a totally custom partitioning in SuSE install I believe. The second time I took more of their recommendations (though a partially custom partitioning) including a separate swap for SuSE (BTW, all four Lx's worked fine before I forgot the two root pwds) and couldn't find the place to make a separate /boot and /root. SuSE installed fine, but I can't make grub boot buy the old (hd0,5) or a new guessed at (hd0,7) or (hd0,6). The old line was rootnoveriy (hd0,5) (for /dev/hda6; logical within primary). I've tried

grub> rootnoverify (hd0,7)
grub> makeactive

but instead of allowing me to go on to

grub> chainloader +1 (then boot)

that is already in grub.conf or whatever the file is, I get "Error 12: invalid device specified", even when I makeactive a known partition. Haven't looked up 12 yet; seems it was 13 with my previous (hdx, y) problems.

Anyway, cannot get to SuSE just yet. Would like to get Pro 9.x when it comes out, esp since it's not that much more $$ than personal.


namayay 10-19-2004 11:18 AM

The trouble seems to be at the point where the programme is trying to start installing files onto the ext2 or ext3 partitions, which were created using Partition Magic.

I had initially thought that maybe the distributions have some problem identifying something to do with the motherboard, but at least one stated that it was unhappy with the partition tables, during loading.

bulliver 10-19-2004 01:01 PM

Again, I think your best bet is to delete these partitions then recreate them using the installer rather than PM...

All times are GMT -5. The time now is 04:41 AM.