Latest LQ Deal: Latest LQ Deals
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 10-09-2009, 03:35 PM   #1
LQ Newbie
Registered: Jul 2005
Location: Northern Virginia
Distribution: SuSE 9.1 Personal
Posts: 21

Rep: Reputation: 0
Difficulty getting NTP to sync the system clock on SuSE Linux 8.


I am having great difficulty getting xntp (4.1.1-121) to work on a SuSE Linux 8 (2.4.19-64GB-SMP). The hardware clock seems to maintain the proper time but the system clock drifts upwards over the course of the day upwards of six seconds.

The drift file never updates and continually shows a 0.000. Never changing out of that.

This is the output from an ntpq -c rv -p.

status=c011 sync_alarm, sync_unspec, 1 event, event_restart,
version="ntpd 4.1.1@1.786 Wed Oct 16 12:55:05 UTC 2002 (1)",
processor="i686", system="Linux2.4.19-64GB-SMP", leap=11, stratum=16,
precision=-17, rootdelay=0.000, rootdispersion=371.775, peer=0,
refid=, reftime=00000000.00000000 Thu, Feb 7 2036 0:28:16.000,
poll=4, d"clock=ce7a18ee.befa5093 Fri, Oct 9 2009 15:17:50.746, state=0,
offset=0.000, frequency=0.000, jitter=0.008, stability=0.000
remote refid st t when poll reach delay offset jitter
dc01.strat_nt.s .LOCL. 1 u 5 64 377 73.216 -512.48 14.547

The clock frequency, jitter, and stability never change. We have other servers that clock off of the same server we are running and they do not have problems.

Below is the ntp.conf for this system.

# Permit time synchronization with our time source, but do not
# permit the source to query or modify the service on this system.
restrict default kod nomodify notrap nopeer noquery
restrict -6 default kod nomodify notrap nopeer noquery

# Permit all access over the loopback interface. This could
# be tightened as well, but to do so would effect some of
# the administrative functions.
restrict -6 ::1

# Hosts on local network are less restricted.
#restrict mask nomodify notrap

restrict default ignore
restrict mask nomodify notrap

# Use public servers from the project.
# Please consider joining the pool (
# server
# server
# server

#broadcast key 42 # broadcast server
#broadcastclient # broadcast client
#broadcast key 42 # multicast server
#multicastclient # multicast client
#manycastserver # manycast server
#manycastclient key 42 # manycast client

# Undisciplined Local Clock. This is a fake driver intended for backup
# and when no outside source of synchronized time is available.
# server # local clock
# fudge stratum 10
restrict nomodify

# Drift file. Put this in a directory which the daemon can write to.
# No symbolic links allowed, either, since the daemon updates the file
# by creating a temporary in the same directory and then rename()'ing
# it to the file.
driftfile /var/lib/ntp/drift

# Key file containing the keys and key identifiers used when operating
# with symmetric key cryptography.
keys /etc/ntp/keys

# Specify the key identifiers which are trusted.
#trustedkey 4 8 42

# Specify the key identifier to use with the ntpdc utility.
#requestkey 8

# Specify the key identifier to use with the ntpq utility.
#controlkey 8

I have ensured that the drift file was accessible and moved it to /tmp for testing. It has rw permissions across the board. I have tried both with and without the restrictions and with different flags on the restrictions with no luck.

Any assistance you can provide on this would be welcome.
Old 10-09-2009, 04:07 PM   #2
harry edwards
Registered: Nov 2007
Location: Lincolnshire, UK
Distribution: CentOS, Fedora, and Suse
Posts: 365

Rep: Reputation: 48
Have you tried switching on the debug for ntpd. On my fedora system I'd do this by modifying the content of /etc/sysconfig/ntpd from

OPTIONS="-u ntp:ntp -p /var/run/ -g"


OPTIONS="-u ntp:ntp -p /var/run/ -g -D<debug level here>"

Then restart ntpd to active.

Also, this page has a lot of useful checks
Old 10-10-2009, 07:21 AM   #3
LQ Veteran
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 422Reputation: 422Reputation: 422Reputation: 422Reputation: 422
# Use public servers from the project.
# Please consider joining the pool (
# server
# server
# server
Um, all your external servers are commented out. To be honest I'm not all that conversant with ntp, but it seems to me that at least 1 external server might help.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
sync Linux clock to windows 2003 AD m2azer Linux - Networking 1 01-11-2007 02:17 PM
Sync KDE/System Time w/ NTP carlosinfl Linux - General 6 03-15-2006 03:37 PM
ntp hell: System clock runs twice as fast as it should do jimieee Linux - Software 0 01-23-2004 05:17 AM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:54 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration