-   Linux - Software (
-   -   different gaim install gtk error (

shanenin 10-17-2003 07:14 PM

different gaim install gtk error
I left an earlier post about a plugin not loading with gaim, that was on redhat.

I just tried installing on slackware I get this error when trying to run the command gaim
root@marsala:/home/shane/src/gaim-0.71# gaim
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

(gaim:25374): Gtk-WARNING **: cannot open display:
what does that mean?

Harpune 10-17-2003 07:16 PM

If you have X windows running, you are trying to run gaim from the root account and your X server is running as a different account. If you type 'exit' and log out of root, you should be in the proper account. At that point gaim should work for you

shanenin 10-17-2003 07:24 PM

thanks that was the problem, I was using root because of my final "make install"

now that is is working I am still getting the same error of msn plugin not loading

GT_Onizuka 10-17-2003 07:28 PM

i got this off of the gAIM FAQ


Q: I just upgraded Gaim and the MSN plugin will not load. Why?

A: You did not compile with SSL support. As of protocol version 9, the MSN protocol requires the use of SSL, which gaim provides by either GnuTls or the combination of NSS and NSPR from the Mozilla project. Install one or both of these and recompile Gaim.
however if you know you installed SSL support this will help you


Q: The MSN plugin won't load, but I have Mozilla NSS!

A: Some distributions, including Slackware, install Mozilla NSS to a non-standard directory. The fix is simple. Edit /etc/ and add /usr/lib/mozilla-1.4 (or whatever version you're using, but it's usually 1.4) to the file. Then re-run configure and recompile Gaim.

Mozilla 1.5 has a broken .pc file and does not install the necessary .h files, and so will not be detected.
hope this helps ya ^_^

shanenin 10-17-2003 08:25 PM

thank you that sure will.

All times are GMT -5. The time now is 04:49 AM.