LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-06-2005, 08:08 PM   #1
carlosinfl
Senior Member
 
Registered: May 2004
Location: Orlando, FL
Distribution: Arch
Posts: 2,905

Rep: Reputation: 77
Question Did I successfully install Java?


How can I tell if I have Java installed? I used yum in FC3 to install Java on my system and it said was 100% but then I installed Limewire RPM file and Limewire will not start. I know Limewire is Java dependant but I don't know if its Java that is forked or Limewire?

I see a Java icon under Preferences and then I downloaded a Java RPM for FC3 and get this error.
Code:
[root@server carlos]# rpm -Uvh j2re-1.4.2-11.1.fc3.rf.i586.rpm
Preparing...                ########################################### [100%]
        package j2re-1.4.2-11.1.fc3.rf is already installed
Any suggestions on how I can see if Java is working for me or how to see what the deal with Limewire P2P is?
 
Old 03-06-2005, 08:38 PM   #2
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
Perhaps it would help more to post the errors generated when you attempt to launch limeware.

Launch it from an x terminal and you can see, copy and paste the errors so we can see them.

# Red Hat & Fedora links
FedoraNEWS.ORG
The Fedora HOWTO explains the different software managers.
Maximum RPM
rpmfind
Easier software management: apt4rpm
Fedora Core 1 Tips and Tricks
Fedora Core 2 Tips and Tricks
Fedora Core 3 Tips and Tricks
apt, yum, and up2date repository settings (configuration files) for Fedora Core 3
# Handling NTFS
New Technology FileSystem (NTFS) HOWTOs
Linux NTFS project
 
Old 03-06-2005, 08:44 PM   #3
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911
updatedb
locate java | grep \/bin\/


from a shell:
java<enter>



Cheers,
Tink
 
Old 03-06-2005, 11:21 PM   #4
zymos
Member
 
Registered: Mar 2005
Location: Boulder, CO
Distribution: Debian, previously Gentoo
Posts: 39

Rep: Reputation: 15
also check to see if java's bin is in your path

echo $PATH

/sbin:/usr/sbin:/bin:/usr/bin:/usr/X11R6/bin:/home/zymos/scripts/:/usr/java/j2sdk1.4.2_01/bin/

that can be a source of java problems

to add it add
PATH=$PATH:/usr/java/j2sdk1.4.2_01/bin/

in .bashrc or .bash_profile

with ur java location of course

jeff
 
Old 03-07-2005, 07:46 AM   #5
carlosinfl
Senior Member
 
Registered: May 2004
Location: Orlando, FL
Distribution: Arch
Posts: 2,905

Original Poster
Rep: Reputation: 77
Quote:
Originally posted by fancypiper
Perhaps it would help more to post the errors generated when you attempt to launch limeware.

Launch it from an x terminal and you can see, copy and paste the errors so we can see them.

Code:
[carlos@server ~]$ whereis limewire
limewire: /usr/bin/limewire
[carlos@server ~]$ cd /usr/bin/
[carlos@server bin]$ limewire
java.lang.UnsatisfiedLinkError: /usr/lib/jre/lib/i386/libawt.so: libXp.so.6: cannot open shared object file: No such file or directory
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
        at java.lang.ClassLoader.loadLibrary0(Unknown Source)
        at java.lang.ClassLoader.loadLibrary(Unknown Source)
        at java.lang.Runtime.loadLibrary0(Unknown Source)
        at java.lang.System.loadLibrary(Unknown Source)
        at sun.security.action.LoadLibraryAction.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.awt.Toolkit.loadLibraries(Unknown Source)
        at java.awt.Toolkit.<clinit>(Unknown Source)
        at com.limegroup.gnutella.gui.Main.showInitialSplash(Main.java:52)
        at com.limegroup.gnutella.gui.Main.main(Main.java:26)
runLime.sh: line 26: unexpected EOF while looking for matching `"'
runLime.sh: line 30: syntax error: unexpected end of file
What does this mean?
 
Old 03-07-2005, 09:43 AM   #6
zeropash
Member
 
Registered: Apr 2003
Location: Bangalore,India
Distribution: FC2, RHES, RH9, FC3, FC1, Slackware 3.0
Posts: 208

Rep: Reputation: 30
check if you have a library called /usr/X11R6/lib/libXp.so.6
check if xorg-x11-deprecated-libs (check using rpm -qi xorg-x11-deprecated-libs)
if its not there install it and then try.
 
Old 03-09-2005, 07:06 PM   #7
zab
LQ Newbie
 
Registered: Mar 2005
Location: Big Apple
Distribution: FC
Posts: 12

Rep: Reputation: 0
We released a new RPM today that should address this problem, or at least give more information about what may have gone wrong. Please give it a try.
 
Old 03-09-2005, 07:11 PM   #8
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911
zab == RedHat official? :)


Cheers,
Tink
 
Old 03-09-2005, 07:13 PM   #9
zab
LQ Newbie
 
Registered: Mar 2005
Location: Big Apple
Distribution: FC
Posts: 12

Rep: Reputation: 0
no, I work for Lime Wire LLC and I built the rpm.
 
Old 03-09-2005, 07:15 PM   #10
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911
Well .. welcome to LQ, and thanks for fixing the thing ;)


Cheers,
Tink
 
Old 03-13-2005, 03:36 PM   #11
carlosinfl
Senior Member
 
Registered: May 2004
Location: Orlando, FL
Distribution: Arch
Posts: 2,905

Original Poster
Rep: Reputation: 77
Quote:
Originally posted by zab
We released a new RPM today that should address this problem, or at least give more information about what may have gone wrong. Please give it a try.
So what I guess you're saying is that I need to remove the RPM I installed and redownload and install the new RPM on Limewires site?

I don't know how I remove the old RPM I installed. Can someone tell me how I can do this? I do see a Limewire icon under "Applications > Internet"
 
Old 03-13-2005, 07:28 PM   #12
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
Maximum RPM

Also see:

man rpm
info rpm

rpm -e <package name without the .rpm>

I have Linux installed, now how do I work some stuff like installing some software?
# I can't figure out what software I want and how to install/uninstall it
The table of equivalents, replacements, analogs of Windows software in Linux
# Find software here
Freshmeat
Sourceforge
rpmfind
# Guides to software management
LNAG: 4.5 Package installation and rpm package manager
Rute Guide's software explanation
You might want to check out CheckInstall to manage source code installations/uninstallation

# Red Hat & Fedora links
FedoraNEWS.ORG
The Fedora HOWTO explains the different software managers.
Maximum RPM
rpmfind
Easier software management: apt4rpm
ATrpms - installation instructions
Fedora Core 1 Tips and Tricks
Fedora Core 2 Tips and Tricks
Fedora Core 3 Tips and Tricks
apt, yum, and up2date repository settings (configuration files) for Fedora Core 3
# Handling NTFS
New Technology FileSystem (NTFS) HOWTOs
Linux NTFS project

Last edited by fancypiper; 03-13-2005 at 07:32 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
successfully install deb packages without using alien pafinator11 SUSE / openSUSE 2 11-15-2005 07:58 PM
Why Won't Net_SSLeay Install Successfully?? njugs79 Linux - Newbie 5 04-07-2005 02:24 AM
Guide successfully install ATI video drivers seelk SUSE / openSUSE 2 02-05-2005 09:43 AM
Successfully installed blackdown-jdk14; no java/javac coindood *BSD 1 09-27-2004 05:40 PM
successfully install kahakai? calvin_wang Fedora 0 03-28-2004 09:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration