-   Linux - Software (
-   -   Desktop Effects used to work now they don't! (

hudsonryde 01-19-2010 11:21 AM

Desktop Effects used to work now they don't!
k, I've been running Karmic for awhile now, and I had all my desktop effects and eye candy set up perfectly, and then i made the mistake of thinking I knew things about linux.... haha

my flash was running slow, and i was attempting various fixes i found online, including mussing in the xorg.conf. well i somehow managed to disable my laptop's ability to run any sort of eye candy, I know it's capable since i've done it before.

i have the standard Intel integrated graphics card that a million other people have, yadda yadda. the main problem(i believe) is getting to where i can select "Normal" under Visual Effects, but when i try all I get is the lovely "Desktop effects could not be enabled" message. hoorah. any help would be GREATLY appreciated.

manwichmakesameal 01-19-2010 03:08 PM

You should probably post your xorg.conf since you edited it.

hudsonryde 01-19-2010 08:54 PM

well, when I tried to edit the xorg.conf, it was blank, so i tried adding what i needed and it messed stuff up, so deleted the changes i made, so now, as far as I can tell, I still have a blank xorg.conf

Vampirite 01-20-2010 02:18 AM

Delete your xorg.conf completely, X may just autodetect everything and it should be fine, otherwise run this:

dpkg-reconfigure xserver-xorg

hudsonryde 01-20-2010 11:07 AM

hmm...I'm not entirely sure how to delete the xorg.conf haha, any help that would be appreciated.

and as far as reconfiguring it, that was one of the first things i tried, but i did it again just now, for measure, and still get the fun little "Desktop effects could not be enabled." message

kalaka 01-21-2010 07:21 AM

The new release of X (which comes with Karmic) no longer requires an xorg.conf. Integrated Intel cards should be autoconfigured (I have one on my laptop, which also runs Karmic).

My advice to you is to delete xorg.conf with

sudo rm /etc/X11/xorg.conf
and then reinstall the intel driver (called xserver-xorg-video-intel)

sudo apt-get install xserver-xorg-video-intel
If you get a message saying "program already installed" you can download the .deb file from one of these links and select the "reinstall package" option.

I hope I helped, good luck!

pjeeanah 01-22-2010 09:45 AM

I think the problem is with with the intel driver. I have a link for jaunty, but exactly the same instructions work for karmic. Here's the link:


pjeeanah 01-22-2010 10:46 AM

NB: If you dont know how to configure your firewall, just skip the keyserver step. You will get a security warning, but go ahead and say yes to install the package.

hudsonryde 02-22-2010 02:15 PM

awesome thank you all, sorry I've been a bit out of the loop but I shall try this today!

All times are GMT -5. The time now is 07:06 AM.