LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-19-2016, 03:52 PM   #16
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 20 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917

Quote:
Originally Posted by Habitual View Post
and I believe he'll need to comment contents of or outright move/delete /etc/apt/sources.list.d/dreibh-ppa-trusty.list
as I believe it may conflict with the repo I supplied, if that is to be used.

Just sayin',
Thanks!
Thanks, Habitual. To be honest, I hadn't even thought about where to source Wireshark yet, just getting things all cleaned up first. I've just looked at the Wireshark web site though and they suggest the PPA you mentioned so good shout.
 
Old 08-19-2016, 04:45 PM   #17
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
It's a "we thing" not a "me thing" my friend.

Last edited by Habitual; 08-20-2016 at 09:11 AM.
 
Old 08-19-2016, 06:33 PM   #18
TheOrangeRemix
LQ Newbie
 
Registered: Aug 2016
Posts: 19

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by hydrurga View Post
Thanks. For info, ii effectively means that a package is installed, un uninstalled, and rc shows that the package is uninstalled but config files have still to be removed.

So, do the following, but if any of the commands appear to be proposing the removal of additional packages that don't look related to Wireshark then don't go through with the removal and paste the output here:

Code:
sudo apt-get purge libwireshark-data
sudo apt-get purge libwireshark0:amd64
sudo apt-get purge wireshark-common
sudo apt-get purge wireshark-doc
apt-get purge removes both a package and its configuration files (but usually not your personal configuration files in your home folder, although that shouldn't be a problem here).

P.S. Can you please go back and edit out a lot of those '=' characters in your previous post as they're pushing the thread beyond the width of the screen (or at least on my screen ;-))
I went through the removal of those packages and it did not seem to be removing anything that was not related to Wireshark. Shall I now try re-installing Wireshark with

Code:
sudo apt-get install wireshark
 
Old 08-19-2016, 07:11 PM   #19
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 20 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917
No, not yet. First of all, we're going to check that there are no unnecessary dependencies hanging around (because you've experienced some dependency problems), and then do another update/upgrade to check all is in order. After that, as Habitual mentioned, we have to remove the dreibh ppa from your repository list so that we don't install that PPA's version of Wireshark (I'm assuming that you only added that repository for Wireshark and haven't installed any other software from it) and then add Wireshark's repository. After that, Wireshark can be installed.

If anything out of the ordinary happens with any of the following commands, take a break in the process and come back here with info.

Check that there are no unnecessary dependencies (packages that were installed by other packages but are no longer needed):

Code:
sudo apt-get autoremove
Final check that all is good to go:

Code:
sudo apt-get check
sudo apt-get update
sudo apt-get upgrade
Remove dreibh ppa (for some reason, Linux Mint 17.3 does not support the --remove flag for add-apt-repository so we'll do it through the gui):

. Run Synaptic Package Manager
. Settings->Repositories->PPAs
. Highlight dreibh and click on Remove. Do the same for dreibh (Sources).
. Authentication keys: highlight Launchpad PPA for Thomas Dreibholz and click on Remove.
. Close Synaptic Package Manager

Add Wireshark PPA (see https://launchpad.net/~wireshark-dev.../ubuntu/stable)

Code:
sudo add-apt-repository ppa:wireshark-dev/stable
Update the database with the new info provided by the above repository and install the package:

Code:
sudo apt-get update
sudo apt-get install wireshark-qt

Last edited by hydrurga; 08-20-2016 at 09:46 AM.
 
1 members found this post helpful.
Old 08-20-2016, 09:12 AM   #20
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Quote:
Originally Posted by hydrurga View Post
Update the database with the new info provided by the above repository and install the package:

Code:
sudo apt-get update
sudo apt-get install wireshark
Not wireshark-qt?
 
Old 08-20-2016, 09:47 AM   #21
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 20 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917
Quote:
Originally Posted by Habitual View Post
Not wireshark-qt?
Good call, thanks. Amended.
 
Old 08-22-2016, 11:30 AM   #22
TheOrangeRemix
LQ Newbie
 
Registered: Aug 2016
Posts: 19

Original Poster
Rep: Reputation: Disabled
After clearing those dependencies and reinstalling Wireshark by following the instructions above, I can start Wireshark now. Thanks very much for your help!
 
Old 08-22-2016, 11:49 AM   #23
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 20 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917
Quote:
Originally Posted by TheOrangeRemix View Post
After clearing those dependencies and reinstalling Wireshark by following the instructions above, I can start Wireshark now. Thanks very much for your help!
Yay!
 
Old 08-22-2016, 02:55 PM   #24
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
And the Gold goes to TeamLQ!
 
Old 03-21-2017, 03:43 PM   #25
Desant
LQ Newbie
 
Registered: Mar 2017
Location: Moscow, Russia
Distribution: Mint 18.1
Posts: 10

Rep: Reputation: Disabled
Similar trouble

Hi.
Sorry for lifting an old topic, i thought it's better than starting a new one, since i have similar problem as TheOrangeRemix had.


I use Linux Mint 18.1 Serena

When running
Quote:
sudo apt-get install
i get this

Quote:
artem@artem-W840AU ~ $ sudo apt-get install wireshark
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
wireshark : Depends: wireshark-qt but it is not going to be installed or
wireshark-gtk but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
for
Quote:
sudo apt-get install wireshark-qt
i receive


Quote:
The following packages have unmet dependencies:
wireshark-qt : Depends: libnl-route-3-200 (>= 3.2.7) but it is not installable
Depends: libqt5multimedia5 (>= 5.0.2) but it is not installable
Depends: libwireshark8 (>= 2.2.5) but it is not going to be installed
Depends: wireshark-common (= 2.2.5+g440fd4d-2~xenial1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Quote:
dpkg -l *wiresh*
dpkg-query: no packages found matching *wiresh*
where should i look now?
 
Old 03-21-2017, 03:59 PM   #26
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 20 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917
Did you work through the same steps that the OP was advised to do to clear up the situation?

Start with post #4.
 
Old 03-21-2017, 04:11 PM   #27
Desant
LQ Newbie
 
Registered: Mar 2017
Location: Moscow, Russia
Distribution: Mint 18.1
Posts: 10

Rep: Reputation: Disabled
I think so.

After executing
Quote:
sudo apt-get update
i get
Quote:
Reading package lists... Done
W: The repository 'http://manpages.ylsoftware.com/debian all Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: The repository 'http://www.skulltag.com/download/files/release/deb stable Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: The repository 'http://packages.domain.com xenial Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: The repository 'http://ftp.mtu.ru/pub/ubuntu/archive xenial Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: The repository 'http://ftp.mtu.ru/pub/ubuntu/archive xenial-updates Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: The repository 'http://ftp.mtu.ru/pub/ubuntu/archive xenial-backports Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: GPG error: http://ppa.launchpad.net/teward/wireshark/ubuntu xenial InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 4A3EF61EE616D378
W: The repository 'http://ppa.launchpad.net/teward/wireshark/ubuntu xenial InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: http://security.ubuntu.com/ubuntu/di...ity/InRelease: Signature by key 630239CC130E1A7FD81A27B140976EAF437D05B5 uses weak digest algorithm (SHA1)
W: http://extras.ubuntu.com/ubuntu/dist...e/Release.gpg: Signature by key C47415DFF48C09645B78609416126D3A3E5C1192 uses weak digest algorithm (SHA1)
N: Skipping acquire of configured file 'non-free/binary-i386/Packages' as repository 'http://dl.google.com/linux/deb stable InRelease' doesn't support architecture 'i386'
W: http://ppa.launchpad.net/dajhorn/ado...k/Release.gpg: Signature by key F5FB497310207E1F600380B30D18601A1EE8660B uses weak digest algorithm (SHA1)
W: http://download.ebz.epson.net/dsc/op...2/Release.gpg: Signature by key E5220FB7014D0FBDA50DFC2BE5E86C008AA65D56 uses weak digest algorithm (SHA1)
E: Failed to fetch http://www.skulltag.com/download/fil...amd64/Packages 404 Not Found
E: Failed to fetch http://packages.domain.com/dists/xen...amd64/Packages 404 Not Found
E: Failed to fetch http://ftp.mtu.ru/pub/ubuntu/archive...amd64/Packages 403 Forbidden [IP: 212.188.20.226 80]
E: Failed to fetch http://ftp.mtu.ru/pub/ubuntu/archive...amd64/Packages 403 Forbidden [IP: 212.188.20.226 80]
E: Failed to fetch http://ftp.mtu.ru/pub/ubuntu/archive...amd64/Packages 403 Forbidden [IP: 212.188.20.226 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.
then upgrade
Quote:
The following packages will be upgraded:
linux-libc-dev
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/839 kB of archives.
After this operation, 5*120 B of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 315055 files and directories currently installed.)
Preparing to unpack .../linux-libc-dev_4.4.0-67.88_amd64.deb ...
Unpacking linux-libc-dev:amd64 (4.4.0-67.88) over (4.4.0-64.85) ...
Setting up linux-libc-dev:amd64 (4.4.0-67.88) ...

dpkg -l *wiresh* shows nothing, hence i cannot purge any packages.
 
Old 03-21-2017, 04:41 PM   #28
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 20 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917
Wow, those repositories are a mess. Let's get that sorted out first.

Please paste the output of inxi -r (those are small i's)
 
Old 03-22-2017, 12:31 AM   #29
Desant
LQ Newbie
 
Registered: Mar 2017
Location: Moscow, Russia
Distribution: Mint 18.1
Posts: 10

Rep: Reputation: Disabled
Yes, I guess..

Quote:
inxi -r
Repos: Active apt sources in file: /etc/apt/sources.list
deb http://download.ebz.epson.net/dsc/op/stable/debian/ lsb3.2 main
deb http://www.skulltag.com/download/files/release/deb stable multiverse
Active apt sources in file: /etc/apt/sources.list.d/additional-repositories.list
deb http://dl.google.com/linux/earth/deb/ stable main
deb http://dl.google.com/linux/talkplugin/deb/ stable main
deb http://dl.google.com/linux/deb/ stable non-free
deb http://manpages.ylsoftware.com/debian/ all main
deb http://ppa.launchpad.net/dajhorn/adobeair/ubuntu maverick main
deb http://packages.domain.com/ xenial main
deb http://security.ubuntu.com/ubuntu precise-security main
deb http://ppa.launchpad.net/teward/wireshark/ubuntu xenial main
deb http://ppa.launchpad.net/wireshark-d...rk-deps/ubuntu trusty main
Active apt sources in file: /etc/apt/sources.list.d/canonical_partner.list
deb http://archive.canonical.com/ubuntu/ yakkety partner
Active apt sources in file: /etc/apt/sources.list.d/extras.list
deb http://extras.ubuntu.com/ubuntu/ precise main
Active apt sources in file: /etc/apt/sources.list.d/getdeb.list
deb http://archive.getdeb.net/ubuntu yakkety-getdeb apps
deb http://archive.getdeb.net/ubuntu yakkety-getdeb games
Active apt sources in file: /etc/apt/sources.list.d/me-davidsansome-clementine-xenial.list
deb http://ppa.launchpad.net/me-davidsan...mentine/ubuntu xenial main
deb-src http://ppa.launchpad.net/me-davidsan...mentine/ubuntu xenial main
Active apt sources in file: /etc/apt/sources.list.d/mint.list
deb http://packages.linuxmint.com/ serena import
deb http://packages.linuxmint.com/ serena main
deb http://packages.linuxmint.com/ serena upstream
Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
deb http://mirror.yandex.ru/linuxmint-packages serena main upstream import backport
deb http://ftp.mtu.ru/pub/ubuntu/archive xenial main restricted universe multiverse
deb http://ftp.mtu.ru/pub/ubuntu/archive xenial-updates main restricted universe multiverse
deb http://ftp.mtu.ru/pub/ubuntu/archive xenial-backports main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ xenial partner
Active apt sources in file: /etc/apt/sources.list.d/opera-stable.list
deb https://deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)
Active apt sources in file: /etc/apt/sources.list.d/otto-kesselgulasch-gimp-xenial.list
deb http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu xenial main
deb-src http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu xenial main
Active apt sources in file: /etc/apt/sources.list.d/team-xbmc-ppa-xenial.list
deb http://ppa.launchpad.net/team-xbmc/ppa/ubuntu xenial main
deb-src http://ppa.launchpad.net/team-xbmc/ppa/ubuntu xenial main
Active apt sources in file: /etc/apt/sources.list.d/ubuntu-wine-ppa-xenial.list
deb http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu xenial main
deb-src http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu xenial main
Active apt sources in file: /etc/apt/sources.list.d/webupd8team-unstable-xenial.list
deb http://ppa.launchpad.net/webupd8team/unstable/ubuntu xenial main
deb-src http://ppa.launchpad.net/webupd8team/unstable/ubuntu xenial main
Active apt sources in file: /etc/apt/sources.list.d/webupd8team-y-ppa-manager-xenial.list
deb http://ppa.launchpad.net/webupd8team...manager/ubuntu xenial main
deb-src http://ppa.launchpad.net/webupd8team...manager/ubuntu xenial main
Active apt sources in file: /etc/apt/sources.list.d/wine-wine-builds-xenial.list
deb http://ppa.launchpad.net/wine/wine-builds/ubuntu xenial main
deb-src http://ppa.launchpad.net/wine/wine-builds/ubuntu xenial main
Active apt sources in file: /etc/apt/sources.list.d/wireshark-dev-stable-xenial.list
deb http://ppa.launchpad.net/wireshark-dev/stable/ubuntu xenial main
deb-src http://ppa.launchpad.net/wireshark-dev/stable/ubuntu xenial main
 
Old 03-22-2017, 02:34 AM   #30
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 20 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917
Desant, one of the first rules of repositories is not to mix different versions of the same distro.

That means that, since you are running Linux Mint 18.1, you should only have Serena (Mint) and Xenial (the parent Ubuntu distribution) repositories, and no Yakkety, Precise etc. repos.

What I would suggest in the first place is that you run gksudo software-sources (use kdesudo instead of gksudo if you're using KDE/Plasma) and, in both the PPA and Additional Repositories sections, disable all the repositories temporarily by unchecking the Enabled box for each one.

That will leave us with only the official repositories for the moment. We'll address all the other repositories once we have the official ones working and check what problems you have on the system as a result of the repository mixing.

However, in addition, since the Russian mirrors you are using produced warnings about not having Release files, you should also click on the "Restore the default settings" button in the Official Repositories section and check that the Serena repository is listed as http://packages.linuxmint.com and the Xenial one as http://archive/ubuntu.com/ubuntu.

Now, close the Software Sources window and enter on the command line:

sudo apt-get update

and paste the results here. Many thanks.

Last edited by hydrurga; 03-22-2017 at 02:37 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Solved Dependency Is Not satisfiable: libvpx1 Error While Installing VirtualBox In Linux Mint 18 Beta LXer Syndicated Linux News 0 06-12-2016 10:15 PM
Mint upgrade => dependency problem ThePigster Linux - Software 3 06-05-2011 06:13 PM
library dependency error when starting wireshark/tcpdump danielle Linux - Newbie 5 01-07-2011 05:09 AM
Problem installing wireshark with yum bozoka45 Fedora 4 10-12-2007 04:33 PM
dependency problem by installing j2sdk-1_4_2-linux-i586.rpm linuxJaver Slackware 8 07-05-2003 12:04 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration