LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Deluge Problem (https://www.linuxquestions.org/questions/linux-software-2/deluge-problem-595286/)

asininity 10-28-2007 03:38 PM

Deluge Problem
 
Hi guys I'm using Ubuntu 7.10 and am having problems with deluge.

I recently tried unsuccessfully to install the updated litorrent and rtorrent while I used 7.04 before upgrading to 7.10. While using 7.04 I couldn't use deluge after messing up the rtorrent/litorrent thing, I thought the upgrade had sorted it but no.

Not sure what the hell is going on but the deluge in the repositories starts and thats it I can't delete torrents or add torrents and the only way I can shut it down is to end it process.

When I installed the lastest version from the debi file it doesn't even start heres the message I get trying to open deluge-torrent_0.5.6-1_i386:

Code:

laptop@laptop:~$ deluge
no existing Deluge session
Starting new Deluge session...
deluge_core; using libtorrent 0.13.0.0. Compiled with NDEBUG.
Applying preferences
Pickling state...
Scanning plugin dir /usr/share/deluge/plugins
Initialising plugin EventLogging
Initialising plugin WebSeed
Initialising plugin TorrentCreator
Initialising plugin MoveTorrent
Initialising plugin TorrentSearch
Initialising plugin DesiredRatio
Initialising plugin NetworkHealth
Initialising plugin Scheduler
Initialising plugin TorrentNotification
Initialising plugin ExtraStats
Initialising plugin BlocklistImport
Initialising plugin NetworkGraph
Initialising plugin SpeedLimiter
Initialising plugin TorrentFiles
Initialising plugin WebUi
Initialising plugin TorrentPeers
Initialising plugin Locations
Initialising plugin SimpleRSS
/home/asmos/.themes/Darker theme/gtk-2.0/gtkrc:50: Clearlooks configuration option "menuitemstyle" is not supported and will be ignored.
/home/asmos/.themes/Darker theme/gtk-2.0/gtkrc:51: Clearlooks configuration option "listviewitemstyle" is not supported and will be ignored.
/home/asmos/.themes/Darker theme/gtk-2.0/gtkrc:52: Clearlooks configuration option "progressbarstyle" is not supported and will be ignored.
Applying preferences
Starting DHT...
Showing window
Loading TorrentPeers plugin...
Loading TorrentFiles plugin...
Loading TorrentCreator plugin...
terminate called after throwing an instance of 'libtorrent::invalid_handle'
  what():  invalid torrent handle used
Aborted (core dumped)

Is the a way of un-installing everything I've tried "apt-get remove purge" but every time I reinstall it it knows where the torrents are, etc, so am I missing a config file somewhere?

Any help would be appreciated because this is really annoying!! Thanks Guys.

P.S. I hope this made sense.

asininity 10-28-2007 04:18 PM

Nevermind sorry to bother you guys found the solution cheers.

ConfidentiaL 10-30-2007 07:12 PM

Would you care sharing the solution with us/me? :P I have the same problem...

asininity 12-06-2007 04:48 PM

Sorry for slow reply hope you've already found the solution but in case you haven't all you have to do is make sure you can view your hidden files and go to /home/username/.config/deluge and delete the "persistant.state" file which has been corrupted somehow a new one will be generated as the program starts. Note that you will have to go to /home/username/.config/deluge/torrentfiles and doubleclick on the torrents you had running because the persistant.state file holds the data for what torrents where running.

Hope this helps.


All times are GMT -5. The time now is 12:14 PM.