LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Deleting libreoffice-base (https://www.linuxquestions.org/questions/linux-software-2/deleting-libreoffice-base-4175513439/)

Adler 08-05-2014 02:52 AM

Deleting libreoffice-base
 
Hi All,

On my way to upgrading to libreoffice4.3 I've run into an issue. I'm running a perfetly great linux box w/ Linux Mint 17 64-bit. Here is my issue:

adler@adler-HP-Spectre-XT-Ultrabook-PC ~ $ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
libreoffice-base
The following packages will be upgraded:
xserver-xorg-video-intel
1 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0 B/1,433 kB of archives.
After this operation, 6,595 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 243818 files and directories currently installed.)
Removing libreoffice-base (1:4.3.0-0ubuntu1~trusty1) ...
No diversion 'diversion of /usr/lib/libreoffice/share/basic/dialog.xlc to /usr/lib/libreoffice/share/basic/dialog.xlc.noaccess by libreoffice-base', none removed.
No diversion 'diversion of /usr/lib/libreoffice/share/basic/script.xlc to /usr/lib/libreoffice/share/basic/script.xlc.noaccess by libreoffice-base', none removed.
/var/lib/dpkg/info/libreoffice-base.postrm: 28: /var/lib/dpkg/info/libreoffice-base.postrm: Syntax error: end of file unexpected (expecting "fi")
dpkg: error processing package libreoffice-base (--remove):
subprocess installed post-removal script returned error exit status 2
Errors were encountered while processing:
libreoffice-base
E: Sub-process /usr/bin/dpkg returned an error code (1)
adler@adler-HP-Spectre-XT-Ultrabook-PC ~ $

All in all, this has gummed up my system.

Any help would be appreciated in deleting libreoffice-base. TIA.

bigrigdriver 08-05-2014 11:42 AM

You could try:

sudo dpkg purge libreoffice-base

or

sudo apt-get purge libreoffice-base

If that works properly, then run sudo apt-get update followed by sudo apt-get install libreoffice-base=4.3 (to install the 4.3 version).

Adler 08-06-2014 02:25 PM

bigrigdriver,

Thanks for the reply. I had in fact tried those commands.

What did work is:

mv /var/lib/dpkg/info/libreoffice-base.* /tmp/
dpkg --remove --force-remove-reinstreq libreoffice-base

I guess this thread can be marked as solved. I am now running Libreoffice 4.3.


All times are GMT -5. The time now is 08:18 PM.