-   Linux - Software (
-   -   Deja-Dup 18.2.1/FC15/x86_64 Backup failed with message about missing tmp file (

Doug Hutcheson 09-02-2011 11:40 PM

Deja-Dup 18.2.1/FC15/x86_64 Backup failed with message about missing tmp file
I have recently upgraded from FC14 to FC15. Under FC14, I successfully ran deja-dup backups of my (large) home directory. Under FC15, I was able to restore my /home successfully.

I just tried to create a full system backup to a 1Tb external drive mounted under /media/[drive name]/[directory which exists] (excluding the obvious candidates like /media, /proc, /dev, ...), running deja-dup from a command line as root. After performing the full system scan, it started creating backup files in the target directory, up to and including an archive file named "duplicity-full.20110903T030853Z.vol46.difftar.gz", but crashed with the following message:

Backup location /tmp/duplicity-adH0ZV-tempdir/mktemp-su5dbi-49 does not exist.
I have 2Gb RAM and 34Gb+ free in /tmp, 500Gb+ free on the target drive. The duplicity-full* files are only 30Mb each, so it is hard to see how it could be a problem with memory or disk.

Any ideas, folks? Is deja-dup not up to the task?

John VV 09-02-2011 11:53 PM

This is an upgrade ? right
did you use preupgrade ?
insert the dvd and upgrade form the dvd
or the recommended reformat and a new clean install

if not a new install
make a new user account to remove all the fedora 14 garbage settings leftover

if that dose not work then uninstall the leftover fedora 14 rpms and replace them with the fedora 15 rpms

rpm -qa | grep fc14
for a list of still installed fedora 14 packages

Doug Hutcheson 09-03-2011 12:08 AM

Hi John VV.

I should have been clearer: I did the upgrade by starting with a full format and clean install of FC15, then restored my /home from a deja-vu backup.

John VV 09-03-2011 01:55 AM


then restored my /home from a deja-vu backup.

you are using settings for fedora 14
15 changed a lot of things

it is RECOMMENDED to manually mover settings
the old ones might be incompatible with the new

I never saved any settings in my home folder only documents and non system files

i am betting that the fedora 15 is using settings for fedora 14

you should have a hidden folder called something like ".deja-vu" ( dot deja-vu )
rename it to ".deja-vu-old" and launch the program

Doug Hutcheson 09-03-2011 05:18 AM

John VV, I'm not sure that applies here. I previously used deja-dup as user 'doug', but the problem is occurring when I run it as root. This is the first time I have used it as root, so there should not have been any trace of deja-dup in /root, I would have thought.

I found /root/.cache/deja-dup as a directory, so renamed it as you suggested, erased the incomplete backup from the external drive and ran the application again. Something is being recorded somewhere other than .cache/deja-dup, because it 'remembered' the target directory for the backup I attempted earlier. This time, the backup ran to successful completion after several hours.

Result: I do not know why it failed, but clearing out the target directory and renaming /root/.cache/deja-dup allowed a fresh attempt to work.

Thanks for your advice.

All times are GMT -5. The time now is 06:49 PM.