LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-30-2015, 07:12 PM   #1
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Costa Rica
Distribution: Kubuntu, Debian, Knoppix
Posts: 2,092
Blog Entries: 1

Rep: Reputation: 90
debian testing - how to set up rd-bomb as screensaver on kde?


Hi!

I installed the xscreensaver-data-extra package on debian testing (kde) and when I go into system settings to set rd-bomb as the screen saver, it's not available (well.... I think that only a small selection of hacks are available). How can I enable rd-bomb to show up on the list? Or even better, how can I enable them ALL to show up on the list?

Code:
$ dpkg -l '*xscreensaver*'
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                       Version                    Architecture               Description
+++-==========================================-==========================-==========================-=========================================================================================
ii  xscreensaver                               5.30-1+b1                  amd64                      Screensaver daemon and frontend for X11
ii  xscreensaver-data                          5.30-1+b1                  amd64                      Screen saver modules for screensaver frontends
ii  xscreensaver-data-extra                    5.30-1+b1                  amd64                      Extra screen saver modules for screensaver frontends
ii  xscreensaver-gl                            5.30-1+b1                  amd64                      GL(Mesa) screen saver modules for screensaver frontends
ii  xscreensaver-gl-extra                      5.30-1+b1                  amd64                      Extra GL(Mesa) screen saver modules for screensaver frontends
un  xscreensaver-gnome                         <none>                     <none>                     (no description available)
un  xscreensaver-nognome                       <none>                     <none>                     (no description available)
Thanks in advance.
 
Old 04-30-2015, 10:25 PM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,627

Rep: Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651
??? testing ???

so the very new alpha 8.1

8 is out so testing is now the NEW version


with 8 just coming out i would not expect many things yet in the 8.1 testing yet
 
Old 05-01-2015, 09:05 AM   #3
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Costa Rica
Distribution: Kubuntu, Debian, Knoppix
Posts: 2,092

Original Poster
Blog Entries: 1

Rep: Reputation: 90
Yes, testing.... I'll keep on rolling on top of it (installed 'testing' on monday when I got my new computer). Anyway, they are so close right now that you'll probably see the same thing on jessie.
 
Old 05-01-2015, 10:20 AM   #4
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Costa Rica
Distribution: Kubuntu, Debian, Knoppix
Posts: 2,092

Original Poster
Blog Entries: 1

Rep: Reputation: 90
Not exactly what I needed but I'll give it a shot to see if it's usable:

From xscreensaver man page:
Code:
USING KDE
       Like GNOME, KDE also decided to invent their own screen saver framework from scratch instead of simply using xscreensaver.  To replace the KDE screen saver  with  xscreensaver,  do
       the following:

           1: Turn off KDE's screen saver.
              Open the "Control Center" and select the "Appearance & Themes / Screensaver" page.  Un-check "Start Automatically".

           2: Find your Autostart directory.
              Open the "System Administration / Paths" page, and see what your "Autostart path" is set to: it will probably be ~/.kde/Autostart/ or something similar.

           3: Make xscreensaver be an Autostart program.
              Create a .desktop file in your autostart directory called xscreensaver.desktop that contains the following five lines:

              [Desktop Entry]
              Exec=xscreensaver
              Name=XScreenSaver
              Type=Application
              X-KDE-StartupNotify=false

           4: Make the various "lock session" buttons call xscreensaver.
              The  file  you  want  to  replace  next  has moved around over the years. It might be called /usr/libexec/kde4/kscreenlocker, or it might be called "kdesktop_lock" or "krun
              ner_lock" or "kscreenlocker_greet", and it might be in /usr/lib/kde4/libexec/ or in /usr/kde/3.5/bin/ or even in /usr/bin/, depending on the distro and phase  of  the  moon.
              Replace the contents of that file with these two lines:

              #!/bin/sh
              xscreensaver-command -lock

              Make sure the file is executable (chmod a+x).

       Now use xscreensaver normally, controlling it via the usual xscreensaver-demo(1) and xscreensaver-command(1) mechanisms.
 
Old 05-01-2015, 10:51 AM   #5
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Costa Rica
Distribution: Kubuntu, Debian, Knoppix
Posts: 2,092

Original Poster
Blog Entries: 1

Rep: Reputation: 90
Well.... apparently, I'll be able to live with that... let's give it some time to see if it's not just an illusion.
 
  


Reply

Tags
kde, rd-bomb, rdbomb, xscreensaver


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Random X Freezes, Debian Testing/KDE nicklaszlo Linux - Software 8 02-14-2010 11:16 PM
debian lenny or testing (for KDE 4.3)? pusrob Debian 6 08-11-2009 08:09 PM
KDE 4.3 in debian testing: when? pusrob Linux - General 2 08-04-2009 09:08 AM
KDE (system) notifications not working (KDE 3.5.8)(Debian:Testing Branch)) kevinbenko Linux - Desktop 2 03-30-2008 12:15 PM
Gnome menu mixed with KDE in Debian Testing Underhill Debian 1 09-14-2005 06:15 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration