LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Debian Squeeze - Can't Install New Packages, nb pdf reader/viewer (https://www.linuxquestions.org/questions/linux-software-2/debian-squeeze-cant-install-new-packages-nb-pdf-reader-viewer-896462/)

ahalin 08-09-2011 09:40 PM

Debian Squeeze - Can't Install New Packages, nb pdf reader/viewer
 
Dear Forum,

I am new to Debian but a long term user of various other Linux distros, most commonly Ubuntu at home and Xubuntu for my old work computer. I tried Debian 6 LXDE the other day on the older PC, from a live LXF disc. It picked up all my hardware automatically and was so stable (more so than the Xubuntu LXDE distro on the HD) that I decided to install it.

Now that it is on the HD it is still very stable, but I am struggling with package management.

I am fairly comfortable with the CLI and have managed to get myself into the sudoers group, install grub and add the old Xubuntu to grub manually (I was not impressed that Debian didn't pick up the other two distros on the machine, even after a grub install and update grub and all the other tricks I could think of).

Anyway, back to package mngt:

First, why is there no pdf viewer/reader by default? How do you start building if you can't read the many helpful articles in pdf?

But more anoying, when I try to install pdfedit, epdfview, evince, okular, pdf-viewer, osso-pdf-viewer or kpdf (at least one of which MUST work in Debian LXDE) using "apt-get install" or "aptitude install", as root or as sudo in the Terminal, why do I get "Couldn't find any package whose name or description matched" "Couldn't find package" or "Unable to locate package"?????????????? I can't even install synaptic to help!

Then I found that my sources.lst only listed the install CD as a repository (how stupid is that?) so added some repositories to it (eg deb http://ftp.debian.org/debian/ squeeze main contrib non-free) and did a sudo apt-get update. And apt STILL can't find anything.

And what is that Debian Installer in the >Menu>System Tools? It asks for a password then nothing opens that I can detect. Is there a GUI for package mngt?

EDDY1 08-09-2011 10:57 PM

Did you comment out the cd with a #?

the trooper 08-10-2011 07:57 AM

Quote:

First, why is there no pdf viewer/reader by default?
Because you installed Lxde,which aims to be a fairly minimal desktop environment.

You'll need to post the output of cat /etc/apt/sources.list.
Everything you need is in the Debian repositories.

EmaRsk 08-10-2011 10:01 AM

Did you update the package lists?

Use
Code:

sudo aptitude update
or
Code:

sudo apt-get update
or (my favourite) use aptitude in interactive mode:
Code:

sudo aptitude
and then hit "u" to update the lists.

Then try again to install what you want.

ahalin 08-11-2011 04:59 AM

Thanks for your help.

No, did not comment out (#) the CD, but deleted it (I know, smarter to just hash it) and played around some more with the sources list, updated, and good to go. If I had just commented the CD out would apt have looked at web repositories, even without adding them to sources.lst?

I must write to LXF, because it seems a bit silly to make it so hard to, as you must, add to a minimalist distro. In this day and age I believe a pdf reader is a must in any distro and I think even Puppy and DSL have them by default. But just my opinion!

Anyway, Debian 6 still stable as a rock and got the few essential extras I needed so happy enough.

Thanks again!

EDDY1 08-15-2011 12:37 AM

Quote:

No, did not comment out (#) the CD, but deleted it (I know, smarter to just hash it) and played around some more with the sources list, updated, and good to go. If I had just commented the CD out would apt have looked at web repositories, even without adding them to sources.lst?
No it would overlook commented out repos.

knudfl 08-15-2011 02:23 AM

Quote:

I must write to LXF
It is not an LXF made version. Debian 6 LXDE is included in (all) Debian mirrors.

6.0.1-live ftp://ftp.mirrorservice.org/sites/cd...cd/6.0.1-live/

i386 ftp://ftp.mirrorservice.org/sites/cd...e/i386/bt-hdd/

amd64 ftp://ftp.mirrorservice.org/sites/cd.../amd64/bt-hdd/

..


All times are GMT -5. The time now is 02:56 PM.