LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-29-2016, 08:08 PM   #1
jjd3592
LQ Newbie
 
Registered: Feb 2016
Posts: 5

Rep: Reputation: Disabled
Debian Jessie - Have Pulseaudio and ALSA installed. Everything is unmuted and settings show sound outputting but no sound actually playing.


I just installed Debian 8.3 (Jessie) on my computer. I'm using my default motherboard sound card which is an HDA Intel PCH and the chip is Realtek ALC1150. Everything in the settings->sound panel appears correctly. When I plug in my headphones, the headphones output pops up and if I play a youtube video or a default ALSA sound, it pops up in the "applications" tab as playing. However nothing actually comes through my headphones.

Everything is unmuted and I have been spending a lot of time messing with the configuration. The correct card is default for both ALSA and Pulseaudio. I'm a little lost on where to go from here.

Even just doing a simple test with aplay does not output any sound. I entered:

aplay /usr/share/sound/alsa/From_Center.wav

it says in the command line it is playing, but I can't hear anything out of my headphones.
 
Old 03-01-2016, 12:37 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,908

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
I had the same problem when I installed Wheezy. I finally solved my problem when I installed pavucontrol (pulseaudio volume control), which is not installed when pulseaudio is installed (on Wheezy).

My suggestion is to check to see that you have pavucontrol installed, then run it.
 
Old 03-01-2016, 01:20 PM   #3
sgosnell
Senior Member
 
Registered: Jan 2008
Location: Baja Oklahoma
Distribution: Debian
Posts: 1,054

Rep: Reputation: 281Reputation: 281Reputation: 281
I agree with installing pavucontrol. Pulseaudio is unintuitive, and can be difficult to configure without it. You need to check the output devices tab and see what it sees, and configure them properly, with the proper device set as default and not muted there. Then play something and check the playback tab and see what is there.
 
Old 03-01-2016, 03:35 PM   #4
norobro
Member
 
Registered: Feb 2006
Distribution: Debian Sid
Posts: 792

Rep: Reputation: 329Reputation: 329Reputation: 329Reputation: 329
I recently had the same problem and tried all kinds of proposed solutions including the above. What finally worked for me was executing:
Code:
$ alsactl init
Don't know if the sound starting to work was the result of the cumulative changes or not as I haven't done another install since. Give it a try and post back.
 
Old 03-01-2016, 06:36 PM   #5
jjd3592
LQ Newbie
 
Registered: Feb 2016
Posts: 5

Original Poster
Rep: Reputation: Disabled
All, thanks for the responses. I tried installing pavucontrol as mentioned, it was not already installed. Then I launched the application. I noticed in the "playback" tab that the system sounds were muted. So I increased the volume there. Then the output devices showed my graphics card (Radeon HDMI) as the first device. I removed that and now only the built-in analog stereo is showing. With the port drop down box showing "headphones."

Everything looks good. I see the sound bar again increase when I play a sound or adjust the volume, but nothing from my headphones. I know that the headphones work. No doubt about it. The connection must be good since it detects when the headphones are actually plugged in.

There are a multitude of options in configuration for the built in audio. The profile I selected was "Analog Stereo Output" which I think is correct?


Also norobro, I tried to do
Code:
alsactl init
and it looks like it ran fine here is what it output:

Code:
Found hardware: "HDA-Intel" "Realtek ALC1150" "HDA:10ec0900,1462d968,00100001" "0x1462" "0xd968"
Hardware is initialized using a generic method
 
Old 03-02-2016, 01:55 PM   #6
sgosnell
Senior Member
 
Registered: Jan 2008
Location: Baja Oklahoma
Distribution: Debian
Posts: 1,054

Rep: Reputation: 281Reputation: 281Reputation: 281
HDMI involves audio as well as video. You may need to re-enable that, I'm not sure where the audio is being sent. But the built-in audio should be the headphones, although I'm not sure. I can't see your computer. Analog Stereo out should be the correct profile. YOu don't need to enable system sounds, those are just the beeps and sounds for stuff like connecting drives, etc. That has nothing to do with audio playback.

Are your headphones plugged into the Realtek card directly? Are you sure the jack isn't damaged?
 
Old 03-02-2016, 07:26 PM   #7
jjd3592
LQ Newbie
 
Registered: Feb 2016
Posts: 5

Original Poster
Rep: Reputation: Disabled
I'm pretty sure the jack isn't damaged, the same result happens when I put it in the back channel jack, which is directly connected to the motherboard. Also is it okay if only system sounds is showing in the playback panel? Should anything else show?
 
Old 03-02-2016, 09:44 PM   #8
sgosnell
Senior Member
 
Registered: Jan 2008
Location: Baja Oklahoma
Distribution: Debian
Posts: 1,054

Rep: Reputation: 281Reputation: 281Reputation: 281
Only what is being played should show there. If nothing is playing, nothing shows. When playback starts, it should show up there. If nothing shows there, then pulseaudio doesn't know about it, and you'll hear nothing.
 
Old 03-03-2016, 12:34 AM   #9
aus9
LQ Addict
 
Registered: Oct 2003
Location: Australia
Distribution: MX 18/ TC64
Posts: 5,301

Rep: Reputation: Disabled
alsactl init is only usefule to initialize the first card that alsa detects and you have yet to reveal it.

pls show
Code:
aplay -L
aplay -l
I would not be surprised if hdmi is the first card detected. Leaping ahead if you find that is the case, and assuming you need the inbuilt card....then here is one way to swap it ....full reboot to test the aplay commands

/etc/modprobe.d/alsa-base.conf

(remove any intel entries and have this as last entry pls)
Quote:
options snd_hda_intel index=1
again....this is to swap the inbuilt for the hdmi so inbuilt grabs index=0 on reboot
another way of checking your index values is just run

Code:
alsamixer
which means alsamixer -c 0

if hdmi shows then hdmi is currently index=0

let me know if I have confused you?
 
Old 03-03-2016, 07:45 AM   #10
seasons
Member
 
Registered: Dec 2014
Distribution: siduction
Posts: 259

Rep: Reputation: 57
Give more detailed info from alsa-info: http://www.alsa-project.org/main/ind.../Help_To_Debug

Quote:
options snd_hda_intel index=1
That's not going to work. The onboard audio (Realtek ALC1150) uses the same snd-hda-intel module. There are ways to accomplish what you want, but let's see the alsa info first to see if we need to go down that road.
 
Old 03-03-2016, 06:54 PM   #11
aus9
LQ Addict
 
Registered: Oct 2003
Location: Australia
Distribution: MX 18/ TC64
Posts: 5,301

Rep: Reputation: Disabled
@seasons I don't have his hw but I do have same module for hdmi and analog

We all learn here so don't let me stop you from offering useful info in the future ...

Quote:
That's not going to work.
I can assure it works for me and here is proof....first I comment out my index mod reboot to get changed cards then fix up.

Quote:
cat /etc/modprobe.d/alsa-base.conf | grep hda
#options snd_hda_intel index=1

(reboot)
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 1: ALC887-VD Digital [ALC887-VD Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

(change mod back to my correct index value and reboot)

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC887-VD Digital [ALC887-VD Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
To the Original Poster....sorry about that distraction but you have yet to reply.

I like to keep it simple....if you agree I know what I am talking about continue with my requests but if you believe you need to provide even more information then seasons request for a link to your alsa info is also fine.

I still suspect your index=0 card is hdmi and a simple swap will fix your issues.

I could be wrong tho.

Last edited by aus9; 03-03-2016 at 06:58 PM.
 
Old 03-07-2016, 02:34 AM   #12
seasons
Member
 
Registered: Dec 2014
Distribution: siduction
Posts: 259

Rep: Reputation: 57
Quote:
Originally Posted by aus9 View Post
@seasons I don't have his hw but I do have same module for hdmi and analog
We all learn here so don't let me stop you from offering useful info in the future ...
My apologies. I stand corrected. I'm just wondering why that changes the indices when both devices use the same module :?
 
Old 03-07-2016, 07:10 AM   #13
aus9
LQ Addict
 
Registered: Oct 2003
Location: Australia
Distribution: MX 18/ TC64
Posts: 5,301

Rep: Reputation: Disabled
no problems but I have scared off the original poster.

ahh well

Alsa counts devices by index which is another way of saying it counts devices.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian 8 PulseAudio/Alsa Mic picking up no sound glinkels Linux - Newbie 9 08-21-2015 07:20 PM
[SOLVED] My sound card is not being detected by Debian 8 (Alsa and Pulseaudio) glinkels Linux - Newbie 8 08-08-2015 01:23 PM
Alsa not outputting sound TheStarLion Debian 1 04-03-2013 09:45 AM
Alsa device recognized (and unmuted!) but won't play sound Kevschef Linux - Hardware 6 11-08-2006 11:26 AM
no sound with ALSA, 2.6.1 kernel, intel8x0 (unmuted) hope Linux - Hardware 8 01-22-2004 04:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration