LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-30-2014, 03:12 AM   #16
descendant_command
Senior Member
 
Registered: Mar 2012
Posts: 1,878

Rep: Reputation: 644Reputation: 644Reputation: 644Reputation: 644Reputation: 644Reputation: 644

Looks like you are mixing stable and testing.
That generally ends badly - especially where the core libs get involved.

What is the output of:
Code:
apt-cache policy libc6 libc6-i386

Last edited by descendant_command; 06-30-2014 at 03:16 AM.
 
1 members found this post helpful.
Old 06-30-2014, 03:35 AM   #17
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and CentOS
Posts: 6,725

Rep: Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705
Hi,
Quote:
Originally Posted by descendant_command View Post
Looks like you are mixing stable and testing.
How could you tell? Did you cross check the version numbers of the various packages from the apt-get output?

Quote:
Originally Posted by descendant_command View Post
That generally ends badly - especially where the core libs get involved.
Sure does.

Evo2.
 
Old 06-30-2014, 04:04 AM   #18
descendant_command
Senior Member
 
Registered: Mar 2012
Posts: 1,878

Rep: Reputation: 644Reputation: 644Reputation: 644Reputation: 644Reputation: 644Reputation: 644
Quote:
Originally Posted by evo2 View Post
Hi,

How could you tell? Did you cross check the version numbers of the various packages from the apt-get output?
Only this one
Quote:
Originally Posted by pan64 View Post
The following packages have unmet dependencies:
libc6-i386 : Depends: libc6 (= 2.13-38+deb7u1) but 2.18-4 is to be installed
The libc6-i386 he is installing is the wheezy one, as it is requiring the wheezy libc6 - however 2.18-4 (presumably a previous testing version - current is 2.19-4) "is to be installed".

I think "is to be installed" can also mean "is already installed", and means that either the sources.list is pointing to jessie/testing as well as stable or (more likely) a package from testing has been installed which pulled in the updated libc6, and the testing repo has subsequently been disabled again.

The "best" way out is probably to update the entire system to jessie (or restore from a pre-bork backup or just reinstall - depending on the role of the machine), as this is going to be a recurring problem with every package install/upgrade.

Last edited by descendant_command; 06-30-2014 at 04:23 AM.
 
Old 06-30-2014, 04:54 AM   #19
pan64
LQ Addict
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 22,253

Original Poster
Rep: Reputation: 7419Reputation: 7419Reputation: 7419Reputation: 7419Reputation: 7419Reputation: 7419Reputation: 7419Reputation: 7419Reputation: 7419Reputation: 7419Reputation: 7419
As far as I remember I needed to install a newer compiler, but nothing else. Otherwise it is the latest stable. No jessie, probably backport was in use. I have no backup, I will simply reinstall if needed (that would be much faster)
Just a bit strange: first installing multiarch together with i386 and finally upgrade libc6 should work, but this way cannot be handled.
 
Old 06-30-2014, 05:37 AM   #20
descendant_command
Senior Member
 
Registered: Mar 2012
Posts: 1,878

Rep: Reputation: 644Reputation: 644Reputation: 644Reputation: 644Reputation: 644Reputation: 644
Quote:
Originally Posted by pan64 View Post
As far as I remember I needed to install a newer compiler, but nothing else. Otherwise it is the latest stable. No jessie, probably backport was in use. I have no backup, I will simply reinstall if needed (that would be much faster)
Just a bit strange: first installing multiarch together with i386 and finally upgrade libc6 should work, but this way cannot be handled.
The problem is you started with an already broken system, with the 'out of branch' libc6.

Presumably came along with this:
Quote:
I needed to install a newer compiler
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Install OpenSUSE 32 bit and CentOS 64 bit in Dualboot Mode GMaK007 Linux - Newbie 7 10-25-2013 06:04 AM
[SOLVED] Compilation of library in 32 bit mode on 64 bit servers gaurav.rustagi Programming 2 01-25-2012 05:43 AM
[SOLVED] building shared libary in 32 bit mode on 64 bit machine using -m32 option gaurav.rustagi Linux - Software 3 01-24-2012 09:03 AM
[SOLVED] building shared libary in 32 bit mode on 64 bit machine using -m32 option gaurav.rustagi Linux - Newbie 1 01-24-2012 07:54 AM
Displaying 8-bit images in 24-bit mode and vice versa yrraja Linux - General 4 04-29-2003 11:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration